registry: Use manually written .pc file.
authorJelmer Vernooij <jelmer@samba.org>
Tue, 22 Jan 2008 17:28:51 +0000 (18:28 +0100)
committerJelmer Vernooij <jelmer@samba.org>
Tue, 22 Jan 2008 17:28:51 +0000 (18:28 +0100)
source/configure.ac
source/lib/registry/config.mk
source/lib/registry/registry.pc.in [new file with mode: 0644]

index 882bd28d00185052ba16f4476b1bd84bdf3f2ca2..59a21375f65d0376f08d9c595e974a29adbc89b7 100644 (file)
@@ -27,6 +27,8 @@ m4_include(lib/charset/config.m4)
 m4_include(lib/socket/config.m4)
 m4_include(nsswitch/nsstest.m4)
 
+AC_OUTPUT(lib/registry/registry.pc)
+
 SMB_EXT_LIB_FROM_PKGCONFIG(LIBTALLOC, talloc >= 1.1.0,
        [],
        [
index f1f50479cbce66e5070bb5adaf55e6e876ba234a..a7365a49ae0862f4deb25e888fe62496ad6cc5e4 100644 (file)
@@ -18,6 +18,7 @@ clean::
 # Start SUBSYSTEM registry
 [LIBRARY::registry]
 VERSION = 0.0.1
+PC_FILE = registry.pc
 SO_VERSION = 0
 DESCRIPTION = Windows-style registry library
 OBJ_FILES = \
diff --git a/source/lib/registry/registry.pc.in b/source/lib/registry/registry.pc.in
new file mode 100644 (file)
index 0000000..21184c4
--- /dev/null
@@ -0,0 +1,12 @@
+prefix=@prefix@
+exec_prefix=@exec_prefix@
+libdir=@libdir@
+includedir=@includedir@
+
+Name: registry
+Description: Windows-style registry library
+Requires: ldb
+Requires.private: 
+Version: @PACKAGE_VERSION@
+Libs: -L${libdir} -lregistry 
+Cflags: -I${includedir}  -DHAVE_IMMEDIATE_STRUCTURES=1