r22046: Rever r22040, which breaks the build on FreeBSD 5.4 (BSD make).
authorJames Peach <jpeach@samba.org>
Mon, 2 Apr 2007 20:19:00 +0000 (20:19 +0000)
committerGerald (Jerry) Carter <jerry@samba.org>
Wed, 10 Oct 2007 19:49:45 +0000 (14:49 -0500)
source/main.mk

index fe7c1e57d86af90ac7adb4238d5b0ae24388ed47..1d6e4ea858f83139a629e81f3d02f2f245fb6434 100644 (file)
@@ -377,27 +377,23 @@ include/includes.d: include/includes.h
 # if it also exists. So better use $* which is foo/bar
 # and append .c manually to get foo/bar.c
 #
-# But if srcdir != builddir, $* does not contain the filename
-# that was found be traversing VPATH. So we are back to $<.
-#      -- jpeach
-#
 
 # Run a static analysis checker
 CHECK = $(CC_CHECKER) `$(PERL) $(srcdir)/script/cflags.pl $@` \
-    $(CFLAGS) $(PICFLAG) -c $< -o $@
+    $(CFLAGS) $(PICFLAG) -c $*.c -o $@
 
 # Run the configured compiler
 COMPILE = $(CC) `$(PERL) $(srcdir)/script/cflags.pl $@` \
-    $(CFLAGS) $(PICFLAG) -c $< -o $@
+    $(CFLAGS) $(PICFLAG) -c $*.c -o $@
 
 # Run the compiler for the build host
 HCOMPILE = $(HOSTCC) `$(PERL) $(srcdir)/script/cflags.pl $@` \
-    $(HOSTCC_CFLAGS) -c $< -o $@
+    $(HOSTCC_CFLAGS) -c $*.c -o $@
 
 # Precompile headers
 PCHCOMPILE = @$(CC) -Ilib/replace \
     `$(PERL) $(srcdir)/script/cflags.pl $@` \
-    $(CFLAGS) $(PICFLAG) -c $< -o $@
+    $(CFLAGS) $(PICFLAG) -c $*.c -o $@
 
 .c.o:
        @if test -n "$(CC_CHECKER)"; then \