r14380: Reduce the size of structs.h
authorJelmer Vernooij <jelmer@samba.org>
Tue, 14 Mar 2006 15:03:25 +0000 (15:03 +0000)
committerGerald (Jerry) Carter <jerry@samba.org>
Wed, 10 Oct 2007 18:57:16 +0000 (13:57 -0500)
57 files changed:
source/auth/auth_sam.c
source/auth/auth_util.c
source/auth/credentials/credentials.c
source/auth/credentials/credentials_ntlm.c
source/auth/gensec/gensec_gssapi.c
source/auth/gensec/gensec_krb5.c
source/auth/kerberos/kerberos.h
source/auth/ntlm_check.c
source/auth/ntlmssp/ntlmssp.h
source/auth/ntlmssp/ntlmssp_client.c
source/auth/ntlmssp/ntlmssp_server.c
source/dsdb/config.mk
source/dsdb/samdb/cracknames.c
source/dsdb/samdb/ldb_modules/password_hash.c
source/dsdb/samdb/samdb.h [new file with mode: 0644]
source/include/includes.h
source/include/structs.h
source/kdc/kpasswdd.c
source/lib/db_wrap.h
source/libcli/auth/libcli_auth.h [new file with mode: 0644]
source/libcli/auth/smbencrypt.c
source/libcli/cliconnect.c
source/libcli/composite/composite.h
source/libcli/libcli.h
source/libcli/smb_composite/sesssetup.c
source/libcli/smb_composite/smb_composite.h
source/libnet/libnet.h
source/libnet/libnet_join.h
source/libnet/libnet_passwd.c
source/libnet/libnet_vampire.c
source/librpc/rpc/dcerpc_schannel.c
source/nbt_server/wins/winsdb.h
source/ntptr/ntptr.h
source/ntvfs/ipc/vfs_ipc.c
source/ntvfs/ntvfs.h
source/rpc_server/common/common.h
source/rpc_server/common/server_info.c
source/rpc_server/common/share_info.c
source/rpc_server/dcerpc_server.h
source/rpc_server/lsa/dcesrv_lsa.c
source/rpc_server/netlogon/dcerpc_netlogon.c
source/rpc_server/samr/samr_password.c
source/rpc_server/unixinfo/dcesrv_unixinfo.c
source/scripting/ejs/smbcalls.h
source/smb_server/smb2/smb2_server.h
source/smbd/config.mk
source/smbd/process_model.h
source/smbd/server.c
source/smbd/service.h [new file with mode: 0644]
source/smbd/service_stream.h
source/smbd/service_task.h
source/utils/ntlm_auth.c
source/web_server/web_server.h
source/winbind/wb_async_helpers.c
source/winbind/wb_async_helpers.h
source/winbind/wb_pam_auth.c
source/winbind/wb_server.h

index db683fda790c1494a97e0287c67cde425a88af7c..0eff955c7162499e42a0f31ac5d0b236a7d7a324 100644 (file)
@@ -23,8 +23,8 @@
 #include "includes.h"
 #include "system/time.h"
 #include "auth/auth.h"
-#include "dsdb/samdb/samdb.h"
 #include "db_wrap.h"
+#include "dsdb/samdb/samdb.h"
 #include "libcli/security/proto.h"
 #include "libcli/ldap/ldap.h"
 
index 86f157334090b903e1da03d3c7810223e381f46e..fede2a278a721d6d5d71e512b45b621ab9238569 100644 (file)
@@ -25,7 +25,7 @@
 #include "includes.h"
 #include "auth/auth.h"
 #include "libcli/security/proto.h"
-#include "libcli/auth/proto.h"
+#include "libcli/auth/libcli_auth.h"
 
 /* this default function can be used by mostly all backends
  * which don't want to set a challlenge
index 4162c2a10a15a12f193e80100f637577936f360e..01a00c3dfcd0121f1501a90a2ba19f31c49d3797 100644 (file)
@@ -25,7 +25,7 @@
 #include "includes.h"
 #include "librpc/gen_ndr/ndr_samr.h" /* for struct samrPassword */
 #include "auth/gensec/gensec.h"
-#include "libcli/auth/proto.h"
+#include "libcli/auth/libcli_auth.h"
 
 /**
  * Create a new credentials structure
index 768ed9bb3f930dbb31700c31210b9ec64604f492..67c73d2230a879e2f554f3fd26e0d802c8c99411 100644 (file)
@@ -25,8 +25,7 @@
 #include "includes.h"
 #include "librpc/gen_ndr/ndr_samr.h" /* for struct samrPassword */
 #include "lib/crypto/crypto.h"
-#include "auth/credentials/credentials.h"
-#include "libcli/auth/proto.h"
+#include "libcli/auth/libcli_auth.h"
 
 void cli_credentials_get_ntlm_username_domain(struct cli_credentials *cred, TALLOC_CTX *mem_ctx, 
                                              const char **username, 
index 580b7a7be1bfeb11bfaba3356ec32b2355345310..a1f5dc118a833a61d06ff55478893b2ff5d40d98 100644 (file)
@@ -27,6 +27,7 @@
 #include "auth/kerberos/kerberos.h"
 #include "librpc/gen_ndr/ndr_krb5pac.h"
 #include "auth/auth.h"
+#include "ldb.h"
 #include "auth/auth_sam.h"
 
 enum gensec_gssapi_sasl_state 
index 200822655d1b251c31166df785539db49dd02a19..030c6f04f8db5f89875f05927bb264593ec434b1 100644 (file)
@@ -29,6 +29,7 @@
 #include "auth/kerberos/kerberos.h"
 #include "librpc/gen_ndr/ndr_krb5pac.h"
 #include "auth/auth.h"
+#include "ldb.h"
 #include "auth/auth_sam.h"
 #include "system/network.h"
 #include "lib/socket/socket.h"
index d8f615562032d8392b80eb6118fa03251e0eff63..97505357bee116db0a1b3f465c12392d8674e2d6 100644 (file)
@@ -23,6 +23,9 @@
 
 #include "auth/credentials/credentials.h"
 #include "auth/kerberos/krb5_init_context.h"
+#include "librpc/gen_ndr/krb5pac.h"
+
+struct auth_serversupplied_info;
 
 struct ccache_container {
        struct smb_krb5_context *smb_krb5_context;
index cea6eeafc13b46df870cd0d8ae24d59c52c264a7..61edcade346813515095209c2772d8a9825d91cc 100644 (file)
@@ -23,8 +23,7 @@
 #include "includes.h"
 #include "lib/crypto/crypto.h"
 #include "librpc/gen_ndr/ndr_netlogon.h"
-#include "auth/credentials/credentials.h"
-#include "libcli/auth/proto.h"
+#include "libcli/auth/libcli_auth.h"
 
 /****************************************************************************
  Core of smb password checking routine.
index 721d05149e06696daae6ad1c650c9825f90382ee..13d89c2db6567027dcd4bbabbfd8fadebfd6fcda 100644 (file)
@@ -185,4 +185,5 @@ struct gensec_ntlmssp_state
        struct auth_serversupplied_info *server_info;
 };
 
+struct auth_session_info;
 #include "auth/ntlmssp/proto.h"
index acb17330fbfbd4038031f3c4f44f027b2d62475e..79f62349a67a6b99e2934632c6af21501c6ddc7d 100644 (file)
@@ -27,7 +27,7 @@
 #include "auth/ntlmssp/ntlmssp.h"
 #include "auth/ntlmssp/msrpc_parse.h"
 #include "lib/crypto/crypto.h"
-#include "libcli/auth/proto.h"
+#include "libcli/auth/libcli_auth.h"
 
 /*********************************************************************
  Client side NTLMSSP
index 0598ff8f1dbbb741b69b4aa05910043067b2cab3..44f7fa8b8c84b95e879b018410c7a78549763437 100644 (file)
@@ -29,7 +29,7 @@
 #include "lib/crypto/crypto.h"
 #include "pstring.h"
 #include "system/filesys.h"
-#include "libcli/auth/proto.h"
+#include "libcli/auth/libcli_auth.h"
 
 /** 
  * Set a username on an NTLMSSP context - ensures it is talloc()ed 
index b1a00cc387d83357c713b962872cbcc4d9ba428b..ba8da697e89a634ec84de0bb4032796184ef7fbf 100644 (file)
@@ -5,7 +5,7 @@ include samdb/ldb_modules/config.mk
 ################################################
 # Start SUBSYSTEM SAMDB
 [SUBSYSTEM::SAMDB]
-PRIVATE_PROTO_HEADER = samdb/samdb.h
+PRIVATE_PROTO_HEADER = samdb/samdb_proto.h
 REQUIRED_SUBSYSTEMS = DB_WRAP LIBCLI_LDAP
 OBJ_FILES = \
                samdb/samdb.o \
index 66cd3fcbe0f53c485acedb09cf305d5888693100..889995ecb530721420790a5b63a6d8400b95feea 100644 (file)
 #include "lib/ldb/include/ldb_errors.h"
 #include "system/kerberos.h"
 #include "auth/kerberos/kerberos.h"
-#include "dsdb/samdb/samdb.h"
 #include "libcli/ldap/ldap.h"
 #include "libcli/security/proto.h"
 #include "auth/auth.h"
 #include "db_wrap.h"
+#include "dsdb/samdb/samdb.h"
 
 static WERROR DsCrackNameOneFilter(struct ldb_context *sam_ctx, TALLOC_CTX *mem_ctx,
                                   struct smb_krb5_context *smb_krb5_context,
index 6943a5f3563eefe0366957d54aa1136789fe95fa..32d226b2b7e1fc4d2884252d1d3c8fb23be0ffc6 100644 (file)
@@ -36,8 +36,7 @@
 #include "ldb/include/ldb_private.h"
 #include "librpc/gen_ndr/ndr_misc.h"
 #include "librpc/gen_ndr/ndr_samr.h"
-#include "auth/credentials/credentials.h"
-#include "libcli/auth/proto.h"
+#include "libcli/auth/libcli_auth.h"
 #include "system/kerberos.h"
 #include "auth/kerberos/kerberos.h"
 #include "system/time.h"
diff --git a/source/dsdb/samdb/samdb.h b/source/dsdb/samdb/samdb.h
new file mode 100644 (file)
index 0000000..886dc6a
--- /dev/null
@@ -0,0 +1,32 @@
+/* 
+   Unix SMB/CIFS implementation.
+
+   interface functions for the sam database
+
+   Copyright (C) Andrew Tridgell 2004
+   
+   This program is free software; you can redistribute it and/or modify
+   it under the terms of the GNU General Public License as published by
+   the Free Software Foundation; either version 2 of the License, or
+   (at your option) any later version.
+   
+   This program is distributed in the hope that it will be useful,
+   but WITHOUT ANY WARRANTY; without even the implied warranty of
+   MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+   GNU General Public License for more details.
+   
+   You should have received a copy of the GNU General Public License
+   along with this program; if not, write to the Free Software
+   Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+*/
+
+#ifndef __SAMDB_H__
+#define __SAMDB_H__
+
+struct auth_session_info;
+struct drsuapi_DsNameInfo1;
+
+#include "ldb.h"
+#include "dsdb/samdb/samdb_proto.h"
+
+#endif /* __SAMDB_H__ */
index 4ff67791f9a58462dc3306f0e8b4a32de48a7868..1a2ff68359c201be5e3e70498de293dd40806b15 100644 (file)
@@ -122,11 +122,7 @@ enum brl_type {
 #include "libcli/nbt/libnbt.h"
 #include "libcli/util/proto.h"
 
-#undef _PRINTF_ATTRIBUTE
-#define _PRINTF_ATTRIBUTE(a1, a2)
-
 /* String routines */
-
 #include "util/safe_string.h"
 
 #if 0
index 124d97f493111c0cc7d100d53e59ba6ef8a650d5..19a811da9fa0d70001b4bcb0a0cdf52b43252991 100644 (file)
   "scope is only this definition or declaration" warning
 */
 
-struct spoolss_EnumPrinters;
-struct spoolss_EnumForms;
-struct spoolss_EnumJobs;
-struct spoolss_EnumPrinterDrivers;
-struct spoolss_EnumPorts;
-struct spoolss_EnumMonitors;
-struct spoolss_EnumPrintProcessors;
-union spoolss_PrinterInfo;
-union spoolss_JobInfo;
-union spoolss_DriverInfo;
-union spoolss_FormInfo;
-union spoolss_PortInfo;
-union spoolss_MonitorInfo;
-union spoolss_PrintProcessorInfo;
-
-struct spoolss_GetPrinterData;
-struct spoolss_SetPrinterData;
-
-struct spoolss_DeviceMode;
-
-struct drsuapi_DsNameInfo1;
-struct drsuapi_DsCrackNames;
-struct drsuapi_DsReplicaObjectListItem;
-struct drsuapi_DsReplicaObjectListItemEx;
-
-struct DsPrivate;
-
-struct PAC_LOGON_INFO;
-struct PAC_DATA;
-struct PAC_BUFFER;
-
-struct samr_ChangePasswordUser;
-struct samr_OemChangePasswordUser2;
-struct samr_ChangePasswordUser3;
-struct samr_ChangePasswordUser2;
-struct samr_CryptPassword;
-struct samr_CryptPasswordEx;
-struct samr_DomInfo1;
-
-struct netr_Credential;
-struct netr_Authenticator;
-union netr_Validation;
-
-struct iface_struct;
-
-struct utimbuf;
-
-struct auth_serversupplied_info;
-struct auth_session_info;
-
-struct spnego_data;
-struct gensec_ntlmssp_state;
-
 struct asn1_data;
-
-struct ldapsrv_call;
-struct ldapsrv_connection;
-struct ldap_connection;
-
-struct rap_NetShareEnum;
-struct rap_NetServerEnum2;
-
 struct smbsrv_tcon;
 struct smbsrv_connection;
-
-struct smbsrv_request;
-
-struct ntvfs_module_context;
-
-struct dcesrv_context;
-struct dcesrv_call_state;
-
-struct libnet_context;
-struct libnet_JoinDomain;
-
-struct clilist_file_info;
-
-struct netr_LMSessionKey;
-
-struct ldb_dn;
-struct ldb_message;
-struct ldb_context;
-struct ldb_parse_tree;
-
-struct lsa_RightSet;
-
-struct irpc_request;
-
-struct smb_composite_loadfile;
-struct smb_composite_savefile;
-struct smb_composite_connect;
-struct smb_composite_sesssetup;
-struct smb_composite_fetchfile;
-struct smb_composite_appendacl;
-struct smb_composite_fsinfo;
-
-struct nbt_dgram_socket;
-struct dgram_mailslot_handler;
-
-struct messaging_context;
-struct stream_connection;
-struct task_server;
-struct stream_server_ops;
-
-struct nbt_dc_name;
-struct wb_sid_object;
-
-struct cldap_socket;
-struct cldapd_server;
-
-struct websrv_context;
-
-struct wbsrv_call;
-
-struct ldb_map_attribute;
-struct ldb_map_objectclass;
-
 struct param_context;
-
-struct socket_address;
-struct smbcli_request;
 struct smbcli_tree;
-
 struct smb2_tree;
-
-struct IUnknown;
-struct IUnknown_vtable;
-
-struct MprVar;
-
-struct registry_context;
-struct nbtd_interface;
-struct smbcli_session;
-struct smbcli_state;
-
-struct model_ops;
-
-struct smb_wire_string;
-
-union smb_fileinfo;
+struct socket_address;
index 7538bc04efd080b42d6379960ec370c3feb2fd37..0a776d46ce082bc6e13e5ee31b348cab6c6a1a2a 100644 (file)
 #include "system/network.h"
 #include "dlinklist.h"
 #include "lib/ldb/include/ldb.h"
+#include "heimdal/lib/krb5/krb5_locl.h"
 #include "heimdal/lib/krb5/krb5-private.h"
 #include "auth/auth.h"
 #include "dsdb/samdb/samdb.h"
+#include "rpc_server/dcerpc_server.h"
 #include "rpc_server/samr/proto.h"
 
 /* hold information about one kdc socket */
index 1af2cd2e2a2ab0c8e0e9e0bfabd36809aae1d4cc..2d7a7b72443ff009bd13c922207bc6373bd8fee6 100644 (file)
@@ -28,4 +28,8 @@ struct tdb_wrap {
        struct tdb_wrap *next, *prev;
 };
 
+struct auth_session_info;
+struct ldb_message;
+struct ldb_dn;
+
 #include "db_wrap_proto.h"
diff --git a/source/libcli/auth/libcli_auth.h b/source/libcli/auth/libcli_auth.h
new file mode 100644 (file)
index 0000000..f8f07e8
--- /dev/null
@@ -0,0 +1,25 @@
+/* 
+   samba -- Unix SMB/CIFS implementation.
+
+   This program is free software; you can redistribute it and/or modify
+   it under the terms of the GNU General Public License as published by
+   the Free Software Foundation; either version 2 of the License, or
+   (at your option) any later version.
+   
+   This program is distributed in the hope that it will be useful,
+   but WITHOUT ANY WARRANTY; without even the implied warranty of
+   MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+   GNU General Public License for more details.
+   
+   You should have received a copy of the GNU General Public License
+   along with this program; if not, write to the Free Software
+   Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+*/
+#ifndef __LIBCLI_AUTH_H__
+#define __LIBCLI_AUTH_H__
+
+#include "librpc/gen_ndr/netlogon.h"
+#include "auth/credentials/credentials.h"
+#include "libcli/auth/proto.h"
+
+#endif /* __LIBCLI_AUTH_H__ */
index 587fb98920bb80b8171d813e6129c6da570b7375..24fdeff33fbe91f8acce1fb7518f2e5b96a4a1be 100644 (file)
@@ -28,8 +28,7 @@
 #include "auth/ntlmssp/ntlmssp.h"
 #include "auth/ntlmssp/msrpc_parse.h"
 #include "lib/crypto/crypto.h"
-#include "auth/credentials/credentials.h"
-#include "libcli/auth/proto.h"
+#include "libcli/auth/libcli_auth.h"
 #include "pstring.h"
 
 /*
index a718f43d96e2e57b3f696b97db3e03d83887eea6..d89d6a15681c99c75f49ff97bb28570469a19bcd 100644 (file)
@@ -24,8 +24,7 @@
 #include "includes.h"
 #include "libcli/libcli.h"
 #include "libcli/raw/libcliraw.h"
-#include "auth/credentials/credentials.h"
-#include "libcli/auth/proto.h"
+#include "libcli/auth/libcli_auth.h"
 #include "libcli/smb_composite/smb_composite.h"
 
 /*
index d1299d77c1f07eb79929f056d127425e12b70580..6210b2b2271786b2e94aac9f2a793ec10eb591d9 100644 (file)
@@ -61,4 +61,7 @@ struct composite_context {
        BOOL used_wait;
 };
 
+struct irpc_request;
+struct smbcli_request;
+
 #include "libcli/composite/proto.h"
index 76fa13525e1a84f0d4e870cba1ff14b8f22104b1..c358ac5752419767acc0c6beb5694520b47f936c 100644 (file)
@@ -19,6 +19,9 @@
    Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 */
 
+#ifndef __LIBCLI_H__
+#define __LIBCLI_H__
+
 #include "smb.h"
 
 /* 
@@ -47,3 +50,5 @@ struct nbt_dc_name {
 };
 
 #include "libcli/libcli_proto.h"
+
+#endif /* __LIBCLI_H__ */
index a62386b67212cccf557dc612522d4072f34bb283..318fc9fbed7c720db4bebae751be8fda143efd66 100644 (file)
@@ -25,8 +25,7 @@
 #include "libcli/raw/libcliraw.h"
 #include "libcli/composite/composite.h"
 #include "libcli/smb_composite/smb_composite.h"
-#include "auth/credentials/credentials.h"
-#include "libcli/auth/proto.h"
+#include "libcli/auth/libcli_auth.h"
 #include "auth/auth.h"
 #include "version.h"
 
index ac34ad40ac790f9106bce9ef8191f214529b8a22..a7a82965e6ba50ce460c22eff898107f71842f67 100644 (file)
@@ -171,4 +171,6 @@ struct smb_composite_connectmulti {
        } out;
 };
 
+struct smbcli_session;
+
 #include "libcli/smb_composite/proto.h"
index 2496eb0a542bccf357a6435539a15d71780c1034..81eb32be51c7b14f7979a970e5e4cfb67a1b947d 100644 (file)
@@ -39,6 +39,7 @@ struct libnet_context {
 };
 
 
+#include "ldb.h"
 #include "libnet/libnet_passwd.h"
 #include "libnet/libnet_time.h"
 #include "libnet/libnet_rpc.h"
index 35460b7a0aedf9a10d55e5a8340d12af2f1a117f..3b233950b0247797d395925e2ba8a436efe68cc5 100644 (file)
@@ -20,6 +20,9 @@
    Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 */
 
+#ifndef __LIBNET_JOIN_H__
+#define __LIBNET_JOIN_H__
+
 #include "librpc/gen_ndr/ndr_netlogon.h"
 
 enum libnet_Join_level {
@@ -76,3 +79,5 @@ struct libnet_Join {
        } out;
 };
 
+
+#endif /* __LIBNET_JOIN_H__ */
index 7d738d8ee0edd1839e90ec52d1d2c85afb68a27c..30012282e090aec66a18be82ec691681a7bd40d5 100644 (file)
@@ -23,8 +23,7 @@
 #include "smb.h"
 #include "libnet/libnet.h"
 #include "lib/crypto/crypto.h"
-#include "auth/credentials/credentials.h"
-#include "libcli/auth/proto.h"
+#include "libcli/auth/libcli_auth.h"
 
 /*
  * do a password change using DCERPC/SAMR calls
index e92dbc281d89f360e5366509f1db1b421f5a6060..93e752311f3d2ccc199b1185b0df524a22232ad9 100644 (file)
@@ -23,9 +23,8 @@
 
 #include "includes.h"
 #include "libnet/libnet.h"
-#include "auth/credentials/credentials.h"
+#include "libcli/auth/libcli_auth.h"
 #include "auth/gensec/schannel_proto.h"
-#include "libcli/auth/proto.h"
 
 
 /**
index e868a8081c8eaf7fc9ebdcbaf8c8d8ef31b03852..229f359d203e29b90621e530434e368dc0b86705 100644 (file)
@@ -25,7 +25,7 @@
 #include "includes.h"
 #include "auth/auth.h"
 #include "libcli/composite/composite.h"
-#include "libcli/auth/proto.h"
+#include "libcli/auth/libcli_auth.h"
 
 
 struct schannel_key_state {
index 47e11b4694f4c49ab0b4bc01193a75d86d66e78b..5dc9ad6975b16592cfc50407a755ef175a5ca7f0 100644 (file)
@@ -74,5 +74,6 @@ enum wins_hook_action {
        WINS_HOOK_DELETE        = 2
 };
 
+struct ldb_message;
 
 #include "nbt_server/wins/winsdb_proto.h"
index b8ef366022388f46e3db907330bf5282c7117fdf..6dace6031d0af31c0244fd93fdea4422eefdee1e 100644 (file)
@@ -66,6 +66,14 @@ struct spoolss_StartDocPrinter;
 struct spoolss_EndDocPrinter;
 struct spoolss_StartPagePrinter;
 struct spoolss_EndPagePrinter;
+struct spoolss_GetPrinterData;
+struct spoolss_SetPrinterData;
+struct spoolss_EnumPrinterDrivers;
+struct spoolss_EnumMonitors;
+struct spoolss_EnumPrinters;
+struct spoolss_EnumForms;
+struct spoolss_EnumPorts;
+struct spoolss_EnumPrintProcessors;
 
 /* the ntptr operations structure - contains function pointers to 
    the backend implementations of each operation */
index b652b0f530fc3b30e5dcdc704b69fa2833aa34a1..ad5c9594d522f7d3eca87dd9e526a02fe6e2449a 100644 (file)
@@ -29,6 +29,7 @@
 #include "dlinklist.h"
 #include "smb_server/smb_server.h"
 #include "ntvfs/ntvfs.h"
+#include "libcli/rap/rap.h"
 #include "ntvfs/ipc/proto.h"
 #include "rpc_server/dcerpc_server.h"
 
index b9b09890f909c41ec05e2f384973ce45411bda2f..0e15ee154229602482dca1336e20f0f62721cfd1 100644 (file)
@@ -213,4 +213,6 @@ struct ntvfs_critical_sizes {
        int sizeof_ntvfs_request;
 };
 
+struct messaging_context;
+
 #include "ntvfs/ntvfs_proto.h"
index d0807d849d146e1a1d8558d75468ebad9cbb0c25..5f0dd9127edc06bacc4fbc658d51159b882b0f04 100644 (file)
@@ -66,4 +66,6 @@
 #define DCESRV_PULL_HANDLE(h, inhandle, t) DCESRV_PULL_HANDLE_RETVAL(h, inhandle, t, NT_STATUS_INVALID_HANDLE)
 #define DCESRV_PULL_HANDLE_WERR(h, inhandle, t) DCESRV_PULL_HANDLE_RETVAL(h, inhandle, t, WERR_BADFID)
 
+struct dcesrv_context;
+
 #include "rpc_server/common/proto.h"
index a5f8ce15fc889ac15f0dca818d76ac97445df3cc..9d0a884803a51bc1a44c4464151062c9d0969bd0 100644 (file)
@@ -22,6 +22,7 @@
 
 #include "includes.h"
 #include "librpc/gen_ndr/ndr_srvsvc.h"
+#include "rpc_server/dcerpc_server.h"
 
 /* 
     Here are common server info functions used by some dcerpc server interfaces
index ec744a503923924810fee6f135ec224858f9ef9b..c98fe980592ee50d0de7d721b8fb5586d3a3d4bf 100644 (file)
@@ -22,6 +22,7 @@
 
 #include "includes.h"
 #include "librpc/gen_ndr/ndr_srvsvc.h"
+#include "rpc_server/dcerpc_server.h"
 
 /* 
     Here are common server info functions used by some dcerpc server interfaces
index 85449c1a602379ebcf32b8e4d2b27d9003a0c224..98cee05f883ebef59e9b526a49267e97065bba30 100644 (file)
@@ -240,6 +240,8 @@ struct dcesrv_critical_sizes {
        int sizeof_dcesrv_handle;
 };
 
+struct model_ops;
+
 #include "rpc_server/dcerpc_server_proto.h"
 
 #endif /* SAMBA_DCERPC_SERVER_H */
index 72c53183df58a311c2bf328e28d62f9bd434b918..3772b62b301dcd8e8d36353e02ba91db6099c418 100644 (file)
@@ -28,8 +28,9 @@
 #include "dsdb/samdb/samdb.h"
 #include "libcli/ldap/ldap.h"
 #include "libcli/security/proto.h"
-#include "libcli/auth/proto.h"
+#include "libcli/auth/libcli_auth.h"
 #include "smb.h"
+#include "smb_server/smb_server.h"
 #include "ntvfs/ntvfs.h"
 #include "passdb/secrets.h"
 #include "db_wrap.h"
index f4340864257fb6c5e17e17f0a8b601c069ca75f8..9f1b84f77efe5a7ef0841eb710b0ed986ff39416 100644 (file)
@@ -29,7 +29,7 @@
 #include "dsdb/samdb/samdb.h"
 #include "rpc_server/samr/proto.h"
 #include "db_wrap.h"
-#include "libcli/auth/proto.h"
+#include "libcli/auth/libcli_auth.h"
 #include "auth/gensec/schannel_state.h"
 
 struct server_pipe_state {
index 00d2f589ae375362ee40b99bc29516b55ab07319..6341dda6812bec4cbc4bcb06e61e98132ae2eed8 100644 (file)
@@ -32,7 +32,7 @@
 #include "dsdb/samdb/samdb.h"
 #include "auth/auth.h"
 #include "rpc_server/samr/proto.h"
-#include "libcli/auth/proto.h"
+#include "libcli/auth/libcli_auth.h"
 #include "db_wrap.h"
 
 /* 
index 3aa18dfe77a4c4723b1c4abe8c95f7557e1a2185..fe608524a14149a48c15a47c3f3e1de15e1bd56e 100644 (file)
@@ -26,6 +26,7 @@
 #include "librpc/gen_ndr/ndr_unixinfo.h"
 #include "lib/events/events.h"
 #include "smb.h"
+#include "smb_server/smb_server.h"
 #include "ntvfs/ntvfs.h"
 
 #include <sys/types.h>
index f47d27643d48c4b7ee23efe3c8523c4cc761f1fd..5954d2385e18f09bbdf19739890358c501084f1c 100644 (file)
@@ -29,4 +29,7 @@ void mprAddArray(struct MprVar *var, int i, struct MprVar v);
 void mprSetCFunction(struct MprVar *obj, const char *name, MprCFunction fn);
 void mprSetStringCFunction(struct MprVar *obj, const char *name, MprStringCFunction fn);
 
+struct ldb_context;
+struct ldb_message;
+
 #include "scripting/ejs/proto.h"
index 1c544bfe82600e4d1a49df5ebff7a5b60d50dd89..5f30c8141d96c4e943768f78e2309891448fb9ba 100644 (file)
@@ -49,4 +49,6 @@ struct smb2srv_request {
        struct smb2_request_buffer out;
 };
 
+struct smbsrv_request;
+
 #include "smb_server/smb2/smb2_proto.h"
index 5a0f92036151f06ec73a52f4aa3cf6e4ce6fb593..63c0a51937a018a58a8f5247754bef790dd3d323 100644 (file)
@@ -105,7 +105,7 @@ REQUIRED_SUBSYSTEMS = \
 #######################
 # Start SUBSERVICE
 [SUBSYSTEM::service]
-PRIVATE_PROTO_HEADER = service.h
+PRIVATE_PROTO_HEADER = service_proto.h
 OBJ_FILES = \
                service.o \
                service_stream.o \
index d525ce9cdd71a99c298d430003b51743bf390e67..27fac68bb90f09a5cfb758c9445f579287a1a08b 100644 (file)
@@ -22,6 +22,9 @@
    Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 */
 
+#ifndef __PROCESS_MODEL_H__
+#define __PROCESS_MODEL_H__
+
 #include "lib/socket/socket.h"
 
 /* modules can use the following to determine if the interface has changed
@@ -65,3 +68,5 @@ struct process_model_critical_sizes {
 };
 
 #include "smbd/process_model_proto.h"
+
+#endif /* __PROCESS_MODEL_H__ */
index c68c436d52a07844f275966d631c86b735557bf6..c472581a06c6e20530a929ffff491738ee0e463b 100644 (file)
@@ -33,6 +33,7 @@
 #include "ldb/include/ldb.h"
 #include "registry/registry.h"
 #include "smb.h"
+#include "smb_server/smb_server.h"
 #include "ntvfs/ntvfs.h"
 #include "ntptr/ntptr.h"
 #include "auth/gensec/gensec.h"
diff --git a/source/smbd/service.h b/source/smbd/service.h
new file mode 100644 (file)
index 0000000..3ccd98d
--- /dev/null
@@ -0,0 +1,31 @@
+/* 
+   Unix SMB/CIFS implementation.
+
+   SERVER SERVICE code
+
+   Copyright (C) Andrew Tridgell 2003-2005
+   Copyright (C) Stefan (metze) Metzmacher     2004
+   
+   This program is free software; you can redistribute it and/or modify
+   it under the terms of the GNU General Public License as published by
+   the Free Software Foundation; either version 2 of the License, or
+   (at your option) any later version.
+   
+   This program is distributed in the hope that it will be useful,
+   but WITHOUT ANY WARRANTY; without even the implied warranty of
+   MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+   GNU General Public License for more details.
+   
+   You should have received a copy of the GNU General Public License
+   along with this program; if not, write to the Free Software
+   Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+*/
+
+#ifndef __SERVICE_H__
+#define __SERVICE_H__
+
+#include "smbd/service_stream.h"
+#include "smbd/service_task.h"
+#include "smbd/service_proto.h"
+
+#endif /* __SERVICE_H__ */
index 6f1a967237305d9b93d6c8bfbcf58c3cdc4c26c2..692e18bea5b521f19e12a05a054785c1a181cdc8 100644 (file)
@@ -21,6 +21,9 @@
    Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 */
 
+#ifndef __SERVICE_STREAM_H__
+#define __SERVICE_STREAM_H__
+
 /* modules can use the following to determine if the interface has changed
  * please increment the version number after each interface change
  * with a comment and maybe update struct stream_connection_critical_sizes.
@@ -58,3 +61,5 @@ struct stream_server_ops {
        void (*recv_handler)(struct stream_connection *, uint16_t);
        void (*send_handler)(struct stream_connection *, uint16_t);
 };
+
+#endif /* __SERVICE_STREAM_H__ */
index 84bb51245513b40582445ad416370ff6f853900d..c0adf08fd0b5b6bf5e8e125d920125be01e5118b 100644 (file)
@@ -20,6 +20,8 @@
    Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 */
 
+#ifndef __SERVICE_TASK_H__
+#define __SERVICE_TASK_H__ 
 
 struct task_server {
        struct event_context *event_ctx;
@@ -29,3 +31,4 @@ struct task_server {
        void *private;
 };
 
+#endif /* __SERVICE_TASK_H__ */
index be5739eade02dc01406bed80fd4d6e916b03914b..cb32345c2be4139ccccebb91c84b0e0e71f5fd66 100644 (file)
@@ -27,7 +27,7 @@
 #include "lib/cmdline/popt_common.h"
 #include "auth/auth.h"
 #include "pstring.h"
-#include "libcli/auth/proto.h"
+#include "libcli/auth/libcli_auth.h"
 
 #define SQUID_BUFFER_SIZE 2010
 
index 45617082e684f6e33d85953d87f1901e53506564..6e266cc8bc3183b8018c86d2729dcc28d71329cc 100644 (file)
@@ -19,7 +19,6 @@
 */
 
 #include "smbd/process_model.h"
-#include "web_server/proto.h"
 
 /*
   context of one open web connection
@@ -77,3 +76,5 @@ struct esp_data {
        struct tls_params *tls_params;
 };
 
+#include "web_server/proto.h"
+
index cf4c83d7671211490696c8014ae27ba6610cadc1..c8611e6300a9897de6cf2a7a6bf5c7e4b4d516c1 100644 (file)
@@ -29,8 +29,7 @@
 #include "librpc/gen_ndr/ndr_irpc.h"
 #include "libcli/auth/credentials.h"
 #include "libcli/security/proto.h"
-#include "libcli/auth/proto.h"
-#include "auth/credentials/credentials.h"
+#include "libcli/auth/libcli_auth.h"
 
 #include "winbind/wb_helper.h"
 
@@ -555,7 +554,7 @@ struct cmd_checkmachacc_state {
 
 static void cmd_checkmachacc_recv_init(struct composite_context *ctx);
 
-struct composite_context *wb_cmd_checkmachacc_send(struct wbsrv_call *call)
+ struct composite_context *wb_cmd_checkmachacc_send(struct wbsrv_call *call)
 {
        struct composite_context *result, *ctx;
        struct cmd_checkmachacc_state *state;
@@ -599,14 +598,14 @@ static void cmd_checkmachacc_recv_init(struct composite_context *ctx)
        composite_done(state->ctx);
 }
 
-NTSTATUS wb_cmd_checkmachacc_recv(struct composite_context *c)
+ NTSTATUS wb_cmd_checkmachacc_recv(struct composite_context *c)
 {
        NTSTATUS status = composite_wait(c);
        talloc_free(c);
        return status;
 }
 
-NTSTATUS wb_cmd_checkmachacc(struct wbsrv_call *call)
+ NTSTATUS wb_cmd_checkmachacc(struct wbsrv_call *call)
 {
        struct composite_context *c = wb_cmd_checkmachacc_send(call);
        return wb_cmd_checkmachacc_recv(c);
index 2754a8acd6fbd9759e34c71f1fa32759ee938a23..af6a52b1d18bdb4ebaf5bcf31bb5b669bfa0ea1a 100644 (file)
@@ -20,6 +20,9 @@
    Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 */
 
+#ifndef __WB_ASYNC_HELPERS_H__
+#define __WB_ASYNC_HELPERS_H__
+
 #include "librpc/gen_ndr/lsa.h"
 
 struct wb_sid_object {
@@ -29,3 +32,4 @@ struct wb_sid_object {
        const char *name;
 };
 
+#endif /* __WB_ASYNC_HELPERS_H__ */
index 97f0845467b9993ba36e268053be50188721d230..2967414fec3cb6ee5c7563c2e122c9584cae06f3 100644 (file)
@@ -26,8 +26,7 @@
 #include "winbind/wb_server.h"
 #include "smbd/service_task.h"
 #include "libcli/auth/credentials.h"
-#include "libcli/auth/proto.h"
-#include "auth/credentials/credentials.h"
+#include "libcli/auth/libcli_auth.h"
 
 /* Oh, there is so much to keep an eye on when authenticating a user.  Oh my! */
 struct pam_auth_crap_state {
index 7906e52de694620a3e108fefeb6991513dcb054d..2a2aec20ea807608df9840239a55aa3518227c50 100644 (file)
@@ -146,4 +146,5 @@ struct wbsrv_samba3_call {
 struct netr_LMSessionKey;
 struct netr_UserSessionKey;
 
+#include "winbind/wb_async_helpers.h"
 #include "winbind/wb_proto.h"