r11249: More OpenBSD make fixes...
authorJelmer Vernooij <jelmer@samba.org>
Fri, 21 Oct 2005 20:40:58 +0000 (20:40 +0000)
committerGerald (Jerry) Carter <jerry@samba.org>
Wed, 10 Oct 2007 18:45:08 +0000 (13:45 -0500)
source/build/smb_build/makefile.pm
source/build/smb_build/output.pm
source/lib/registry/config.mk

index 06f98446bbcde1022c713211422d2151a5cae626..6f0cf6e189aaa1c60b8386e33747f81e583236b9 100644 (file)
@@ -182,7 +182,10 @@ sub _prepare_manpages($)
        my @mp_list = ();
 
        foreach (values %$ctx) {
-               push (@mp_list, "$_->{BASEDIR}/$_->{MANPAGE}") if (defined($_->{MANPAGE}) and $_->{MANPAGE} ne "");
+               my $dir = $_->{BASEDIR};
+               next unless defined($dir);
+               $dir =~ s/^\.\///g;
+               push (@mp_list, "$dir/$_->{MANPAGE}") if (defined($_->{MANPAGE}) and $_->{MANPAGE} ne "");
        }
        
        my $mp = array2oneperline(\@mp_list);
index 46e8ffb0c5f817f1bb89ba120865ada41a9b57eb..309a02794760427959dfbbd5ab0d9ed5b2f31975 100644 (file)
@@ -14,6 +14,8 @@ sub add_dir($$)
 {
        my ($dir,$files) = @_;
        my @ret = ();
+
+       $dir =~ s/^\.\///g;
        
        foreach (@$files) {
                $_ = "$dir/$_";
index 7aa720cc7ab85f601983d76e4adfc284a45e1219..9461bb2a95d205a2f4561a7011ba1d9d91d5a026 100644 (file)
@@ -16,8 +16,8 @@ REQUIRED_SUBSYSTEMS = TDR
 NOPROTO = YES
 INIT_OBJ_FILES = tdr_regf.o
 
-./lib/registry/reg_backend_nt4.c: ./lib/registry/tdr_regf.c
-./lib/registry/tdr_regf.c: lib/registry/regf.idl
+lib/registry/reg_backend_nt4.c: lib/registry/tdr_regf.c
+lib/registry/tdr_regf.c: lib/registry/regf.idl
        @CPP="$(CPP)" pidl/pidl $(PIDL_ARGS) --header --outputdir=lib/registry --tdr-header --tdr-parser -- lib/registry/regf.idl
 
 ################################################