When testing for /usr/include/heimdal, don't include /usr/heimdal/include
[ira/wip.git] / source3 / configure.in
index 8e15da6fac795f3f5760dd686c3fbd68478aca87..fdc83769c7385f659660bd872f02d43af3c85b62 100644 (file)
@@ -462,6 +462,7 @@ AC_CHECK_HEADERS(sys/fs/vx_quota.h)
 
 # For quotas on Linux XFS filesystems
 AC_CHECK_HEADERS(linux/xqm.h)
+AC_CHECK_HEADERS(xfs/xqm.h)
 
 AC_CHECK_SIZEOF(int,cross)
 AC_CHECK_SIZEOF(long,cross)
@@ -1992,8 +1993,8 @@ if test x$FOUND_KRB5 = x"no"; then
 # see if this box has the SuSE location for the heimdal kerberos implementation
 AC_MSG_CHECKING(for /usr/include/heimdal)
 if test -d /usr/include/heimdal; then
-    CFLAGS="$CFLAGS -I/usr/heimdal/include"
-    CPPFLAGS="$CPPFLAGS -I/usr/heimdal/include"
+    CFLAGS="$CFLAGS -I/usr/include/heimdal"
+    CPPFLAGS="$CPPFLAGS -I/usr/include/heimdal"
     AC_MSG_RESULT(yes)
 else
     AC_MSG_RESULT(no)
@@ -2085,14 +2086,15 @@ fi
 
 ########################################################
 # Compile with MySQL support?
-AM_PATH_MYSQL()
+AM_PATH_MYSQL([0.11.0],[MODULE_PDB_MYSQL=bin/pdb_mysql.so],[MODULE_PDB_MYSQL=])
 CFLAGS="$CFLAGS $MYSQL_CFLAGS"
-
+AC_SUBST(MODULE_PDB_MYSQL)
 
 ########################################################
 # Compile with XML support?
-AM_PATH_XML2()
+AM_PATH_XML2([2.0.0],[MODULE_PDB_XML=bin/pdb_xml.so],[MODULE_PDB_XML=])
 CFLAGS="$CFLAGS $XML_CFLAGS"
+AC_SUBST(MODULE_PDB_XML)
 
 #################################################
 # check for automount support
@@ -3174,7 +3176,7 @@ AC_SUBST(builddir)
 # I added make files that are outside /source directory.
 # I know this is not a good solution, will work out a better
 # solution soon.                       --simo
-AC_OUTPUT(include/stamp-h Makefile script/findsmb ../examples/VFS/Makefile ../examples/sam/Makefile)
+AC_OUTPUT(include/stamp-h Makefile script/findsmb ../examples/sam/Makefile)
 
 #################################################
 # Print very concise instructions on building/use