Sync autogen.sh from samba3
[ira/wip.git] / source / autogen.sh
index a2228a6fd929d977b55ca67a41c7a6a266813818..2d91173f4a8d094e78b3c873b7cb56803298e558 100755 (executable)
@@ -1,31 +1,54 @@
-#! /bin/sh
+#!/bin/sh
 
 # Run this script to build samba from CVS.
 
-## first try the default names
-AUTOHEADER="autoheader"
-AUTOCONF="autoconf"
+## insert all possible names (only works with 
+## autoconf 2.x
+TESTAUTOHEADER="autoheader autoheader-2.53"
+TESTAUTOCONF="autoconf autoconf-2.53"
+
+AUTOHEADERFOUND="0"
+AUTOCONFFOUND="0"
 
-if which $AUTOCONF > /dev/null
-then
-    :
-else
-    echo "$0: need autoconf 2.53 or later to build samba from CVS" >&2
-    exit 1
-fi
 
 ##
-## what version do we need?
+## Look for autoheader 
+##
+for i in $TESTAUTOHEADER; do
+       if which $i > /dev/null 2>&1; then
+               if [ `$i --version | head -n 1 | cut -d.  -f 2` -ge 53 ]; then
+                       AUTOHEADER=$i
+                       AUTOHEADERFOUND="1"
+                       break
+               fi
+       fi
+done
+
+## 
+## Look for autoconf
 ##
-if [ `$AUTOCONF --version | head -1 | cut -d.  -f 2` -lt 53 ]; then
 
-       ## maybe it's installed under a different name (e.g. RedHat 7.3)
+for i in $TESTAUTOCONF; do
+       if which $i > /dev/null 2>&1; then
+               if [ `$i --version | head -n 1 | cut -d.  -f 2` -ge 53 ]; then
+                       AUTOCONF=$i
+                       AUTOCONFFOUND="1"
+                       break
+               fi
+       fi
+done
 
-       AUTOCONF="autoconf-2.53"
-       AUTOHEADER="autoheader-2.53"
 
+## 
+## do we have it?
+##
+if [ "$AUTOCONFFOUND" = "0" -o "$AUTOHEADERFOUND" = "0" ]; then
+       echo "$0: need autoconf 2.53 or later to build samba from CVS" >&2
+       exit 1
 fi
 
+
+
 echo "$0: running $AUTOHEADER"
 $AUTOHEADER || exit 1
 
@@ -34,3 +57,4 @@ $AUTOCONF || exit 1
 
 echo "Now run ./configure and then make."
 exit 0
+