r735: Fix some paths
[ira/wip.git] / packaging / debian / rules
index 5de994450dad3bdce65798cc473591c69c2bc2b7..c2c3dc14ceae00dcbe4787c6320b9cc697b8ddca 100755 (executable)
@@ -3,12 +3,15 @@
 # Made with the aid of debmake, by Christoph Lameter,
 # based on the sample debian/rules file for GNU hello by Ian Jackson.
 
 # Made with the aid of debmake, by Christoph Lameter,
 # based on the sample debian/rules file for GNU hello by Ian Jackson.
 
+
+SOURCEPATH=../source
+
 package=samba4
 
 configure:
        $(checkdir)
 package=samba4
 
 configure:
        $(checkdir)
-       cd source && ./autogen.sh
-       cd source && ./configure --with-fhs \
+       cd $(SOURCEPATH) && ./autogen.sh
+       cd $(SOURCEPATH) && ./configure --with-fhs \
                --prefix=/usr \
                --enable-shared \
                --enable-static \
                --prefix=/usr \
                --enable-shared \
                --enable-static \
@@ -26,13 +29,13 @@ configure:
 
 build: configure
        $(checkdir)
 
 build: configure
        $(checkdir)
-       cd source && $(MAKE) proto all
+       cd $(SOURCEPATH) && $(MAKE) proto all
        touch build
 
 clean:
        $(checkdir)
        rm -f build
        touch build
 
 clean:
        $(checkdir)
        rm -f build
-       -cd source && $(MAKE) clean
+       -cd $(SOURCEPATH) && $(MAKE) clean
        rm -f `find . -name "*~"`
        rm -rf debian/tmp `find debian/* -type d ! -name CVS` debian/files* core
        rm -f debian/*substvars
        rm -f `find . -name "*~"`
        rm -rf debian/tmp `find debian/* -type d ! -name CVS` debian/files* core
        rm -f debian/*substvars
@@ -48,7 +51,7 @@ binary-arch: checkroot build
        rm -rf debian/tmp `find debian/* -type d ! -name CVS`
        install -d debian/tmp
        cd debian/tmp && install -d `cat ../dirs`
        rm -rf debian/tmp `find debian/* -type d ! -name CVS`
        install -d debian/tmp
        cd debian/tmp && install -d `cat ../dirs`
-       cd source && $(MAKE) install DESTDIR=`pwd`/../debian/tmp
+       cd $(SOURCEPATH) && $(MAKE) install DESTDIR=`pwd`/../packaging/debian/tmp
        debstd 
        dpkg-gencontrol -isp -psamba4
        chown -R root:root debian/tmp
        debstd 
        dpkg-gencontrol -isp -psamba4
        chown -R root:root debian/tmp