talloc: add --enable-talloc-compat1 to build a compat library for talloc 1.x.x
[ira/wip.git] / lib / talloc / compat / talloc_compat1.mk
1 talloccompatdir := $(tallocdir)/compat
2
3 TALLOC_COMPAT1_VERSION_MAJOR = 1
4 TALLOC_COMPAT1_OBJ = $(talloccompatdir)/talloc_compat1.o
5
6 TALLOC_COMPAT1_SOLIB = libtalloc-compat1-$(TALLOC_VERSION).$(SHLIBEXT)
7 TALLOC_COMPAT1_SONAME = libtalloc.$(SHLIBEXT).$(TALLOC_COMPAT1_VERSION_MAJOR)
8
9 $(TALLOC_COMPAT1_SOLIB): $(TALLOC_COMPAT1_OBJ) $(TALLOC_SOLIB)
10         $(SHLD) $(SHLD_FLAGS) -o $@ $(TALLOC_COMPAT1_OBJ) \
11                 $(TALLOC_SOLIB) $(SONAMEFLAG)$(TALLOC_COMPAT1_SONAME)
12
13 all:: $(TALLOC_COMPAT1_SOLIB)
14
15 install::
16         ${INSTALLCMD} -d $(DESTDIR)$(libdir)
17         ${INSTALLCMD} -m 755 $(TALLOC_COMPAT1_SOLIB) $(DESTDIR)$(libdir)
18
19 clean::
20         rm -f $(TALLOC_COMPAT1_OBJ) $(TALLOC_COMPAT1_SOLIB)
21