talloc: add --enable-talloc-compat1 to build a compat library for talloc 1.x.x
[ira/wip.git] / lib / talloc / compat / talloc_compat1.m4
1 TALLOC_COMPAT1_MK=""
2 AC_SUBST(TALLOC_COMPAT1_MK)
3
4 AC_ARG_ENABLE(talloc-compat1,
5         [AS_HELP_STRING([--enable-talloc-compat1],
6                 [Build talloc 1.x.x compat library [default=no]])],
7         [ enable_talloc_compat1=$enableval ],
8         [ enable_talloc_compat1=no ]
9 )
10
11 if test "x$enable_talloc_compat1" = x"yes"; then
12         TALLOC_COMPAT1_MK='include $(tallocdir)/compat/talloc_compat1.mk'
13 fi
14