8b8eccacc762ffc388ade104ae88fa002879483a
[ira/wip.git] / docs-xml / Samba3-Developers-Guide / packagers.xml
1 <?xml version="1.0" encoding="iso-8859-1"?>
2 <!DOCTYPE chapter PUBLIC "-//Samba-Team//DTD DocBook V4.2-Based Variant V1.0//EN" "http://www.samba.org/samba/DTD/samba-doc">
3 <chapter id="Packaging">
4 <chapterinfo>
5         <author>
6                 <firstname>Jelmer</firstname><surname>Vernooij</surname>
7         </author>
8 </chapterinfo>
9
10 <title>Notes to packagers</title>
11
12 <sect1>
13 <title>Versioning</title>
14
15 <para>
16 Please, please update the version number in <filename>source/include/version.h</filename> to include the
17 versioning of your package. This makes it easier to distinguish standard samba builds from custom-build samba
18 builds (distributions often patch packages). For example, a good version would be:
19 </para>
20
21 <para><programlisting>
22 Version 2.999+3.0.alpha21-5 for Debian
23 </programlisting></para>
24
25 </sect1>
26
27 <sect1>
28 <title>Modules</title>
29
30 <para>
31 Samba3 has support for building parts of samba as plugins. This makes it possible to, for example,
32 put ldap or mysql support in a separate package, thus making it possible to have a normal samba package not
33 depending on ldap or mysql. To build as much parts of samba as a plugin, run:
34 </para>
35
36 <para>
37 The option <literal>--with-shared-modules</literal> is maintained to support specific modules such as
38 idmap_XXX and vfs_XXX. For example, <literal>--with-shared-modules=idmap_ad</literal>. Use of this parameter
39 to the <command>configure</command> command as not been supported in official releases.
40 </para>
41
42 <para>
43 <programlisting>
44 ./configure --with-shared-modules=rpc,vfs,auth,pdb,charset
45 </programlisting>
46 </para>
47
48 </sect1>
49
50
51 </chapter>