s4 dsdb util: remove samdb_search_count
[gd/samba-autobuild/.git] / wscript
1 #!/usr/bin/env python
2
3 top = '.'
4 out = 'bin'
5
6 APPNAME='samba'
7 VERSION=None
8
9 import sys, os, tempfile
10 sys.path.insert(0, top+"/buildtools/wafsamba")
11 import shutil
12 import wafsamba, samba_dist, samba_git, samba_version, samba_utils
13 from waflib import Options, Scripting, Logs, Context, Errors
14
15 samba_dist.DIST_DIRS('.')
16 samba_dist.DIST_BLACKLIST('.gitignore .bzrignore source4/selftest/provisions')
17
18 # install in /usr/local/samba by default
19 default_prefix = Options.default_prefix = '/usr/local/samba'
20
21 # This callback optionally takes a list of paths as arguments:
22 # --with-system_mitkrb5 /path/to/krb5 /another/path
23 def system_mitkrb5_callback(option, opt, value, parser):
24     setattr(parser.values, option.dest, True)
25     value = []
26     for arg in parser.rargs:
27         # stop on --foo like options
28         if arg[:2] == "--" and len(arg) > 2:
29             break
30         value.append(arg)
31     if len(value)>0:
32         del parser.rargs[:len(value)]
33         setattr(parser.values, option.dest, value)
34
35 def options(opt):
36     opt.BUILTIN_DEFAULT('NONE')
37     opt.PRIVATE_EXTENSION_DEFAULT('samba4')
38     opt.RECURSE('lib/replace')
39     opt.RECURSE('dynconfig')
40     opt.RECURSE('packaging')
41     opt.RECURSE('lib/ldb')
42     opt.RECURSE('selftest')
43     opt.RECURSE('source4/lib/tls')
44     opt.RECURSE('source4/dsdb/samdb/ldb_modules')
45     opt.RECURSE('pidl')
46     opt.RECURSE('source3')
47     opt.RECURSE('lib/util')
48     opt.RECURSE('lib/crypto')
49     opt.RECURSE('ctdb')
50
51
52     opt.samba_add_onoff_option('pthreadpool', with_name="enable", without_name="disable", default=True)
53
54     opt.add_option('--with-system-mitkrb5',
55                    help='build Samba with system MIT Kerberos. ' +
56                         'You may specify list of paths where Kerberos is installed (e.g. /usr/local /usr/kerberos) to search krb5-config',
57                    action='callback', callback=system_mitkrb5_callback, dest='with_system_mitkrb5', default=False)
58
59     opt.add_option('--with-experimental-mit-ad-dc',
60                    help='Enable the experimental MIT Kerberos-backed AD DC.  ' +
61                    'Note that security patches are not issued for this configuration',
62                    action='store_true',
63                    dest='with_experimental_mit_ad_dc',
64                    default=False)
65
66     opt.add_option('--with-system-mitkdc',
67                    help=('Specify the path to the krb5kdc binary from MIT Kerberos'),
68                    type="string",
69                    dest='with_system_mitkdc',
70                    default=None)
71
72     opt.add_option('--with-system-heimdalkrb5',
73                    help=('build Samba with system Heimdal Kerberos. ' +
74                          'Requires --without-ad-dc' and
75                          'conflicts with --with-system-mitkrb5'),
76                    action='store_true',
77                    dest='with_system_heimdalkrb5',
78                    default=False)
79
80     opt.add_option('--without-ad-dc',
81                    help='disable AD DC functionality (enables only Samba FS (File Server, Winbind, NMBD) and client utilities.',
82                    action='store_true', dest='without_ad_dc', default=False)
83
84     opt.add_option('--with-ntvfs-fileserver',
85                    help='enable the deprecated NTVFS file server from the original Samba4 branch (default if --enable-selftest specified).  Conflicts with --with-system-mitkrb5 and --without-ad-dc',
86                    action='store_true', dest='with_ntvfs_fileserver')
87
88     opt.add_option('--without-ntvfs-fileserver',
89                    help='disable the deprecated NTVFS file server from the original Samba4 branch',
90                    action='store_false', dest='with_ntvfs_fileserver')
91
92     opt.add_option('--with-pie',
93                   help=("Build Position Independent Executables " +
94                         "(default if supported by compiler)"),
95                   action="store_true", dest='enable_pie')
96     opt.add_option('--without-pie',
97                   help=("Disable Position Independent Executable builds"),
98                   action="store_false", dest='enable_pie')
99
100     opt.add_option('--with-relro',
101                   help=("Build with full RELocation Read-Only (RELRO)" +
102                         "(default if supported by compiler)"),
103                   action="store_true", dest='enable_relro')
104     opt.add_option('--without-relro',
105                   help=("Disable RELRO builds"),
106                   action="store_false", dest='enable_relro')
107
108     gr = opt.option_group('developer options')
109
110     opt.load('python') # options for disabling pyc or pyo compilation
111     # enable options related to building python extensions
112
113     opt.add_option('--with-json',
114                    action='store_true', dest='with_json',
115                    help=("Build with JSON support (default=True). This "
116                          "requires the jansson development headers."))
117     opt.add_option('--without-json',
118                    action='store_false', dest='with_json',
119                    help=("Build without JSON support."))
120
121 def configure(conf):
122     version = samba_version.load_version(env=conf.env)
123
124     conf.DEFINE('CONFIG_H_IS_FROM_SAMBA', 1)
125     conf.DEFINE('_SAMBA_BUILD_', version.MAJOR, add_to_cflags=True)
126     conf.DEFINE('HAVE_CONFIG_H', 1, add_to_cflags=True)
127
128     if Options.options.developer:
129         conf.ADD_CFLAGS('-DDEVELOPER -DDEBUG_PASSWORD')
130         conf.env.DEVELOPER = True
131         # if we are in a git tree without a pre-commit hook, install a
132         # simple default.
133         pre_commit_hook = os.path.join(Context.g_module.top, '.git/hooks/pre-commit')
134         if (os.path.isdir(os.path.dirname(pre_commit_hook)) and
135             not os.path.exists(pre_commit_hook)):
136             shutil.copy(os.path.join(Context.g_module.top, 'script/git-hooks/pre-commit-hook'),
137                         pre_commit_hook)
138
139     conf.ADD_EXTRA_INCLUDES('#include/public #source4 #lib #source4/lib #source4/include #include #lib/replace')
140
141     conf.env.replace_add_global_pthread = True
142     conf.RECURSE('lib/replace')
143
144     conf.RECURSE('examples/fuse')
145     conf.RECURSE('examples/winexe')
146
147     conf.SAMBA_CHECK_PERL(mandatory=True)
148     conf.find_program('xsltproc', var='XSLTPROC')
149
150     if conf.env.disable_python:
151         if not (Options.options.without_ad_dc):
152             raise Errors.WafError('--disable-python requires --without-ad-dc')
153
154     conf.SAMBA_CHECK_PYTHON(mandatory=True, version=(2, 6, 0))
155     conf.SAMBA_CHECK_PYTHON_HEADERS(mandatory=(not conf.env.disable_python))
156
157     if sys.platform == 'darwin' and not conf.env['HAVE_ENVIRON_DECL']:
158         # Mac OSX needs to have this and it's also needed that the python is compiled with this
159         # otherwise you face errors about common symbols
160         if not conf.CHECK_SHLIB_W_PYTHON("Checking if -fno-common is needed"):
161             conf.ADD_CFLAGS('-fno-common')
162         if not conf.CHECK_SHLIB_W_PYTHON("Checking if -undefined dynamic_lookup is not need"):
163             conf.env.append_value('cshlib_LINKFLAGS', ['-undefined', 'dynamic_lookup'])
164
165     if sys.platform == 'darwin':
166         conf.ADD_LDFLAGS('-framework CoreFoundation')
167
168     conf.RECURSE('dynconfig')
169     conf.RECURSE('selftest')
170
171     if conf.CHECK_FOR_THIRD_PARTY():
172         conf.RECURSE('third_party')
173     else:
174         if not conf.CHECK_ZLIB():
175             raise Errors.WafError('zlib development packages have not been found.\nIf third_party is installed, check that it is in the proper place.')
176         else:
177             conf.define('USING_SYSTEM_ZLIB',1)
178
179         if not conf.CHECK_POPT():
180             raise Errors.WafError('popt development packages have not been found.\nIf third_party is installed, check that it is in the proper place.')
181         else:
182             conf.define('USING_SYSTEM_POPT', 1)
183
184         if not conf.CHECK_CMOCKA():
185             raise Errors.WafError('cmocka development packages has not been found.\nIf third_party is installed, check that it is in the proper place.')
186         else:
187             conf.define('USING_SYSTEM_CMOCKA', 1)
188
189         if conf.CONFIG_GET('ENABLE_SELFTEST'):
190             if not conf.CHECK_SOCKET_WRAPPER():
191                 raise Errors.WafError('socket_wrapper package has not been found.\nIf third_party is installed, check that it is in the proper place.')
192             else:
193                 conf.define('USING_SYSTEM_SOCKET_WRAPPER', 1)
194
195             if not conf.CHECK_NSS_WRAPPER():
196                 raise Errors.WafError('nss_wrapper package has not been found.\nIf third_party is installed, check that it is in the proper place.')
197             else:
198                 conf.define('USING_SYSTEM_NSS_WRAPPER', 1)
199
200             if not conf.CHECK_RESOLV_WRAPPER():
201                 raise Errors.WafError('resolv_wrapper package has not been found.\nIf third_party is installed, check that it is in the proper place.')
202             else:
203                 conf.define('USING_SYSTEM_RESOLV_WRAPPER', 1)
204
205             if not conf.CHECK_UID_WRAPPER():
206                 raise Errors.WafError('uid_wrapper package has not been found.\nIf third_party is installed, check that it is in the proper place.')
207             else:
208                 conf.define('USING_SYSTEM_UID_WRAPPER', 1)
209
210             if not conf.CHECK_PAM_WRAPPER():
211                 raise Errors.WafError('pam_wrapper package has not been found.\nIf third_party is installed, check that it is in the proper place.')
212             else:
213                 conf.define('USING_SYSTEM_PAM_WRAPPER', 1)
214
215     conf.RECURSE('lib/ldb')
216
217     if conf.CHECK_LDFLAGS(['-Wl,--wrap=test']):
218         conf.env['HAVE_LDWRAP'] = True
219         conf.define('HAVE_LDWRAP', 1)
220
221     if not (Options.options.without_ad_dc):
222         conf.DEFINE('AD_DC_BUILD_IS_ENABLED', 1)
223
224     if Options.options.with_system_mitkrb5:
225         if not Options.options.with_experimental_mit_ad_dc and \
226            not Options.options.without_ad_dc:
227             raise Errors.WafError('The MIT Kerberos build of Samba as an AD DC ' +
228                                   'is experimental. Therefore '
229                                   '--with-system-mitkrb5 requires either ' +
230                                   '--with-experimental-mit-ad-dc or ' +
231                                   '--without-ad-dc')
232
233         conf.PROCESS_SEPARATE_RULE('system_mitkrb5')
234
235     if not (Options.options.without_ad_dc or Options.options.with_system_mitkrb5):
236         conf.DEFINE('AD_DC_BUILD_IS_ENABLED', 1)
237
238     if Options.options.with_system_heimdalkrb5:
239         if Options.options.with_system_mitkrb5:
240             raise Errors.WafError('--with-system-heimdalkrb5 conflicts with ' +
241                                   '--with-system-mitkrb5')
242         if not Options.options.without_ad_dc:
243             raise Errors.WafError('--with-system-heimdalkrb5 requires ' +
244                                   '--without-ad-dc')
245         conf.env.SYSTEM_LIBS += ('heimdal', 'asn1', 'com_err', 'roken',
246                                  'hx509', 'wind', 'gssapi', 'hcrypto',
247                                  'krb5', 'heimbase', 'asn1_compile',
248                                  'compile_et', 'kdc', 'hdb', 'heimntlm')
249         conf.PROCESS_SEPARATE_RULE('system_heimdal')
250
251     if not conf.CONFIG_GET('KRB5_VENDOR'):
252         conf.PROCESS_SEPARATE_RULE('embedded_heimdal')
253
254     conf.RECURSE('source4/lib/tls')
255     conf.RECURSE('source4/dsdb/samdb/ldb_modules')
256     conf.RECURSE('source4/ntvfs/sysdep')
257     conf.RECURSE('lib/util')
258     conf.RECURSE('lib/util/charset')
259     conf.RECURSE('source4/auth')
260     conf.RECURSE('nsswitch')
261     conf.RECURSE('libcli/smbreadline')
262     conf.RECURSE('lib/crypto')
263     conf.RECURSE('pidl')
264     if conf.CONFIG_GET('ENABLE_SELFTEST'):
265         if Options.options.with_ntvfs_fileserver != False:
266             if not (Options.options.without_ad_dc):
267                 conf.DEFINE('WITH_NTVFS_FILESERVER', 1)
268         if Options.options.with_ntvfs_fileserver == False:
269             if not (Options.options.without_ad_dc):
270                 raise Errors.WafError('--without-ntvfs-fileserver conflicts with --enable-selftest while building the AD DC')
271         conf.RECURSE('testsuite/unittests')
272
273     if Options.options.with_ntvfs_fileserver == True:
274         if Options.options.without_ad_dc:
275             raise Errors.WafError('--with-ntvfs-fileserver conflicts with --without-ad-dc')
276         conf.DEFINE('WITH_NTVFS_FILESERVER', 1)
277
278     if Options.options.with_pthreadpool:
279         if conf.CONFIG_SET('HAVE_PTHREAD'):
280             conf.DEFINE('WITH_PTHREADPOOL', '1')
281         else:
282             Logs.warn("pthreadpool support cannot be enabled when pthread support was not found")
283             conf.undefine('WITH_PTHREADPOOL')
284
285     conf.SET_TARGET_TYPE('jansson', 'EMPTY')
286
287     if Options.options.with_json != False:
288         if conf.CHECK_CFG(package='jansson', args='--cflags --libs',
289                           msg='Checking for jansson'):
290             conf.CHECK_FUNCS_IN('json_object', 'jansson')
291
292     if not conf.CONFIG_GET('HAVE_JSON_OBJECT'):
293         if Options.options.with_json != False:
294             conf.fatal("Jansson JSON support not found. "
295                        "Try installing libjansson-dev or jansson-devel. "
296                        "Otherwise, use --without-json to build without "
297                        "JSON support. "
298                        "JSON support is required for the JSON "
299                        "formatted audit log feature, the AD DC, and "
300                        "the JSON printers of the net utility")
301         if not Options.options.without_ad_dc:
302             raise Errors.WafError('--without-json requires --without-ad-dc. '
303                                  'Jansson JSON library is required for '
304                                  'building the AD DC')
305         Logs.info("Building without Jansson JSON log support")
306
307     conf.RECURSE('source3')
308     conf.RECURSE('lib/texpect')
309     conf.RECURSE('python')
310     if conf.env.with_ctdb:
311         conf.RECURSE('ctdb')
312     conf.RECURSE('lib/socket')
313     conf.RECURSE('lib/mscat')
314     conf.RECURSE('packaging')
315
316     conf.SAMBA_CHECK_UNDEFINED_SYMBOL_FLAGS()
317
318     # gentoo always adds this. We want our normal build to be as
319     # strict as the strictest OS we support, so adding this here
320     # allows us to find problems on our development hosts faster.
321     # It also results in faster load time.
322
323     conf.env.asneeded_ldflags = conf.ADD_LDFLAGS('-Wl,--as-needed', testflags=True)
324
325     if not conf.CHECK_NEED_LC("-lc not needed"):
326         conf.ADD_LDFLAGS('-lc', testflags=False)
327
328     if not conf.CHECK_CODE('#include "tests/summary.c"',
329                            define='SUMMARY_PASSES',
330                            addmain=False,
331                            msg='Checking configure summary'):
332         raise Errors.WafError('configure summary failed')
333
334     if Options.options.enable_pie != False:
335         if Options.options.enable_pie == True:
336                 need_pie = True
337         else:
338                 # not specified, only build PIEs if supported by compiler
339                 need_pie = False
340         if conf.check_cc(cflags='-fPIE', ldflags='-pie', mandatory=need_pie,
341                          msg="Checking compiler for PIE support"):
342             conf.env['ENABLE_PIE'] = True
343
344     if Options.options.enable_relro != False:
345         if Options.options.enable_relro == True:
346             need_relro = True
347         else:
348             # not specified, only build RELROs if supported by compiler
349             need_relro = False
350         if conf.check_cc(cflags='', ldflags='-Wl,-z,relro,-z,now', mandatory=need_relro,
351                          msg="Checking compiler for full RELRO support"):
352             conf.env['ENABLE_RELRO'] = True
353
354     conf.SAMBA_CONFIG_H('include/config.h')
355
356 def etags(ctx):
357     '''build TAGS file using etags'''
358     from waflib import Utils
359     source_root = os.path.dirname(Context.g_module.root_path)
360     cmd = 'rm -f %s/TAGS && (find %s -name "*.[ch]" | egrep -v \.inst\. | xargs -n 100 etags -a)' % (source_root, source_root)
361     print("Running: %s" % cmd)
362     status = os.system(cmd)
363     if os.WEXITSTATUS(status):
364         raise Errors.WafError('etags failed')
365
366 def ctags(ctx):
367     "build 'tags' file using ctags"
368     from waflib import Utils
369     source_root = os.path.dirname(Context.g_module.root_path)
370     cmd = 'ctags --python-kinds=-i $(find %s -name "*.[ch]" | grep -v "*_proto\.h" | egrep -v \.inst\.) $(find %s -name "*.py")' % (source_root, source_root)
371     print("Running: %s" % cmd)
372     status = os.system(cmd)
373     if os.WEXITSTATUS(status):
374         raise Errors.WafError('ctags failed')
375
376
377 # putting this here enabled build in the list
378 # of commands in --help
379 def build(bld):
380     '''build all targets'''
381     samba_version.load_version(env=bld.env, is_install=bld.is_install)
382
383
384 def pydoctor(ctx):
385     '''build python apidocs'''
386     bp = os.path.abspath('bin/python')
387     mpaths = {}
388     modules = ['talloc', 'tdb', 'ldb']
389     for m in modules:
390         f = os.popen("PYTHONPATH=%s python -c 'import %s; print %s.__file__'" % (bp, m, m), 'r')
391         try:
392             mpaths[m] = f.read().strip()
393         finally:
394             f.close()
395     mpaths['main'] = bp
396     cmd = ('PYTHONPATH=%(main)s pydoctor --introspect-c-modules --project-name=Samba '
397            '--project-url=http://www.samba.org --make-html --docformat=restructuredtext '
398            '--add-package bin/python/samba ' + ''.join('--add-module %s ' % n for n in modules))
399     cmd = cmd % mpaths
400     print("Running: %s" % cmd)
401     status = os.system(cmd)
402     if os.WEXITSTATUS(status):
403         raise Errors.WafError('pydoctor failed')
404
405
406 def pep8(ctx):
407     '''run pep8 validator'''
408     cmd='PYTHONPATH=bin/python pep8 -r bin/python/samba'
409     print("Running: %s" % cmd)
410     status = os.system(cmd)
411     if os.WEXITSTATUS(status):
412         raise Errors.WafError('pep8 failed')
413
414
415 def wafdocs(ctx):
416     '''build wafsamba apidocs'''
417     from samba_utils import recursive_dirlist
418     os.system('pwd')
419     list = recursive_dirlist('../buildtools/wafsamba', '.', pattern='*.py')
420
421     cmd='PYTHONPATH=bin/python pydoctor --project-name=wafsamba --project-url=http://www.samba.org --make-html --docformat=restructuredtext'
422     print(list)
423     for f in list:
424         cmd += ' --add-module %s' % f
425     print("Running: %s" % cmd)
426     status = os.system(cmd)
427     if os.WEXITSTATUS(status):
428         raise Errors.WafError('wafdocs failed')
429
430
431 def dist():
432     '''makes a tarball for distribution'''
433     sambaversion = samba_version.load_version(env=None)
434
435     os.system("make -C ctdb manpages")
436     samba_dist.DIST_FILES('ctdb/doc:ctdb/doc', extend=True)
437
438     os.system("DOC_VERSION='" + sambaversion.STRING + "' " + Context.g_module.top + "/release-scripts/build-manpages-nogit")
439     samba_dist.DIST_FILES('bin/docs:docs', extend=True)
440
441     if sambaversion.IS_SNAPSHOT:
442         # write .distversion file and add to tar
443         if not os.path.isdir(Context.g_module.out):
444             os.makedirs(Context.g_module.out)
445         distversionf = tempfile.NamedTemporaryFile(mode='w', prefix='.distversion',dir=Context.g_module.out)
446         for field in sambaversion.vcs_fields:
447             distveroption = field + '=' + str(sambaversion.vcs_fields[field])
448             distversionf.write(distveroption + '\n')
449         distversionf.flush()
450         samba_dist.DIST_FILES('%s:.distversion' % distversionf.name, extend=True)
451
452         samba_dist.dist()
453         distversionf.close()
454     else:
455         samba_dist.dist()
456
457
458 def distcheck():
459     '''test that distribution tarball builds and installs'''
460     samba_version.load_version(env=None)
461
462 def wildcard_cmd(cmd):
463     '''called on a unknown command'''
464     from samba_wildcard import run_named_build_task
465     run_named_build_task(cmd)
466
467 def main():
468     from samba_wildcard import wildcard_main
469
470     wildcard_main(wildcard_cmd)
471 Scripting.main = main
472
473 def reconfigure(ctx):
474     '''reconfigure if config scripts have changed'''
475     import samba_utils
476     samba_utils.reconfigure(ctx)
477
478
479 if os.path.isdir(os.path.join(top, ".git")):
480     # Check if there are submodules that are checked out but out of date.
481     for submodule, status in samba_git.read_submodule_status(top):
482         if status == "out-of-date":
483             raise Errors.WafError("some submodules are out of date. Please run 'git submodule update'")