Remove unnecessary checks for apps now used through dblatex.
[bbaumbach/samba-autobuild/.git] / docs-xml / configure.ac
1 AC_INIT(xslt/latex.xsl)
2
3 LATEX_DOCUMENTCLASS_OPTIONS="letterpaper,11pt,openright,twoside"
4 AC_ARG_ENABLE(prentice-hall,
5 [ --enable-prentice-hall     Produce Prentice-Hall compatible output],
6 [ test "$enableval" && LATEX_DOCUMENTCLASS_OPTIONS="letterpaper,10pt,openleft,twoside,ph" ])
7 AC_SUBST(LATEX_DOCUMENTCLASS_OPTIONS)
8
9 DOC_BUILD_DATE=`date '+%d-%m-%Y'`
10 AC_SUBST(DOC_BUILD_DATE)
11
12 DOCS_TARGET_REQUIRE_PROGRAM(XSLTPROC, xsltproc, ALL)
13 DOCS_TARGET_REQUIRE_PROGRAM(RM, rm, ALL)
14 dnl DOCS_TARGET_REQUIRE_PROGRAM(DIA, dia, HTML)
15 dnl DOCS_TARGET_REQUIRE_PROGRAM(DIA, dia, HTMLHELP)
16 dnl DOCS_TARGET_REQUIRE_PROGRAM(DIA, dia, PEARSON)
17 dnl DOCS_TARGET_REQUIRE_PROGRAM(DIA, dia, PLUCKER)
18 dnl DOCS_TARGET_REQUIRE_PROGRAM(DIA, dia, FOPDF)
19 DOCS_TARGET_REQUIRE_PROGRAM(INKSCAPE, inkscape, LATEX)
20 DOCS_TARGET_REQUIRE_PROGRAM(INKSCAPE, inkscape, PS)
21 DOCS_TARGET_REQUIRE_PROGRAM(INKSCAPE, inkscape, PDF)
22 DOCS_TARGET_REQUIRE_PROGRAM(INKSCAPE, inkscape, HTML)
23 DOCS_TARGET_REQUIRE_PROGRAM(INKSCAPE, inkscape, HTMLHELP)
24 DOCS_TARGET_REQUIRE_PROGRAM(INKSCAPE, inkscape, PEARSON)
25 DOCS_TARGET_REQUIRE_PROGRAM(INKSCAPE, inkscape, PLUCKER)
26 DOCS_TARGET_REQUIRE_PROGRAM(INKSCAPE, inkscape, FOPDF)
27 # Check dia version number
28
29 #if test -n "$DIA"; then
30 #   [ DIA_VERSION=`$DIA -v | egrep -o '([0-9]+)\.([0-9]+)'`]
31 #   DIA_MAJ_VERSION=`echo $DIA_VERSION | cut -d . -f 1`
32 #   DIA_MIN_VERSION=`echo $DIA_VERSION | cut -d . -f 2`
33
34 #   if test "$DIA_MAJ_VERSION" -le "0"
35 #   then
36 #       if test "$DIA_MIN_VERSION" -le "92" && test -z "$DISPLAY"
37 #       then
38 #               AC_MSG_ERROR([Dia below 0.93 requires an X environment. Set \$DISPLAY or install Dia 0.93 or higher])
39 #       fi
40 #   fi   
41 #fi
42
43 DOCS_TARGET_REQUIRE_PROGRAM(EPSTOPDF, epstopdf, PDF)
44 DOCS_TARGET_REQUIRE_PROGRAM(PNGTOPNM, pngtopnm, PS)
45 DOCS_TARGET_REQUIRE_PROGRAM(PNMTOPS, pnmtops, PS)
46 DOCS_TARGET_REQUIRE_PROGRAM(DBLATEX, dblatex, LATEX)
47 DOCS_TARGET_REQUIRE_PROGRAM(PLUCKERBUILD, plucker-build, PLUCKER)
48 DOCS_TARGET_REQUIRE_PROGRAM(HTML2TEXT, html2text, TXT)
49 DOCS_TARGET_REQUIRE_PROGRAM(PERL, perl, UNDOCUMENTED)
50 DOCS_TARGET_REQUIRE_PROGRAM(XMLLINT, xmllint, VALIDATE)
51 DOCS_TARGET_REQUIRE_PROGRAM(FOP, fop, FOPDF)
52 DOCS_TARGET_REQUIRE_PROGRAM(DB2TEXI, docbook2x-texi, TEXI)
53 DOCS_TARGET_REQUIRE_PROGRAM(MAKEINFO, makeinfo, TEXIINFO)
54
55 AC_MSG_RESULT([])
56 AC_MSG_RESULT([Summary:])
57 AC_MSG_RESULT([--------------])
58
59 DOCS_DEFINE_TARGET(ALL, [], [base requirements], [])
60 DOCS_DEFINE_TARGET(LATEX, ALL, [LaTeX versions], [tex ps pdf])
61 DOCS_DEFINE_TARGET(HTML, ALL, [HTML versions], [html])
62 DOCS_DEFINE_TARGET(HTMLHELP, ALL, [HTML Help versions], [htmlhelp])
63 DOCS_DEFINE_TARGET(HTMLMAN, ALL, [HTML versions of the manpages], [htmlman3])
64 DOCS_DEFINE_TARGET(MANPAGES, ALL, [manpages], [manpages3])
65 DOCS_DEFINE_TARGET(PEARSON, ALL, [pearson-compatible XML], [pearson])
66 DOCS_DEFINE_TARGET(PLUCKER, HTML, [plucker versions], [plucker])
67 DOCS_DEFINE_TARGET(VALIDATE, ALL, [validating docbook output], [])
68 DOCS_DEFINE_TARGET(FOPDF, ALL, [PDF versions thru FO], [fo-pdf])
69 DOCS_DEFINE_TARGET(TEXI, ALL, [TexInfo versions], [texi])
70 DOCS_DEFINE_TARGET(TEXIINFO, ALL, [TexInfo Info versions], [texiinfo])
71 DOCS_DEFINE_TARGET(UNDOCUMENTED, MANPAGES, [list of undocumented options], [undocumented])
72 DOCS_DEFINE_TARGET(TXT, HTML, [text versions], [txt])
73
74 if test x"$TARGETS" = x; then 
75         AC_MSG_ERROR([You won't be able to build any of the docs])
76 else 
77         AC_MSG_RESULT([You will be able to build: $TARGETS])
78 fi
79
80 AC_SUBST(TARGETS)
81
82 AC_OUTPUT( Makefile.settings build/catalog.xml)