r26474: Move credentials-specific kerberos file to credentials subsystem. Fixes missi...
authorJelmer Vernooij <jelmer@samba.org>
Sun, 16 Dec 2007 14:33:58 +0000 (15:33 +0100)
committerStefan Metzmacher <metze@samba.org>
Fri, 21 Dec 2007 04:50:34 +0000 (05:50 +0100)
source/auth/credentials/config.mk
source/auth/credentials/credentials_krb5.h
source/auth/kerberos/config.mk
source/samba4-skip
source/scripting/python/config.mk
source/scripting/python/samba/__init__.py
source/selftest/samba4_tests.sh

index c8fb8c86289334ad5b32c56a0927b77b8701be85..1a6c1487b05c4a1f9576f381a7065ace2a1ef395 100644 (file)
@@ -17,9 +17,10 @@ PRIVATE_DEPENDENCIES = CREDENTIALS_KRB5
 [SUBSYSTEM::CREDENTIALS_KRB5]
 PUBLIC_PROTO_HEADER = credentials_krb5_proto.h
 PUBLIC_HEADERS = credentials_krb5.h
-OBJ_FILES = credentials_krb5.o
+OBJ_FILES = credentials_krb5.o \
+                       ../kerberos/kerberos_util.o
 PUBLIC_DEPENDENCIES = \
-               HEIMDAL_GSSAPI 
+               HEIMDAL_GSSAPI KERBEROS
 # End SUBSYSTEM CREDENTIALS
 #################################
 
index 102650860127a62cc5221ef2eb5358865c4a33f6..bf6047edf32f57c286b8438d3ede16cd2739c773 100644 (file)
@@ -21,6 +21,7 @@
 */
 
 #include <gssapi/gssapi.h>
+#include <krb5.h>
 
 struct ccache_container;
 
index c3f8c6f8cef76300d37b18471d2e003ab71af0b4..7493a6d06d7520ae18a7b2740aa4f77bf84c23b0 100644 (file)
@@ -5,11 +5,10 @@ PRIVATE_PROTO_HEADER = proto.h
 OBJ_FILES = kerberos.o \
                        clikrb5.o \
                        kerberos_heimdal.o \
-                       kerberos_util.o \
                        kerberos_pac.o \
                        gssapi_parse.o \
                        krb5_init_context.o
 PUBLIC_DEPENDENCIES = HEIMDAL_KRB5 NDR_KRB5PAC samba-socket LIBCLI_RESOLVE
-PRIVATE_DEPENDENCIES = ASN1_UTIL auth_sam_reply CREDENTIALS_KRB5 LIBPACKET LIBNDR
+PRIVATE_DEPENDENCIES = ASN1_UTIL auth_sam_reply LIBPACKET LIBNDR
 # End SUBSYSTEM KERBEROS
 #################################
index 0e785b7002316c9afb2a43abcc45299332dfafc2..f0efdfbfa6f842d890d95efaedfccf62ed9845d2 100644 (file)
@@ -49,6 +49,4 @@ RPC-FRSAPI                                                    # Not provided by Samba 4
 ^samba4.NET-API-BECOME-DC.*$                   # Fails
 WINBIND                                                        # FIXME: This should not be skipped
 NSS-TEST                                               # Fails
-samba4.credentials.python              # Fails to link properly
-samba4.registry.python                 # Fails to link properly
-samba4.auth.python                             # Fails to link properly
+samba4.auth.python                             # Missing symbols
index 9d972f7ee0ef48e89f61d3e648cd41d1d827cb77..cf17a28a7083ed33f62caea4517faf31fae3b562 100644 (file)
@@ -25,3 +25,7 @@ PYDOCTOR_MODULES=bin/python/ldb.py bin/python/auth.py bin/python/credentials.py
 
 pydoctor:: pythonmods
        LD_LIBRARY_PATH=bin/shared PYTHONPATH=bin/python pydoctor --make-html --docformat=restructuredtext --add-package scripting/python/samba/ $(addprefix --add-module , $(PYDOCTOR_MODULES))
+
+clean::
+       @echo "Removing python modules"
+       @rm -f bin/python/*
index 00b82e18007128e8e5bfbc922176193602fceea5..2c51440b0cef8b0b03dae4f572c39bd62f0dadaa 100644 (file)
 import os
 from misc import ldb_set_credentials
 
+def _in_source_tree():
+    print os.path.exists("%s/../../../samba4-skip" % os.path.dirname(__file__))
+
+# When running, in-tree, make sure bin/python is in the PYTHONPATH
+if _in_source_tree():
+    import sys
+    dir = os.path.dirname(__file__)
+    sys.path.append("%s/../../../bin/python" % os.path.dirname(__file__))
+
 def Ldb(url, session_info=None, credentials=None, modules_dir=None):
     """Open a Samba Ldb file. 
 
index 424e1f0209c63ca5dbdd29750fd4619594b018e7..eaf72764854ca75d7b36f813c1eed4901fe3838d 100755 (executable)
@@ -212,7 +212,7 @@ if test x"${PIDL_TESTS_SKIP}" = x"yes"; then
    echo "Skipping pidl tests - PIDL_TESTS_SKIP=yes"
 elif $PERL -e 'eval require Test::More;' > /dev/null 2>&1; then
   for f in $samba4srcdir/pidl/tests/*.pl; do
-     plantest "pidl/`basename $f`" none $PERL $f "|" $samba4srcdir/script/harness2subunit.pl
+     plantest "pidl.`basename $f .pl`" none $PERL $f "|" $samba4srcdir/script/harness2subunit.pl
   done
 else 
    echo "Skipping pidl tests - Test::More not installed"
@@ -279,13 +279,6 @@ for env in dc member; do
        done
 done
 
-# Tests for SWIG
-# export PYTHONPATH=lib/tdb/swig:lib/ldb/swig:scripting/swig:$PYTHONPATH
-# export LD_LIBRARY_PATH=bin:$LD_LIBRARY_PATH
-
-# plantest "tdb wrappers" scripting/swig/torture/torture_tdb.py
-# plantest "ldb wrappers" scripting/swig/torture/torture_ldb.py
-
 if test -f $samba4bindir/nsstest 
 then
        plantest "NSS-TEST using winbind" member $VALGRIND $samba4bindir/nsstest $samba4bindir/shared/libnss_winbind.so