r18045: Update format, list "test" target as phony.
authorJelmer Vernooij <jelmer@samba.org>
Mon, 4 Sep 2006 13:47:57 +0000 (13:47 +0000)
committerGerald (Jerry) Carter <jerry@samba.org>
Wed, 10 Oct 2007 19:17:07 +0000 (14:17 -0500)
source/lib/replace/Makefile.in
source/lib/replace/test/testsuite.c

index 1dbc94341b26a7d1fbfb21f1aa1bc9e30304b86f..54196b089a0cf796bdc5a2a56f3854f10cdaf6ef 100644 (file)
@@ -9,6 +9,8 @@ srcdir = @srcdir@
 builddir = @builddir@
 INSTALL = @INSTALL@
 
+.PHONY: test
+
 CFLAGS=-I. -I$(srcdir) @CFLAGS@
 
 OBJS = dlfcn.o getpass.o replace.o snprintf.o timegm.o
index 5d20c345f8a3ddc3b9527547900264dd9e70d396..998715f63fcfe4d4bf07c2747cae166fd82229f0 100644 (file)
@@ -96,7 +96,7 @@ static int test_strlcpy()
        printf("testing strlcpy\n");
        for (i=0;tests[i].src;i++) {
                if (strlcpy(buf, tests[i].src, sizeof(buf)) != tests[i].result) {
-                       printf("strlcpy test %d failed\n");
+                       printf("strlcpy test %d failed\n", i);
                        return false;
                }
        }