r23306: pass down LDFLAGS to the link command in the libreplace standalone build
authorStefan Metzmacher <metze@samba.org>
Sat, 2 Jun 2007 08:16:42 +0000 (08:16 +0000)
committerGerald (Jerry) Carter <jerry@samba.org>
Wed, 10 Oct 2007 19:53:10 +0000 (14:53 -0500)
metze

source/lib/replace/Makefile.in
source/lib/replace/configure.ac

index 41454f6ec42322af783e511661bd1beec22fa988..30f39ac6cb4b92c75a9e0b3ff0da402b147c5f8f 100644 (file)
@@ -14,6 +14,7 @@ INSTALL = @INSTALL@
 .PHONY: test all showflags install installcheck clean distclean realdistclean
 
 CFLAGS=-I. @CFLAGS@
+LDFLAGS=@LDFLAGS@
 
 OBJS = @LIBREPLACEOBJ@
 
@@ -23,7 +24,7 @@ showflags:
        @echo 'libreplace will be compiled with flags:'
        @echo '  CC     = $(CC)'
        @echo '  CFLAGS = $(CFLAGS)'
-       @echo '  LIBS   = $(LIBS)'
+       @echo '  LDFLAGS= $(LDFLAGS)'
 
 install: all
        mkdir -p $(libdir)
@@ -40,7 +41,7 @@ installcheck: install test
 TEST_OBJS = test/testsuite.o test/os2_delete.o test/strptime.o
 
 testsuite: libreplace.a $(TEST_OBJS)
-       $(CC) -o testsuite $(TEST_OBJS) -L. -lreplace
+       $(CC) -o testsuite $(TEST_OBJS) -L. -lreplace $(LDFLAGS)
 
 .c.o:
        @echo Compiling $*.c
index 48fb7ce25948dd63f38e744baac6637615e4bd25..beeb77e15204a6d7bb7f0b22bfe3003d2218a06b 100644 (file)
@@ -19,4 +19,6 @@ if test "$ac_cv_prog_gcc" = yes; then
    CFLAGS="$CFLAGS -Wno-format-y2k"
 fi
 
+AC_SUBST(LDFLAGS)
+
 AC_OUTPUT(Makefile)