CVE-2016-2111: s4:smb_server: implement "raw NTLMv2 auth" checks