CVE-2016-2115: s4:libcli/smb2: use the configured min_protocol