s4-waf: we need a recent version of perls MakeMaker module