WHATSNEW: Document new GnuTLS 3.4.7 requirement
authorAndrew Bartlett <abartlet@samba.org>
Mon, 26 Aug 2019 02:39:40 +0000 (14:39 +1200)
committerAndrew Bartlett <abartlet@samba.org>
Tue, 27 Aug 2019 06:01:50 +0000 (06:01 +0000)
Signed-off-by: Andrew Bartlett <abartlet@samba.org>
Reviewed-by: Gary Lockyer <gary@catalyst.net.nz>
Autobuild-User(master): Andrew Bartlett <abartlet@samba.org>
Autobuild-Date(master): Tue Aug 27 06:01:50 UTC 2019 on sn-devel-184

WHATSNEW.txt

index 9abc453812502f0d2fadb33ad6c8a8e69e853aee..c3b99dbee80705e32a660c8532c91b59f5b7e616 100644 (file)
@@ -17,6 +17,28 @@ NEW FEATURES/CHANGES
 ====================
 
 
 ====================
 
 
+GnuTLS 3.4.7 required
+---------------------
+
+Samba is making efforts to remove in-tree cryptographic functionality,
+and to instead rely on externally maintained libraries.  To this end,
+Samba has chosen GnuTLS as our standard cryptographic provider.
+
+Samba now requires GnuTLS 3.4.7 to be installed (including development
+headers at build time) for all configurations, not just the Samba AD
+DC.
+
+NOTE WELL: The use of GnuTLS means that Samba will honour the
+system-wide 'FIPS mode' (a reference to the US FIPS-140 cryptographic
+standard) and so will not operate in many still common situations if
+this system-wide parameter is in effect, as many of our protocols rely
+on outdated cryptography.
+
+A future Samba version will mitigate this to some extent where good
+cryptography effectively wraps bad cryptography, but for now that above
+applies.
+
+
 REMOVED FEATURES
 ================
 
 REMOVED FEATURES
 ================