build: Remove manual specification of minimum python version
authorAndrew Bartlett <abartlet@samba.org>
Fri, 15 Feb 2019 03:04:53 +0000 (16:04 +1300)
committerAndrew Bartlett <abartlet@samba.org>
Thu, 21 Mar 2019 04:06:16 +0000 (04:06 +0000)
We now used the default of 3.4 from conf.SAMBA_CHECK_PYTHON()

Signed-off-by: Andrew Bartlett <abartlet@samba.org>
Reviewed-by: Douglas Bagnall <douglas.bagnall@catalyst.net.nz>
ctdb/wscript
lib/talloc/wscript
wscript

index 4adf600..15dd757 100644 (file)
@@ -140,7 +140,7 @@ def configure(conf):
     if conf.env.standalone_ctdb:
         conf.SAMBA_CHECK_PERL(mandatory=True)
 
-        conf.SAMBA_CHECK_PYTHON(mandatory=False, version=(2,5,0))
+        conf.SAMBA_CHECK_PYTHON(mandatory=False)
         conf.SAMBA_CHECK_PYTHON_HEADERS(mandatory=False)
 
     if conf.CHECK_FOR_THIRD_PARTY():
index 81d12f8..827ae88 100644 (file)
@@ -62,7 +62,7 @@ def configure(conf):
 
     if not conf.env.disable_python:
         # also disable if we don't have the python libs installed
-        conf.SAMBA_CHECK_PYTHON(mandatory=False, version=(2,4,2))
+        conf.SAMBA_CHECK_PYTHON(mandatory=False)
         conf.SAMBA_CHECK_PYTHON_HEADERS(mandatory=False)
         if not conf.env.HAVE_PYTHON_H:
             Logs.warn('Disabling pytalloc-util as python devel libs not found')
diff --git a/wscript b/wscript
index ff6dae2..a0a8080 100644 (file)
--- a/wscript
+++ b/wscript
@@ -151,8 +151,7 @@ def configure(conf):
         if not (Options.options.without_ad_dc):
             raise Errors.WafError('--disable-python requires --without-ad-dc')
 
-    conf.SAMBA_CHECK_PYTHON(mandatory=not conf.env.disable_python,
-                            version=(2, 6, 0))
+    conf.SAMBA_CHECK_PYTHON(mandatory=not conf.env.disable_python)
     conf.SAMBA_CHECK_PYTHON_HEADERS(mandatory=(not conf.env.disable_python))
 
     if sys.platform == 'darwin' and not conf.env['HAVE_ENVIRON_DECL']: