ldb: Use pyembed rather than pyext for ldb-util library.
authorJelmer Vernooij <jelmer@samba.org>
Sat, 12 Nov 2011 14:51:16 +0000 (15:51 +0100)
committerJelmer Vernooij <jelmer@samba.org>
Sun, 13 Nov 2011 17:06:06 +0000 (18:06 +0100)
buildtools/wafsamba/wafsamba.py
lib/ldb/wscript

index 0a120da..21b91e4 100644 (file)
@@ -172,6 +172,7 @@ def SAMBA_LIBRARY(bld, libname, source,
                         autoproto_extra_source=autoproto_extra_source,
                         depends_on     = depends_on,
                         hide_symbols   = hide_symbols,
+                        pyembed        = pyembed,
                         pyext          = pyext or (target_type == "PYTHON"),
                         local_include  = local_include,
                         global_include = global_include)
@@ -491,7 +492,8 @@ def SAMBA_SUBSYSTEM(bld, modname, source,
                     vars=None,
                     subdir=None,
                     hide_symbols=False,
-                    pyext=False):
+                    pyext=False,
+                    pyembed=False):
     '''define a Samba subsystem'''
 
     if not enabled:
@@ -518,6 +520,8 @@ def SAMBA_SUBSYSTEM(bld, modname, source,
     features = 'cc'
     if pyext:
         features += ' pyext'
+    if pyembed:
+        features += ' pyembed'
 
     t = bld(
         features       = features,
index 3772871..0437383 100755 (executable)
@@ -120,7 +120,7 @@ def build(bld):
                           vnum=VERSION,
                           private_library=private_library,
                           pc_files='pyldb-util.pc',
-                          pyext=True,
+                          pyembed=True,
                           abi_directory='ABI',
                           abi_match='pyldb_*')