CVE-2016-2111: auth/gensec: require DCERPC_AUTH_LEVEL_INTEGRITY or higher in schannel...
authorStefan Metzmacher <metze@samba.org>
Tue, 15 Dec 2015 14:11:32 +0000 (15:11 +0100)
committerStefan Metzmacher <metze@samba.org>
Tue, 12 Apr 2016 17:25:23 +0000 (19:25 +0200)
commit2200d49cc6452e15a4429f5cb0aaa27eecd13243
tree97883f878dff105fe1f091e5c865b7eab8d09ab4
parent0d641ee36ae2c2e47708587c5fc20eb1dc5d92d0
CVE-2016-2111: auth/gensec: require DCERPC_AUTH_LEVEL_INTEGRITY or higher in schannel_update()

It doesn't make any sense to allow other auth levels.

BUG: https://bugzilla.samba.org/show_bug.cgi?id=11749

Signed-off-by: Stefan Metzmacher <metze@samba.org>
Reviewed-by: G√ľnther Deschner <gd@samba.org>
auth/gensec/schannel.c