Fixed spelling typo in Kerberos configure option.
[samba.git] / source3 / configure.in
index 9176afcbf36e11ad13825ae3e4a9fc7e551e0a8b..efe2b952d4bb3c3e9f6e4bff7e44273805c94687 100644 (file)
@@ -52,16 +52,17 @@ AC_HEADER_DIRENT
 AC_HEADER_TIME
 AC_HEADER_SYS_WAIT
 AC_CHECK_HEADERS(sys/fcntl.h sys/select.h fcntl.h sys/time.h sys/unistd.h)
+AC_CHECK_HEADERS(sys/param.h ctype.h )
 AC_CHECK_HEADERS(unistd.h utime.h grp.h sys/id.h limits.h memory.h net/route.h net/if.h)
 AC_CHECK_HEADERS(compat.h rpc/rpc.h rpcsvc/yp_prot.h rpcsvc/ypclnt.h sys/param.h ctype.h )
-AC_CHECK_HEADERS(sys/wait.h sys/resource.h sys/ioctl.h sys/mode.h)
+AC_CHECK_HEADERS(sys/wait.h sys/resource.h sys/ioctl.h sys/mode.h sys/mman.h)
 AC_CHECK_HEADERS(sys/filio.h string.h strings.h stdlib.h sys/socket.h)
 AC_CHECK_HEADERS(sys/mount.h sys/vfs.h sys/fs/s5param.h sys/filsys.h termios.h)
 AC_CHECK_HEADERS(sys/statfs.h sys/dustat.h sys/statvfs.h stdarg.h sys/sockio.h)
 AC_CHECK_HEADERS(shadow.h netinet/tcp.h sys/security.h security/pam_appl.h)
 AC_CHECK_HEADERS(stropts.h poll.h readline.h history.h readline/readline.h)
 AC_CHECK_HEADERS(readline/history.h sys/capability.h syscall.h sys/syscall.h)
-AC_CHECK_HEADERS(sys/acl.h sys/cdefs.h glob.h)
+AC_CHECK_HEADERS(sys/acl.h sys/cdefs.h glob.h mysql.h)
 
 AC_CHECK_SIZEOF(int,cross)
 AC_CHECK_SIZEOF(long,cross)
@@ -185,14 +186,14 @@ if test x"$ac_cv_func_connect" = x"no"; then
 fi
 
 
-AC_CHECK_FUNCS(waitpid getcwd strdup strerror chown chmod chroot)
+AC_CHECK_FUNCS(waitpid getcwd strdup strtoul strerror chown chmod chroot)
 AC_CHECK_FUNCS(fstat strchr utime utimes getrlimit fsync execl bzero memset)
 AC_CHECK_FUNCS(memmove vsnprintf snprintf setsid glob strpbrk pipe crypt16 getauthuid)
 AC_CHECK_FUNCS(strftime sigprocmask sigblock sigaction innetgr setnetgrent getnetgrent endnetgrent)
-AC_CHECK_FUNCS(initgroups select rdchk getgrnam pathconf putprpwnam)
+AC_CHECK_FUNCS(initgroups select rdchk getgrnam pathconf)
 AC_CHECK_FUNCS(setuidx setgroups mktime rename ftruncate stat64 fstat64 lstat64 fopen64)
-AC_CHECK_FUNCS(set_auth_parameters atexit grantpt getspnam dup2 lseek64 ftruncate64)
-AC_CHECK_FUNCS(fseek64 ftell64 bigcrypt getprpwnam setluid yp_get_default_domain getpwanam)
+AC_CHECK_FUNCS(atexit grantpt dup2 lseek64 ftruncate64)
+AC_CHECK_FUNCS(fseek64 ftell64 setluid yp_get_default_domain getpwanam)
 AC_CHECK_FUNCS(srandom random srand rand setenv mmap64)
 # syscall() is needed for smbwrapper.
 AC_CHECK_FUNCS(syscall)
@@ -218,80 +219,20 @@ AC_CHECK_FUNCS(open64 _open64 __open64 creat64)
 # Needed for OSF1 and HPUX.
 #
 
-if test x"$ac_cv_func_putprpwnam" = x"no"; then
-    case "$LIBS" in
-    *-lsecurity*) ;;
-    *) AC_CHECK_LIB(security, putprpwnam) ;;
-    esac
-    case "$LIBS" in
-    *-lsec*) ;;
-    *) AC_CHECK_LIB(sec, putprpwnam) ;;
-    esac
-    if test x"$ac_cv_lib_security_putprpwnam" = x"yes" ||
-       test x"$ac_cv_lib_sec_putprpwnam" = x"yes"; then
-        AC_DEFINE(HAVE_PUTPRPWNAM)
-    fi
-fi
+AC_LIBTESTFUNC(security, putprpwnam)
+AC_LIBTESTFUNC(sec, putprpwnam)
 
-if test x"$ac_cv_func_set_auth_parameters" = x"no"; then
-    case "$LIBS" in
-    *-lsecurity*) ;;
-    *) AC_CHECK_LIB(security, set_auth_parameters) ;;
-    esac
-    case "$LIBS" in
-    *-lsec*) ;;
-    *) AC_CHECK_LIB(sec, set_auth_parameters) ;;
-    esac
-    if test x"$ac_cv_lib_security_set_auth_parameters" = x"yes" ||
-       test x"$ac_cv_lib_sec_set_auth_parameters" = x"yes"; then
-        AC_DEFINE(HAVE_SET_AUTH_PARAMETERS)
-    fi
-fi
+AC_LIBTESTFUNC(security, set_auth_parameters)
+AC_LIBTESTFUNC(sec, set_auth_parameters)
 
-if test x"$ac_cv_func_getspnam" = x"no"; then
-    case "$LIBS" in
-    *-lsecurity*) ;;
-    *) AC_CHECK_LIB(security, getspnam) ;;
-    esac
-    case "$LIBS" in
-    *-lsec*) ;;
-    *) AC_CHECK_LIB(sec, getspnam) ;;
-    esac
-    if test x"$ac_cv_lib_security_getspnam" = x"yes" ||
-       test x"$ac_cv_lib_sec_getspnam" = x"yes"; then
-        AC_DEFINE(HAVE_GETSPNAM)
-    fi
-fi
+AC_LIBTESTFUNC(security, getspnam)
+AC_LIBTESTFUNC(sec, getspnam)
 
-if test x"$ac_cv_func_bigcrypt" = x"no"; then
-    case "$LIBS" in
-    *-lsecurity*) ;;
-    *) AC_CHECK_LIB(security, bigcrypt) ;;
-    esac
-    case "$LIBS" in
-    *-lsec*) ;;
-    *) AC_CHECK_LIB(sec, bigcrypt) ;;
-    esac
-    if test x"$ac_cv_lib_security_bigcrypt" = x"yes" ||
-       test x"$ac_cv_lib_sec_bigcrypt" = x"yes"; then
-        AC_DEFINE(HAVE_BIGCRYPT)
-    fi
-fi
+AC_LIBTESTFUNC(security, bigcrypt)
+AC_LIBTESTFUNC(sec, bigcrypt)
 
-if test x"$ac_cv_func_getprpwnam" = x"no"; then
-    case "$LIBS" in
-    *-lsecurity*) ;;
-    *) AC_CHECK_LIB(security, getprpwnam) ;;
-    esac
-    case "$LIBS" in
-    *-lsec*) ;;
-    *) AC_CHECK_LIB(sec, getprpwnam) ;;
-    esac
-    if test x"$ac_cv_lib_security_getprpwnam" = x"yes" ||
-       test x"$ac_cv_lib_sec_getprpwnam" = x"yes"; then
-        AC_DEFINE(HAVE_GETPRPWNAM)
-    fi
-fi
+AC_LIBTESTFUNC(security, getprpwnam)
+AC_LIBTESTFUNC(sec, getprpwnam)
 
 # this bit needs to be modified for each OS that is suported by
 # smbwrapper. You need to specify how to created a shared library and
@@ -775,7 +716,7 @@ AC_ARG_WITH(dfs,
 AC_MSG_CHECKING(whether to use Kerberos IV)
 AC_ARG_WITH(krb4,
 [  --with-krb4=base-dir     Include Kerberos IV support
-  --whithout-krb4          Don't include Kerbers IV support (default)],
+  --without-krb4          Don't include Kerberos IV support (default)],
 [   AC_MSG_RESULT(yes)
     AC_DEFINE(KRB4_AUTH)
     AC_CHECK_LIB(resolv, dn_expand)
@@ -834,6 +775,7 @@ AC_ARG_WITH(ldap,
   yes)
     AC_MSG_RESULT(yes)
     AC_DEFINE(WITH_LDAP)
+    LIBS="$LIBS -lldap -llber"
     ;;
   *)
     AC_MSG_RESULT(no)
@@ -932,6 +874,25 @@ AC_ARG_WITH(syslog,
   AC_MSG_RESULT(no)
 )
 
+#################################################
+# check for a shared memory profiling support
+AC_MSG_CHECKING(whether to use profiling)
+AC_ARG_WITH(profile,
+[  --with-profile     Include profile support
+  --without-profile  Don't include profile support (default)],
+[ case "$withval" in
+  yes)
+    AC_MSG_RESULT(yes)
+    AC_DEFINE(WITH_PROFILE)
+    ;;
+  *)
+    AC_MSG_RESULT(no)
+    ;;
+  esac ],
+  AC_MSG_RESULT(no)
+)
+
+
 #################################################
 # check for experimental netatalk resource fork support
 AC_MSG_CHECKING(whether to support netatalk)