Fix typo in comment.
[samba.git] / source3 / configure.in
index e44aa5a52f53a018ee68e6c90b23169ff425ea84..a8ae1c760e359375f3c80968bd5525b6116aac23 100644 (file)
@@ -729,7 +729,7 @@ if test x"$ac_cv_func_connect" = x"no"; then
 fi
 
 ###############################################
-# test for where we get get_yp_default_domain() from
+# test for where we get yp_get_default_domain() from
 AC_CHECK_FUNCS(yp_get_default_domain)
 if test x"$ac_cv_func_yp_get_default_domain" = x"no"; then
        AC_CHECK_LIB(nsl, yp_get_default_domain, [LIBS="$LIBS -lnsl";
@@ -1188,13 +1188,6 @@ if test x"$samba_cv_SEEKDIR_RETURNS_VOID" = x"yes"; then
     AC_DEFINE(SEEKDIR_RETURNS_VOID,1,[Whether seekdir returns void])
 fi
 
-AC_CACHE_CHECK([for __FILE__ macro],samba_cv_HAVE_FILE_MACRO,[
-AC_TRY_COMPILE([#include <stdio.h>], [printf("%s\n", __FILE__);],
-samba_cv_HAVE_FILE_MACRO=yes,samba_cv_HAVE_FILE_MACRO=no)])
-if test x"$samba_cv_HAVE_FILE_MACRO" = x"yes"; then
-    AC_DEFINE(HAVE_FILE_MACRO,1,[Whether there is a __FILE__ macro])
-fi
-
 AC_CACHE_CHECK([for __FUNCTION__ macro],samba_cv_HAVE_FUNCTION_MACRO,[
 AC_TRY_COMPILE([#include <stdio.h>], [printf("%s\n", __FUNCTION__);],
 samba_cv_HAVE_FUNCTION_MACRO=yes,samba_cv_HAVE_FUNCTION_MACRO=no)])
@@ -2852,20 +2845,21 @@ samba_cv_HAVE_BROKEN_LINUX_SENDFILE=yes,samba_cv_HAVE_BROKEN_LINUX_SENDFILE=no)]
                AC_CACHE_CHECK([for freebsd sendfile support],samba_cv_HAVE_SENDFILE,[
                AC_TRY_LINK([\
 #include <sys/types.h>
+#include <unistd.h>
 #include <sys/socket.h>
 #include <sys/uio.h>],
 [\
-       int fromfd, tofd;
+       int fromfd, tofd, ret, total=0;
        off_t offset, nwritten;
        struct sf_hdtr hdr;
        struct iovec hdtrl;
-       hdr->headers = &hdtrl;
-       hdr->hdr_cnt = 1;
-       hdr->trailers = NULL;
-       hdr->trl_cnt = 0;
+       hdr.headers = &hdtrl;
+       hdr.hdr_cnt = 1;
+       hdr.trailers = NULL;
+       hdr.trl_cnt = 0;
        hdtrl.iov_base = NULL;
        hdtrl.iov_len = 0;
-       int ret = sendfile(fromfd, tofd, offset, total, &hdr, &nwritten, 0);
+       ret = sendfile(fromfd, tofd, offset, total, &hdr, &nwritten, 0);
 ],
 samba_cv_HAVE_SENDFILE=yes,samba_cv_HAVE_SENDFILE=no)])