CVE-2016-2112: docs-xml: add "ldap server require strong auth" option
[samba.git] / lib / param / param_table.c
index 1ebb2f89121e0fb7ffbbd719bdf3adcae543ba20..be4881f9249b73185140a4f9041cebea63f32708 100644 (file)
@@ -223,6 +223,18 @@ static const struct enum_list enum_ldap_sasl_wrapping[] = {
        {-1, NULL}
 };
 
+static const struct enum_list enum_ldap_server_require_strong_auth_vals[] = {
+       { LDAP_SERVER_REQUIRE_STRONG_AUTH_NO, "No" },
+       { LDAP_SERVER_REQUIRE_STRONG_AUTH_NO, "False" },
+       { LDAP_SERVER_REQUIRE_STRONG_AUTH_NO, "0" },
+       { LDAP_SERVER_REQUIRE_STRONG_AUTH_ALLOW_SASL_OVER_TLS,
+         "allow_sasl_over_tls" },
+       { LDAP_SERVER_REQUIRE_STRONG_AUTH_YES, "Yes" },
+       { LDAP_SERVER_REQUIRE_STRONG_AUTH_YES, "True" },
+       { LDAP_SERVER_REQUIRE_STRONG_AUTH_YES, "1" },
+       {-1, NULL}
+};
+
 static const struct enum_list enum_ldap_ssl[] = {
        {LDAP_SSL_OFF, "no"},
        {LDAP_SSL_OFF, "off"},