CVE-2016-2112: docs-xml: add "ldap server require strong auth" option
[samba.git] / lib / param / loadparm.h
index b453aca5ef705d436d80d1f893db6a60f8f6e008..aa256c17afda3481baffa4dce78c9be6ffbe2c1e 100644 (file)
@@ -204,6 +204,12 @@ enum printing_types {PRINT_BSD,PRINT_SYSV,PRINT_AIX,PRINT_HPUX,
 #define ADS_AUTH_SASL_FORCE       0x0080
 #define ADS_AUTH_USER_CREDS       0x0100
 
+enum ldap_server_require_strong_auth {
+       LDAP_SERVER_REQUIRE_STRONG_AUTH_NO,
+       LDAP_SERVER_REQUIRE_STRONG_AUTH_ALLOW_SASL_OVER_TLS,
+       LDAP_SERVER_REQUIRE_STRONG_AUTH_YES,
+};
+
 /* DNS update settings */
 enum dns_update_settings {DNS_UPDATE_OFF, DNS_UPDATE_ON, DNS_UPDATE_SIGNED};