CVE-2016-2112: docs-xml: add "ldap server require strong auth" option
[samba.git] / lib / param / loadparm.c
index 696c2d679905ccb42128ae6126dc3c4a3ac21b97..d26a3f819c19b5bca25b04c3a02a3e6274b7c2c3 100644 (file)
@@ -2810,6 +2810,8 @@ struct loadparm_context *loadparm_init(TALLOC_CTX *mem_ctx)
 
        lpcfg_do_global_parameter(lp_ctx, "client ldap sasl wrapping", "sign");
 
+       lpcfg_do_global_parameter(lp_ctx, "ldap server require strong auth", "no");
+
        lpcfg_do_global_parameter(lp_ctx, "follow symlinks", "yes");
 
        lpcfg_do_global_parameter(lp_ctx, "machine password timeout", "604800");