build: added --minimum-library-version configure option
[samba.git] / buildtools / wafsamba / wscript
index 1ae6b976403b547f60d366a43ee668a22798fc73..2e42139bb9dc884eeac0f81b56405761b33679ef 100644 (file)
@@ -30,6 +30,10 @@ def set_options(opt):
                    help=("command separated list of libraries to build directly into binaries [%s]" % builtin_defauilt),
                    action="store", dest='BUILTIN_LIBRARIES', default=builtin_defauilt)
 
+    opt.add_option('--minimum-library-version',
+                   help=("list of minimum system library versions (LIBNAME1:version,LIBNAME2:version)"),
+                   action="store", dest='MINIMUM_LIBRARY_VERSION', default='')
+
     opt.add_option('--with-modulesdir',
                    help=("modules directory [PREFIX/modules]"),
                    action="store", dest='MODULESDIR', default='${PREFIX}/modules')