smbd: Simplify logic in fsp_lease_update
[samba.git] / wscript
1 #!/usr/bin/env python
2
3 top = '.'
4 out = 'bin'
5
6 APPNAME='samba'
7 VERSION=None
8
9 import sys, os, tempfile
10 sys.path.insert(0, top+"/buildtools/wafsamba")
11 import shutil
12 import wafsamba, samba_dist, samba_git, samba_version, samba_utils
13 from waflib import Options, Scripting, Logs, Context, Errors
14
15 samba_dist.DIST_DIRS('.')
16 samba_dist.DIST_BLACKLIST('.gitignore .bzrignore source4/selftest/provisions')
17
18 # install in /usr/local/samba by default
19 default_prefix = Options.default_prefix = '/usr/local/samba'
20
21 # This callback optionally takes a list of paths as arguments:
22 # --with-system_mitkrb5 /path/to/krb5 /another/path
23 def system_mitkrb5_callback(option, opt, value, parser):
24     setattr(parser.values, option.dest, True)
25     value = []
26     for arg in parser.rargs:
27         # stop on --foo like options
28         if arg[:2] == "--" and len(arg) > 2:
29             break
30         value.append(arg)
31     if len(value)>0:
32         del parser.rargs[:len(value)]
33         setattr(parser.values, option.dest, value)
34
35 def options(opt):
36     opt.BUILTIN_DEFAULT('NONE')
37     opt.PRIVATE_EXTENSION_DEFAULT('samba4')
38     opt.RECURSE('lib/audit_logging')
39     opt.RECURSE('lib/replace')
40     opt.RECURSE('dynconfig')
41     opt.RECURSE('packaging')
42     opt.RECURSE('lib/ldb')
43     opt.RECURSE('selftest')
44     opt.RECURSE('source4/lib/tls')
45     opt.RECURSE('source4/dsdb/samdb/ldb_modules')
46     opt.RECURSE('pidl')
47     opt.RECURSE('source3')
48     opt.RECURSE('lib/util')
49     opt.RECURSE('lib/crypto')
50     opt.RECURSE('ctdb')
51
52
53     opt.samba_add_onoff_option('pthreadpool', with_name="enable", without_name="disable", default=True)
54
55     opt.add_option('--with-system-mitkrb5',
56                    help='build Samba with system MIT Kerberos. ' +
57                         'You may specify list of paths where Kerberos is installed (e.g. /usr/local /usr/kerberos) to search krb5-config',
58                    action='callback', callback=system_mitkrb5_callback, dest='with_system_mitkrb5', default=False)
59     opt.add_option('--with-system-mitkdc',
60                    help=('Specify the path to the krb5kdc binary from MIT Kerberos'),
61                    type="string",
62                    dest='with_system_mitkdc',
63                    default=None)
64
65     opt.add_option('--with-system-heimdalkrb5',
66                    help=('build Samba with system Heimdal Kerberos. ' +
67                          'Requires --without-ad-dc' and
68                          'conflicts with --with-system-mitkrb5'),
69                    action='store_true',
70                    dest='with_system_heimdalkrb5',
71                    default=False)
72
73     opt.add_option('--without-ad-dc',
74                    help='disable AD DC functionality (enables only Samba FS (File Server, Winbind, NMBD) and client utilities.',
75                    action='store_true', dest='without_ad_dc', default=False)
76
77     opt.add_option('--with-ntvfs-fileserver',
78                    help='enable the deprecated NTVFS file server from the original Samba4 branch (default if --enable-selftest specified).  Conflicts with --with-system-mitkrb5 and --without-ad-dc',
79                    action='store_true', dest='with_ntvfs_fileserver')
80
81     opt.add_option('--without-ntvfs-fileserver',
82                    help='disable the deprecated NTVFS file server from the original Samba4 branch',
83                    action='store_false', dest='with_ntvfs_fileserver')
84
85     opt.add_option('--with-pie',
86                   help=("Build Position Independent Executables " +
87                         "(default if supported by compiler)"),
88                   action="store_true", dest='enable_pie')
89     opt.add_option('--without-pie',
90                   help=("Disable Position Independent Executable builds"),
91                   action="store_false", dest='enable_pie')
92
93     opt.add_option('--with-relro',
94                   help=("Build with full RELocation Read-Only (RELRO)" +
95                         "(default if supported by compiler)"),
96                   action="store_true", dest='enable_relro')
97     opt.add_option('--without-relro',
98                   help=("Disable RELRO builds"),
99                   action="store_false", dest='enable_relro')
100
101     gr = opt.option_group('developer options')
102
103     opt.load('python') # options for disabling pyc or pyo compilation
104     # enable options related to building python extensions
105
106
107 def configure(conf):
108     version = samba_version.load_version(env=conf.env)
109
110     conf.DEFINE('CONFIG_H_IS_FROM_SAMBA', 1)
111     conf.DEFINE('_SAMBA_BUILD_', version.MAJOR, add_to_cflags=True)
112     conf.DEFINE('HAVE_CONFIG_H', 1, add_to_cflags=True)
113
114     if Options.options.developer:
115         conf.ADD_CFLAGS('-DDEVELOPER -DDEBUG_PASSWORD')
116         conf.env.DEVELOPER = True
117         # if we are in a git tree without a pre-commit hook, install a
118         # simple default.
119         pre_commit_hook = os.path.join(Context.g_module.top, '.git/hooks/pre-commit')
120         if (os.path.isdir(os.path.dirname(pre_commit_hook)) and
121             not os.path.exists(pre_commit_hook)):
122             shutil.copy(os.path.join(Context.g_module.top, 'script/git-hooks/pre-commit-hook'),
123                         pre_commit_hook)
124
125     conf.ADD_EXTRA_INCLUDES('#include/public #source4 #lib #source4/lib #source4/include #include #lib/replace')
126
127     conf.env.replace_add_global_pthread = True
128     conf.RECURSE('lib/replace')
129
130     conf.RECURSE('examples/fuse')
131     conf.RECURSE('examples/winexe')
132
133     conf.SAMBA_CHECK_PERL(mandatory=True)
134     conf.find_program('xsltproc', var='XSLTPROC')
135
136     if conf.env.disable_python:
137         if not (Options.options.without_ad_dc):
138             raise Errors.WafError('--disable-python requires --without-ad-dc')
139
140     conf.SAMBA_CHECK_PYTHON(mandatory=True, version=(2, 6, 0))
141     conf.SAMBA_CHECK_PYTHON_HEADERS(mandatory=(not conf.env.disable_python))
142
143     if sys.platform == 'darwin' and not conf.env['HAVE_ENVIRON_DECL']:
144         # Mac OSX needs to have this and it's also needed that the python is compiled with this
145         # otherwise you face errors about common symbols
146         if not conf.CHECK_SHLIB_W_PYTHON("Checking if -fno-common is needed"):
147             conf.ADD_CFLAGS('-fno-common')
148         if not conf.CHECK_SHLIB_W_PYTHON("Checking if -undefined dynamic_lookup is not need"):
149             conf.env.append_value('cshlib_LINKFLAGS', ['-undefined', 'dynamic_lookup'])
150
151     if sys.platform == 'darwin':
152         conf.ADD_LDFLAGS('-framework CoreFoundation')
153
154     if int(conf.env['PYTHON_VERSION'][0]) >= 3:
155         raise Errors.WafError('Python version 3.x is not supported by Samba yet')
156
157     conf.RECURSE('dynconfig')
158     conf.RECURSE('selftest')
159
160     if conf.CHECK_FOR_THIRD_PARTY():
161         conf.RECURSE('third_party')
162     else:
163         if not conf.CHECK_ZLIB():
164             raise Errors.WafError('zlib development packages have not been found.\nIf third_party is installed, check that it is in the proper place.')
165         else:
166             conf.define('USING_SYSTEM_ZLIB',1)
167
168         if not conf.CHECK_POPT():
169             raise Errors.WafError('popt development packages have not been found.\nIf third_party is installed, check that it is in the proper place.')
170         else:
171             conf.define('USING_SYSTEM_POPT', 1)
172
173         if not conf.CHECK_CMOCKA():
174             raise Errors.WafError('cmocka development packages has not been found.\nIf third_party is installed, check that it is in the proper place.')
175         else:
176             conf.define('USING_SYSTEM_CMOCKA', 1)
177
178         if conf.CONFIG_GET('ENABLE_SELFTEST'):
179             if not conf.CHECK_SOCKET_WRAPPER():
180                 raise Errors.WafError('socket_wrapper package has not been found.\nIf third_party is installed, check that it is in the proper place.')
181             else:
182                 conf.define('USING_SYSTEM_SOCKET_WRAPPER', 1)
183
184             if not conf.CHECK_NSS_WRAPPER():
185                 raise Errors.WafError('nss_wrapper package has not been found.\nIf third_party is installed, check that it is in the proper place.')
186             else:
187                 conf.define('USING_SYSTEM_NSS_WRAPPER', 1)
188
189             if not conf.CHECK_RESOLV_WRAPPER():
190                 raise Errors.WafError('resolv_wrapper package has not been found.\nIf third_party is installed, check that it is in the proper place.')
191             else:
192                 conf.define('USING_SYSTEM_RESOLV_WRAPPER', 1)
193
194             if not conf.CHECK_UID_WRAPPER():
195                 raise Errors.WafError('uid_wrapper package has not been found.\nIf third_party is installed, check that it is in the proper place.')
196             else:
197                 conf.define('USING_SYSTEM_UID_WRAPPER', 1)
198
199             if not conf.CHECK_PAM_WRAPPER():
200                 raise Errors.WafError('pam_wrapper package has not been found.\nIf third_party is installed, check that it is in the proper place.')
201             else:
202                 conf.define('USING_SYSTEM_PAM_WRAPPER', 1)
203
204     conf.RECURSE('lib/ldb')
205
206     if conf.CHECK_LDFLAGS(['-Wl,--wrap=test']):
207         conf.env['HAVE_LDWRAP'] = True
208         conf.define('HAVE_LDWRAP', 1)
209
210     if not (Options.options.without_ad_dc):
211         conf.DEFINE('AD_DC_BUILD_IS_ENABLED', 1)
212
213     if Options.options.with_system_mitkrb5:
214         conf.PROCESS_SEPARATE_RULE('system_mitkrb5')
215     if not (Options.options.without_ad_dc or Options.options.with_system_mitkrb5):
216         conf.DEFINE('AD_DC_BUILD_IS_ENABLED', 1)
217
218     if Options.options.with_system_heimdalkrb5:
219         if Options.options.with_system_mitkrb5:
220             raise Utils.WafError('--with-system-heimdalkrb5 conflicts with ' +
221                                  '--with-system-mitkrb5')
222         if not Options.options.without_ad_dc:
223             raise Utils.WafError('--with-system-heimdalkrb5 requires ' +
224                                  '--without-ad-dc')
225         conf.env.SYSTEM_LIBS += ('heimdal', 'asn1', 'com_err', 'roken',
226                                  'hx509', 'wind', 'gssapi', 'hcrypto',
227                                  'krb5', 'heimbase', 'asn1_compile',
228                                  'compile_et', 'kdc', 'hdb', 'heimntlm')
229
230     # Only process heimdal_build for non-MIT KRB5 builds
231     # When MIT KRB5 checks are done as above, conf.env.KRB5_VENDOR will be set
232     # to the lowcased output of 'krb5-config --vendor'.
233     # If it is not set or the output is 'heimdal', we are dealing with
234     # system-provided or embedded Heimdal build
235     if conf.CONFIG_GET('KRB5_VENDOR') in (None, 'heimdal'):
236         conf.RECURSE('source4/heimdal_build')
237     conf.RECURSE('lib/audit_logging')
238     conf.RECURSE('source4/lib/tls')
239     conf.RECURSE('source4/dsdb/samdb/ldb_modules')
240     conf.RECURSE('source4/ntvfs/sysdep')
241     conf.RECURSE('lib/util')
242     conf.RECURSE('lib/util/charset')
243     conf.RECURSE('source4/auth')
244     conf.RECURSE('nsswitch')
245     conf.RECURSE('libcli/smbreadline')
246     conf.RECURSE('lib/crypto')
247     conf.RECURSE('pidl')
248     if conf.CONFIG_GET('ENABLE_SELFTEST'):
249         if Options.options.with_ntvfs_fileserver != False:
250             if not (Options.options.without_ad_dc):
251                 conf.DEFINE('WITH_NTVFS_FILESERVER', 1)
252         if Options.options.with_ntvfs_fileserver == False:
253             if not (Options.options.without_ad_dc):
254                 raise Errors.WafError('--without-ntvfs-fileserver conflicts with --enable-selftest while building the AD DC')
255         conf.RECURSE('testsuite/unittests')
256
257     if Options.options.with_ntvfs_fileserver == True:
258         if Options.options.without_ad_dc:
259             raise Errors.WafError('--with-ntvfs-fileserver conflicts with --without-ad-dc')
260         conf.DEFINE('WITH_NTVFS_FILESERVER', 1)
261
262     if Options.options.with_pthreadpool:
263         if conf.CONFIG_SET('HAVE_PTHREAD') and \
264            conf.CONFIG_SET('HAVE___THREAD') and \
265            conf.CONFIG_SET('HAVE_ATOMIC_THREAD_FENCE_SUPPORT'):
266             conf.DEFINE('WITH_PTHREADPOOL', '1')
267         else:
268             if not conf.CONFIG_SET('HAVE_PTHREAD'):
269                 Logs.warn("pthreadpool support cannot be enabled when pthread support was not found")
270             if not conf.CONFIG_SET('HAVE_ATOMIC_THREAD_FENCE_SUPPORT'):
271                 Logs.warn("""pthreadpool support cannot be enabled when there is
272                           no support for atomic_thead_fence()""")
273             if not conf.CONFIG_SET('HAVE___THREAD'):
274                 Logs.warn("pthreadpool support cannot be enabled when __thread support was not found")
275             conf.undefine('WITH_PTHREADPOOL')
276
277     conf.RECURSE('source3')
278     conf.RECURSE('lib/texpect')
279     conf.RECURSE('python')
280     if conf.env.with_ctdb:
281         conf.RECURSE('ctdb')
282     conf.RECURSE('lib/socket')
283     conf.RECURSE('lib/mscat')
284     conf.RECURSE('packaging')
285
286     conf.SAMBA_CHECK_UNDEFINED_SYMBOL_FLAGS()
287
288     # gentoo always adds this. We want our normal build to be as
289     # strict as the strictest OS we support, so adding this here
290     # allows us to find problems on our development hosts faster.
291     # It also results in faster load time.
292
293     conf.env.asneeded_ldflags = conf.ADD_LDFLAGS('-Wl,--as-needed', testflags=True)
294
295     if not conf.CHECK_NEED_LC("-lc not needed"):
296         conf.ADD_LDFLAGS('-lc', testflags=False)
297
298     if not conf.CHECK_CODE('#include "tests/summary.c"',
299                            define='SUMMARY_PASSES',
300                            addmain=False,
301                            msg='Checking configure summary'):
302         raise Errors.WafError('configure summary failed')
303
304     if Options.options.enable_pie != False:
305         if Options.options.enable_pie == True:
306                 need_pie = True
307         else:
308                 # not specified, only build PIEs if supported by compiler
309                 need_pie = False
310         if conf.check_cc(cflags='-fPIE', ldflags='-pie', mandatory=need_pie,
311                          msg="Checking compiler for PIE support"):
312             conf.env['ENABLE_PIE'] = True
313
314     if Options.options.enable_relro != False:
315         if Options.options.enable_relro == True:
316             need_relro = True
317         else:
318             # not specified, only build RELROs if supported by compiler
319             need_relro = False
320         if conf.check_cc(cflags='', ldflags='-Wl,-z,relro,-z,now', mandatory=need_relro,
321                          msg="Checking compiler for full RELRO support"):
322             conf.env['ENABLE_RELRO'] = True
323
324     conf.SAMBA_CONFIG_H('include/config.h')
325
326 def etags(ctx):
327     '''build TAGS file using etags'''
328     from waflib import Utils
329     source_root = os.path.dirname(Context.g_module.root_path)
330     cmd = 'rm -f %s/TAGS && (find %s -name "*.[ch]" | egrep -v \.inst\. | xargs -n 100 etags -a)' % (source_root, source_root)
331     print("Running: %s" % cmd)
332     status = os.system(cmd)
333     if os.WEXITSTATUS(status):
334         raise Errors.WafError('etags failed')
335
336 def ctags(ctx):
337     "build 'tags' file using ctags"
338     from waflib import Utils
339     source_root = os.path.dirname(Context.g_module.root_path)
340     cmd = 'ctags --python-kinds=-i $(find %s -name "*.[ch]" | grep -v "*_proto\.h" | egrep -v \.inst\.) $(find %s -name "*.py")' % (source_root, source_root)
341     print("Running: %s" % cmd)
342     status = os.system(cmd)
343     if os.WEXITSTATUS(status):
344         raise Errors.WafError('ctags failed')
345
346
347 # putting this here enabled build in the list
348 # of commands in --help
349 def build(bld):
350     '''build all targets'''
351     samba_version.load_version(env=bld.env, is_install=bld.is_install)
352
353
354 def pydoctor(ctx):
355     '''build python apidocs'''
356     bp = os.path.abspath('bin/python')
357     mpaths = {}
358     modules = ['talloc', 'tdb', 'ldb']
359     for m in modules:
360         f = os.popen("PYTHONPATH=%s python -c 'import %s; print %s.__file__'" % (bp, m, m), 'r')
361         try:
362             mpaths[m] = f.read().strip()
363         finally:
364             f.close()
365     mpaths['main'] = bp
366     cmd = ('PYTHONPATH=%(main)s pydoctor --introspect-c-modules --project-name=Samba '
367            '--project-url=http://www.samba.org --make-html --docformat=restructuredtext '
368            '--add-package bin/python/samba ' + ''.join('--add-module %s ' % n for n in modules))
369     cmd = cmd % mpaths
370     print("Running: %s" % cmd)
371     status = os.system(cmd)
372     if os.WEXITSTATUS(status):
373         raise Errors.WafError('pydoctor failed')
374
375
376 def pep8(ctx):
377     '''run pep8 validator'''
378     cmd='PYTHONPATH=bin/python pep8 -r bin/python/samba'
379     print("Running: %s" % cmd)
380     status = os.system(cmd)
381     if os.WEXITSTATUS(status):
382         raise Errors.WafError('pep8 failed')
383
384
385 def wafdocs(ctx):
386     '''build wafsamba apidocs'''
387     from samba_utils import recursive_dirlist
388     os.system('pwd')
389     list = recursive_dirlist('../buildtools/wafsamba', '.', pattern='*.py')
390
391     cmd='PYTHONPATH=bin/python pydoctor --project-name=wafsamba --project-url=http://www.samba.org --make-html --docformat=restructuredtext'
392     print(list)
393     for f in list:
394         cmd += ' --add-module %s' % f
395     print("Running: %s" % cmd)
396     status = os.system(cmd)
397     if os.WEXITSTATUS(status):
398         raise Errors.WafError('wafdocs failed')
399
400
401 def dist():
402     '''makes a tarball for distribution'''
403     sambaversion = samba_version.load_version(env=None)
404
405     os.system("make -C ctdb manpages")
406     samba_dist.DIST_FILES('ctdb/doc:ctdb/doc', extend=True)
407
408     os.system("DOC_VERSION='" + sambaversion.STRING + "' " + Context.g_module.top + "/release-scripts/build-manpages-nogit")
409     samba_dist.DIST_FILES('bin/docs:docs', extend=True)
410
411     if sambaversion.IS_SNAPSHOT:
412         # write .distversion file and add to tar
413         if not os.path.isdir(Context.g_module.out):
414             os.makedirs(Context.g_module.out)
415         distversionf = tempfile.NamedTemporaryFile(mode='w', prefix='.distversion',dir=Context.g_module.out)
416         for field in sambaversion.vcs_fields:
417             distveroption = field + '=' + str(sambaversion.vcs_fields[field])
418             distversionf.write(distveroption + '\n')
419         distversionf.flush()
420         samba_dist.DIST_FILES('%s:.distversion' % distversionf.name, extend=True)
421
422         samba_dist.dist()
423         distversionf.close()
424     else:
425         samba_dist.dist()
426
427
428 def distcheck():
429     '''test that distribution tarball builds and installs'''
430     samba_version.load_version(env=None)
431
432 def wildcard_cmd(cmd):
433     '''called on a unknown command'''
434     from samba_wildcard import run_named_build_task
435     run_named_build_task(cmd)
436
437 def main():
438     from samba_wildcard import wildcard_main
439
440     wildcard_main(wildcard_cmd)
441 Scripting.main = main
442
443 def reconfigure(ctx):
444     '''reconfigure if config scripts have changed'''
445     import samba_utils
446     samba_utils.reconfigure(ctx)
447
448
449 if os.path.isdir(os.path.join(top, ".git")):
450     # Check if there are submodules that are checked out but out of date.
451     for submodule, status in samba_git.read_submodule_status(top):
452         if status == "out-of-date":
453             raise Errors.WafError("some submodules are out of date. Please run 'git submodule update'")