3 # Made with the aid of debmake, by Christoph Lameter,
4 # based on the sample debian/rules file for GNU hello by Ian Jackson.
7 SOURCEPATH=../../source
13 cd $(SOURCEPATH) && ./autogen.sh
14 cd $(SOURCEPATH) && ./configure --with-fhs \
19 --libdir=/etc/samba4 \
20 --with-privatedir=/etc/samba4 \
21 --with-piddir=/var/run/samba4 \
22 --localstatedir=/var \
31 cd $(SOURCEPATH) && $(MAKE) proto all
37 -cd $(SOURCEPATH) && $(MAKE) clean
38 rm -f `find . -name "*~"`
39 rm -rf debian/tmp `find debian/* -type d ! -name CVS` debian/files* core
40 rm -f debian/*substvars
42 binary-indep: checkroot build
44 # There are no architecture-independent files to be uploaded
45 # generated by this package. If there were any they would be
48 binary-arch: checkroot build
50 rm -rf debian/tmp `find debian/* -type d ! -name CVS`
52 cd debian/tmp && install -d `cat ../dirs`
53 cd $(SOURCEPATH) && $(MAKE) install DESTDIR=`pwd`/../packaging/debian/tmp
54 mkdir -p debian/tmp/usr/share/man/man1
55 mkdir -p debian/tmp/usr/share/man/man7
56 cp $(SOURCEPATH)/build/pidl/pidl.pl debian/tmp/usr/bin/pidl
58 dpkg-gencontrol -isp -psamba4
59 chown -R root:root debian/tmp
60 chmod -R go=rX debian/tmp
61 dpkg --build debian/tmp ..
67 binary: binary-indep binary-arch
71 test root = "`whoami`"
73 .PHONY: binary binary-arch binary-indep clean checkroot