ad-schema/license.txt: Fix typo.
[samba.git] / packaging / Debian / debian-woody / README.build-upstream
1 Building Samba Packages for Debian GNU/Linux
2 --------------------------------------------
3
4 Building Debian packages is not as hard as some people might think.
5 The following instructions will allow you to build your own Samba
6 Debian packages. These instructions and the files in packaging/Debian/
7 are current as of Samba 3.0.0, and allow you to build Debian packages
8 for Debian unstable (so you need some development packages available
9 only in Debian unstable.) If you are using something newer than 3.0.0
10 you might want to try to follow the instructions to see if patches
11 apply cleanly. If some patches don't apply cleanly please e-mail
12 samba@packages.debian.org since we might have fixed patches that we have
13 not yet integrated into upstream Samba.
14
15 We try to maintain as much compatibility with previous releases
16 of Debian as possible, so it is possible that the files in
17 packaging/Debian/ can also be used to build Samba Debian packages for
18 other Debian releases. However, sometimes this is just not possible
19 because we need to use stuff that is only available on Debian unstable.
20
21 Instructions
22 ------------
23
24 If you want to build Samba packages for Debian and you just want to use
25 upstream sources, i.e. you don't want to wait for us to put official
26 packages out, or you want packages for a Debian version for which we
27 don't provide deb's, or you don't want to use official packages, or
28 you want to add --this-cool-switch to configure, or whatever, follow
29 these instructions:
30
31 0) Make sure you have the following packages installed (in addition
32 to the normal Debian development packages -- dpkg-dev, libc6-dev,
33 devscripts, etc.):
34
35   autoconf
36   debhelper
37   libpam0g-dev
38   libreadline4-dev
39   libcupsys2-dev
40   acl-dev, libacl1
41   libkrb5-dev
42   libldap2-dev
43   python2.2-dev
44
45   Notes regarding the packages required to build Samba Debian packages:
46
47   * The libcupsys2-dev is not available in Debian Potato (Debian 2.2).
48     That's fine; the configure script won't detect CUPS support and the
49     resulting binaries won't support CUPS.
50
51   * The list above is current as of samba-3.0.0rc2, but it can get
52     out of date. The best way to check what packages are required to
53     build the samba packages on Debian is to look for the Build-Depends:
54     field in the file debian/control.
55
56 1) cd samba[-<version>]. For example, "cd samba-3.0.0rc2".
57 2) cp -a packaging/Debian/debian/ debian
58   It's important that you copy instead of symlink because the build
59   tools in Potato have a problem that prevents the build to work with
60   a symlink.
61 3) dch -i (this is completely optional - only do it if you understand
62    Debian version numbers! Don't complain later if you can't upgrade
63    to official versions of the Samba packages for Debian.)
64   - Edit the changelog and make sure the version is right. For example,
65     for Samba 3.0.0beta3, the version number should something like
66   3.0.0beta3-0.1.
67 4) Run 'debian/rules binary'.
68   - It is better that you prefix the above command with 'fakeroot'.
69     If you have problems you might try building as root.
70 5) That's it. Your new packages should be in ../. Install with dpkg.
71
72 Please e-mail samba@packages.debian.org with comments, questions or
73 suggestions. Please talk to us and not to the Samba Team. They have
74 better things to do and know nothing about the Debian packaging system.
75
76 Eloy A. Paris <peloy@debian.org>
77 Steve Langasek <vorlon@debian.org>
78