winbindd: winbindd_ccache_ntlm_auth() -> bool_dispatch_table
[samba.git] / nsswitch / libwbclient / wscript
1 #!/usr/bin/env python
2
3 import Options, Logs
4
5 # Remember to also update wbclient.h
6 VERSION="0.14"
7
8 # It may be useful at some point to allow Samba to build against a
9 # system libwbclient, such as the one provided by Likewise.  To to
10 # this, not only must the check below be activated but this must only
11 # be activated with an off-by-default option to disable the internal
12 # build of both winbindd implementations, and all the internal
13 # references to libwbclient.h will need to be fixed to point at the
14 # system libwbclient.  Finally, as a system libwbclient would probably
15 # not use the same version scheme as Samba, so this would need to
16 # reference Likewise version numbers instead.
17 #
18 #def configure(conf):
19 #    if conf.CHECK_BUNDLED_SYSTEM_PKG('wbclient', minversion=VERSION):
20 #        conf.define('USING_SYSTEM_LIBWBCLIENT', 1)
21 #
22
23 def build(bld):
24 #    if bld.CONFIG_SET('USING_SYSTEM_LIBWBCLIENT'):
25 #        Logs.info("\tSelected system libwbclient build")
26 #        return
27 #
28 #    Logs.info("\tSelected embedded libwbclient build")
29
30     abi_match = 'wbc*'
31     bld.SAMBA_LIBRARY('wbclient',
32                       source='''
33                              wbc_guid.c
34                              wbc_idmap.c
35                              wbclient.c
36                              wbc_pam.c
37                              wbc_pwd.c
38                              wbc_sid.c
39                              wbc_util.c''',
40                       deps='winbind-client',
41                       pc_files='wbclient.pc',
42                       public_headers='wbclient.h',
43                       abi_directory='ABI',
44                       abi_match=abi_match,
45                       vnum=VERSION)