build: fixed a typo that prevented --bundled-libraries from working correctly
[samba.git] / buildtools / wafsamba / samba_errtable.py
1 # waf build tool for building .et files with compile_et
2 import Build
3 from samba_utils import *
4
5 def SAMBA_ERRTABLE(bld, name, source):
6     '''Build a heimdal errtable from a .et file'''
7
8     bname = source[0:-3]; # strip off the .et suffix
9
10     if not SET_TARGET_TYPE(bld, name, 'ET'):
11         return
12
13     bld.SET_BUILD_GROUP('build_source')
14
15     out_files = []
16     out_files.append('%s.c' % bname)
17     out_files.append('%s.h' % bname)
18
19     t = bld(rule='${SRC[1].abspath(env)} . ${TGT[0].parent.abspath(env)} default/source4/heimdal_build/compile_et ${SRC[0].abspath(env)} ${TGT[0].bldpath(env)}',
20             ext_out = '.c',
21             before  = 'cc',
22             on_results = True,
23             shell   = True,
24             source  = [source, 'et_compile_wrapper.sh', 'compile_et'],
25             target  = out_files,
26             name    = name)
27 Build.BuildContext.SAMBA_ERRTABLE = SAMBA_ERRTABLE