e0a8e54eaec3b05d75649e79569f610fb0f9ceab
[samba.git] / buildtools / wafsamba / samba_bundled.py
1 # functions to support bundled libraries
2
3 from Configure import conf
4 from samba_utils import *
5
6 def BUNDLED_NAME(bld, name, bundled_extension):
7     '''possibly rename a library to include a bundled extension'''
8     if bld.env.DISABLE_SHARED or not bundled_extension:
9         return name
10     if name in bld.env.BUNDLED_EXTENSION_EXCEPTION:
11         return name
12     extension = getattr(bld.env, 'BUNDLED_EXTENSION', '')
13     if extension:
14         return name + '-' + extension
15     return name
16
17
18 def target_in_list(target, lst, default):
19     for l in lst:
20         if target == l:
21             return True
22         if '!' + target == l:
23             return False
24         if l == 'ALL':
25             return True
26         if l == 'NONE':
27             return False
28     return default
29
30
31 def BUILTIN_LIBRARY(bld, name):
32     '''return True if a library should be builtin
33        instead of being built as a shared lib'''
34     if bld.env.DISABLE_SHARED:
35         return True
36     return target_in_list(name, bld.env.BUILTIN_LIBRARIES, False)
37
38
39 def BUILTIN_DEFAULT(opt, builtins):
40     '''set a comma separated default list of builtin libraries for this package'''
41     if 'BUILTIN_LIBRARIES_DEFAULT' in Options.options:
42         return
43     Options.options['BUILTIN_LIBRARIES_DEFAULT'] = builtins
44 Options.Handler.BUILTIN_DEFAULT = BUILTIN_DEFAULT
45
46
47 def BUNDLED_EXTENSION_DEFAULT(opt, extension, noextenion=''):
48     '''set a default bundled library extension'''
49     if 'BUNDLED_EXTENSION_DEFAULT' in Options.options:
50         return
51     Options.options['BUNDLED_EXTENSION_DEFAULT'] = extension
52     Options.options['BUNDLED_EXTENSION_EXCEPTION'] = noextenion
53 Options.Handler.BUNDLED_EXTENSION_DEFAULT = BUNDLED_EXTENSION_DEFAULT
54
55
56
57 @runonce
58 @conf
59 def CHECK_BUNDLED_SYSTEM(conf, libname, minversion='0.0.0',
60                          checkfunctions=None, headers=None,
61                          onlyif=None, implied_deps=None,
62                          require_headers=True):
63     '''check if a library is available as a system library.
64     this first tries via pkg-config, then if that fails
65     tries by testing for a specified function in the specified lib
66     '''
67     if 'ALL' in conf.env.BUNDLED_LIBS or libname in conf.env.BUNDLED_LIBS:
68         return False
69     found = 'FOUND_SYSTEMLIB_%s' % libname
70     if found in conf.env:
71         return conf.env[found]
72
73     # see if the library should only use a system version if another dependent
74     # system version is found. That prevents possible use of mixed library
75     # versions
76     if onlyif:
77         for syslib in TO_LIST(onlyif):
78             f = 'FOUND_SYSTEM_%s' % syslib
79             if not f in conf.env:
80                 if 'NONE' in conf.env.BUNDLED_LIBS or '!'+libname in conf.env.BUNDLED_LIBS:
81                     print('ERROR: Use of system library %s depends on missing system library %s' % (libname, syslib))
82                     sys.exit(1)
83                 conf.env[found] = False
84                 return False
85
86     # try pkgconfig first
87     if conf.check_cfg(package=libname,
88                       args='"%s >= %s" --cflags --libs' % (libname, minversion),
89                       msg='Checking for system %s >= %s' % (libname, minversion)):
90         conf.SET_TARGET_TYPE(libname, 'SYSLIB')
91         conf.env[found] = True
92         if implied_deps:
93             conf.SET_SYSLIB_DEPS(libname, implied_deps)
94         return True
95     if checkfunctions is not None:
96         headers_ok = True
97         if require_headers and headers and not conf.CHECK_HEADERS(headers):
98             headers_ok = False
99         if headers_ok and conf.CHECK_FUNCS_IN(checkfunctions, libname, headers=headers, empty_decl=False):
100             conf.env[found] = True
101             if implied_deps:
102                 conf.SET_SYSLIB_DEPS(libname, implied_deps)
103             return True
104     conf.env[found] = False
105     if 'NONE' in conf.env.BUNDLED_LIBS or '!'+libname in conf.env.BUNDLED_LIBS:
106         print('ERROR: System library %s of version %s not found, and bundling disabled' % (libname, minversion))
107         sys.exit(1)
108     return False