Only use sw_vers if we're on OS X.
authorGuy Harris <guy@alum.mit.edu>
Wed, 31 Jul 2013 20:40:19 +0000 (20:40 -0000)
committerGuy Harris <guy@alum.mit.edu>
Wed, 31 Jul 2013 20:40:19 +0000 (20:40 -0000)
svn path=/trunk/; revision=51074

configure.ac

index b139f09b85f6685d20712e304c898533caff4390..3ec8ccad7d72859835f3ef8dcdacf452300a6c33 100644 (file)
@@ -437,13 +437,23 @@ then
        esac
 else
        #
-       # In the installer package XML file, give the current OS
-       # version, minor version and all, as the minimum version.
-       # We can't guarantee that the resulting binary will work
-       # on older OS versions, not even older minor versions
-       # (original release or earlier software updates).
+       # Is this OS X?
        #
-       OSX_MIN_VERSION=`sw_vers -productVersion`
+       case "$host_os" in
+       darwin*)
+               #
+               # Yes.
+               #
+               #
+               # In the installer package XML file, give the current OS
+               # version, minor version and all, as the minimum version.
+               # We can't guarantee that the resulting binary will work
+               # on older OS versions, not even older minor versions
+               # (original release or earlier software updates).
+               #
+               OSX_MIN_VERSION=`sw_vers -productVersion`
+               ;;
+       esac
 fi
 AC_SUBST(OSX_MIN_VERSION)