Explicitly require autoconf 2.64.
authorGuy Harris <guy@alum.mit.edu>
Tue, 23 Feb 2016 02:45:30 +0000 (18:45 -0800)
committerGuy Harris <guy@alum.mit.edu>
Tue, 23 Feb 2016 02:46:29 +0000 (02:46 +0000)
AX_APPEND_FLAG requires it, and we use AX_APPEND_FLAG, so explicitly
require it up front.

Change-Id: Ieff378e63eba245fdf1454bc388b6be7fc94a10c
Reviewed-on: https://code.wireshark.org/review/14084
Reviewed-by: Guy Harris <guy@alum.mit.edu>
autogen.sh
configure.ac

index cbe7e51b7aa052a2a504bd75402c962a1e90209c..19b4e8516d6e9e438589341bcb3834b6d5a61121 100755 (executable)
@@ -59,10 +59,10 @@ esac
 
 ACVER=`$AUTOCONF --version | grep '^autoconf' | sed 's/.*) *//'`
 case "$ACVER" in
-'' | 0.* | 1.* | 2.[0-5]* )
+'' | 0.* | 1.* | 2.[0-5]* | 2.6[0123]* )
   cat >&2 <<_EOF_
 
-       You must have autoconf 2.60 or later installed to compile $PROJECT.
+       You must have autoconf 2.64 or later installed to compile $PROJECT.
        Download the appropriate package for your distribution/OS,
        or get the source tarball at ftp://ftp.gnu.org/pub/gnu/autoconf/
 _EOF_
index d84212f89100cb44d3bac94ebf750dd9edc1bb51..ec1b65ef56a889c3147ef3b995a0caaba4d48e6d 100644 (file)
@@ -16,9 +16,9 @@ CONFIG_ARGS="$*"
 AC_SUBST(CONFIG_ARGS)
 
 # Minimum autoconf version we require.
-AC_PREREQ(2.60)
+AC_PREREQ(2.64)
 # Variable expansion doesn't work in AC_PREREQ()
-AC_MIN_VERSION=2.60
+AC_MIN_VERSION=2.64
 AC_SUBST(AC_MIN_VERSION)
 
 dnl Make sure to keep ACLOCAL_AMFLAGS in Makefile.am and AC_CONFIG_MACRO_DIRS