1.99.8 → 1.99.9.
[metze/wireshark/wip.git] / wiretap / Makefile.am
index 4b9436adace274163cf4750b58717f477cfda40a..b82ba2e537f736590da865dca70dd4ae5fcb9420 100644 (file)
@@ -1,8 +1,6 @@
 # Makefile.am
 # Automake file for Wiretap
 #
-# $Id$
-#
 # Wireshark - Network traffic analyzer
 # By Gerald Combs <gerald@wireshark.org>
 # Copyright 1998 Gerald Combs
@@ -30,20 +28,21 @@ include Makefile.common
 noinst_LTLIBRARIES = libwiretap_generated.la
 lib_LTLIBRARIES = libwiretap.la
 # http://www.gnu.org/software/libtool/manual/html_node/Updating-version-info.html
-libwiretap_la_LDFLAGS = -version-info 0:0:0 -export-symbols wtap.sym @LDFLAGS_SHAREDLIB@
+libwiretap_la_LDFLAGS = -version-info 0:9:0 @LDFLAGS_SHAREDLIB@
+
+AM_NON_GENERATED_CFLAGS =-DWS_BUILD_DLL
 
 if HAVE_WARNINGS_AS_ERRORS
-AM_NON_GENERATED_CFLAGS = -Werror
+AM_NON_GENERATED_CFLAGS += -Werror
 endif
 
-INCLUDES = -I$(srcdir)/..
+AM_CPPFLAGS = -I$(srcdir)/..
 
 CLEANFILES = \
        libwiretap.a            \
        libwiretap.la           \
        libwiretap_generated.a  \
        libwiretap_generated.la \
-       wtap.sym                \
        *~
 
 MAINTAINERCLEANFILES = \
@@ -67,13 +66,11 @@ EXTRA_DIST = \
        README.developer        \
        Makefile.common         \
        Makefile.nmake          \
-       libwiretap.vcproj       \
-       wtap.def                \
        $(GENERATOR_FILES)      \
        $(GENERATED_FILES)
 
 libwiretap_la_LIBADD = libwiretap_generated.la ${top_builddir}/wsutil/libwsutil.la $(GLIB_LIBS)
-libwiretap_la_DEPENDENCIES = libwiretap_generated.la ${top_builddir}/wsutil/libwsutil.la wtap.sym
+libwiretap_la_DEPENDENCIES = libwiretap_generated.la ${top_builddir}/wsutil/libwsutil.la
 
 RUNLEX = $(top_srcdir)/tools/runlex.sh
 
@@ -83,7 +80,9 @@ ascend_scanner_lex.h : ascend_scanner.c
 
 ascend_scanner.c: ascend.h
 
-ascend.c ascend.h: ascend.y
+ascend.h: ascend.c
+
+ascend.c: ascend.y
        @if [ -z "$(YACC)" ]; then \
                echo "Neither bison nor byacc has been found"; \
                exit 1; \
@@ -93,11 +92,11 @@ ascend.c ascend.h: ascend.y
 # ABI compliance checker can be obtained from
 # http://ispras.linux-foundation.org/index.php/ABI_compliance_checker
 # Checked using version 1.21.12
-dumpabi: all abi-descriptor.xml
+dumpabi-libwiretap: all abi-descriptor.xml
        rm -rf abi-check-headers abi_dumps .libs/*.abi.tar.gz
        mkdir abi-check-headers
-       cp *.h abi-check-headers/
-       abi-compliance-checker -l libwiretap -v1 `ls  .libs/libwiretap.so.?.?.?|sed 's/.*\.so\.//'` \
+       cp *.h ../ws_symbol_export.h abi-check-headers/
+       abi-compliance-checker -l libwiretap -v1 `readlink .libs/libwiretap.so | sed 's/.*\.so\.//'` \
                -relpath $(abs_srcdir) -dump-abi abi-descriptor.xml || \
                cat logs/libwiretap/[0-9]*/log.txt
        cp -f abi_dumps/libwiretap/libwiretap_* .libs/
@@ -105,5 +104,7 @@ dumpabi: all abi-descriptor.xml
 
 checkapi:
 ## 'abort' checking disabled for now pending resolution of existing use of g_assert & g_error
-##     $(PERL) ../tools/checkAPIs.pl -g abort -g termoutput $(NONGENERATED_C_FILES) $(GENERATOR_FILES)
-       $(PERL) ../tools/checkAPIs.pl -g termoutput -build $(NONGENERATED_C_FILES) $(GENERATOR_FILES)
+##     $(PERL) $(top_srcdir)/tools/checkAPIs.pl -g abort -g termoutput \
+       $(PERL) $(top_srcdir)/tools/checkAPIs.pl -g termoutput -build \
+       -sourcedir=$(srcdir) \
+       $(NONGENERATED_C_FILES) $(GENERATOR_FILES)