Attempt to fix Qt dependencies for SUSE.
[metze/wireshark/wip.git] / packaging / rpm / SPECS / wireshark.spec.in
index e98fa00ec67080992a3a8e443b7f2f2f1b68d640..0957de4b3147a409714b1e2f1f8b1c25ab21c1fe 100644 (file)
@@ -155,8 +155,13 @@ Contains the Gnome (GTK+) Wireshark GUI and desktop integration files.
 %package       qt
 Summary:       Qt GUI for Wireshark
 Group:         Applications/Internet
+%if 0%{?suse_version}
+Requires:      libqt4 >= @QT_MIN_VERSION@
+BuildRequires: libqt4-devel >= @QT_MIN_VERSION@
+%else
 Requires:      qt >= @QT_MIN_VERSION@
 BuildRequires: qt-devel >= @QT_MIN_VERSION@
+%endif
 Requires:      %{name} = %{version}-%{release}
 Requires:      xdg-utils
 Requires:      hicolor-icon-theme