CMake: API reference fixes.
[metze/wireshark/wip.git] / extcap / Makefile.am
index 89f5399853f68ed4ffa0b3bc24f5233579d7de1d..6a4d7f39c728d18743eac1ef74b79fb873b50cc8 100644 (file)
@@ -5,26 +5,11 @@
 # By Gerald Combs <gerald@wireshark.org>
 # Copyright 1998 Gerald Combs
 #
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License
-# as published by the Free Software Foundation; either version 2
-# of the License, or (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+# SPDX-License-Identifier: GPL-2.0-or-later
 
 include ../Makefile.am.inc
 
-AM_CPPFLAGS = $(INCLUDEDIRS) $(WS_CPPFLAGS) $(GLIB_CFLAGS)
-
-MAINTAINERCLEANFILES = \
-       Makefile.in
+AM_CPPFLAGS = $(INCLUDEDIRS) $(WS_CPPFLAGS) $(GLIB_CFLAGS) $(PCAP_CFLAGS)
 
 EXTRA_DIST = \
        .editorconfig
@@ -42,12 +27,6 @@ androiddump_SOURCES = \
        androiddump.c   \
        extcap-base.c
 
-if ENABLE_STATIC
-androiddump_LDFLAGS = -Wl,-static -all-static
-else
-androiddump_LDFLAGS = -export-dynamic
-endif
-
 # Libraries and plugin flags with which to link androiddump.
 androiddump_LDADD = \
        ../ui/libui.a                   \
@@ -59,12 +38,6 @@ randpktdump_SOURCES = \
        randpktdump.c   \
        extcap-base.c
 
-if ENABLE_STATIC
-       randpktdump_LDFLAGS = -Wl,-static -all-static
-else
-       randpktdump_LDFLAGS = -export-dynamic
-endif
-
 # Libraries and plugin flags with which to link randpktdump.
 randpktdump_LDADD = \
        ../randpkt_core/librandpkt_core.a       \
@@ -78,12 +51,6 @@ sshdump_SOURCES = \
        extcap-base.c   \
        ssh-base.c
 
-if ENABLE_STATIC
-       sshdump_LDFLAGS = -Wl,-static -all-static
-else
-       sshdump_LDFLAGS = -export-dynamic
-endif
-
 # Libraries and plugin flags with which to link sshdump.
 sshdump_LDADD = \
        ../wiretap/libwiretap.la        \
@@ -96,12 +63,6 @@ ciscodump_SOURCES = \
        extcap-base.c   \
        ssh-base.c
 
-if ENABLE_STATIC
-       ciscodump_LDFLAGS = -Wl,-static -all-static
-else
-       ciscodump_LDFLAGS = -export-dynamic
-endif
-
 # Libraries and plugin flags with which to link ciscodump.
 ciscodump_LDADD = \
        ../writecap/libwritecap.a       \
@@ -113,12 +74,6 @@ udpdump_SOURCES = \
        udpdump.c \
        extcap-base.c
 
-if ENABLE_STATIC
-       udpdump_LDFLAGS = -Wl,-static -all-static
-else
-       udpdump_LDFLAGS = -export-dynamic
-endif
-
 # Libraries and plugin flags with which to link udpdump.
 udpdump_LDADD = \
        ../writecap/libwritecap.a       \