CMake: Clean up and homogenize plugin dir configuration
[metze/wireshark/wip.git] / extcap / CMakeLists.txt
index 0e8c95d69e3d78cd20e7497bce08e296ed460e4f..5ed2f7fcd364072701747ff616dffb1c127af99d 100644 (file)
@@ -99,7 +99,7 @@ if(BUILD_androiddump)
        # XXX Shouldn't we add wsutil to androiddump_LIBS instead?
        set_extcap_executable_properties(androiddump)
        target_link_libraries(androiddump ${androiddump_LIBS})
-       install(TARGETS androiddump RUNTIME DESTINATION ${EXTCAP_DIR})
+       install(TARGETS androiddump RUNTIME DESTINATION ${EXTCAP_INSTALL_LIBDIR})
        add_dependencies(extcaps androiddump)
 endif()
 
@@ -120,7 +120,7 @@ if(BUILD_sshdump AND LIBSSH_FOUND)
        set_extcap_executable_properties(sshdump)
        target_link_libraries(sshdump ${sshdump_LIBS})
        target_include_directories(sshdump PUBLIC ${LIBSSH_INCLUDE_DIR})
-       install(TARGETS sshdump RUNTIME DESTINATION ${EXTCAP_DIR})
+       install(TARGETS sshdump RUNTIME DESTINATION ${EXTCAP_INSTALL_LIBDIR})
        add_dependencies(extcaps sshdump)
 elseif (BUILD_sshdump)
        #message( WARNING "Cannot find libssh, cannot build sshdump" )
@@ -144,7 +144,7 @@ if(BUILD_ciscodump AND LIBSSH_FOUND)
        set_extcap_executable_properties(ciscodump)
        target_link_libraries(ciscodump ${ciscodump_LIBS})
        target_include_directories(ciscodump PUBLIC ${LIBSSH_INCLUDE_DIR})
-       install(TARGETS ciscodump RUNTIME DESTINATION ${EXTCAP_DIR})
+       install(TARGETS ciscodump RUNTIME DESTINATION ${EXTCAP_INSTALL_LIBDIR})
        add_dependencies(extcaps ciscodump)
 elseif (BUILD_ciscodump)
        #message( WARNING "Cannot find libssh, cannot build ciscodump" )
@@ -167,7 +167,7 @@ if(BUILD_dpauxmon AND HAVE_LIBNL3)
        set_extcap_executable_properties(dpauxmon)
        target_link_libraries(dpauxmon ${dpauxmon_LIBS})
        target_include_directories(dpauxmon PUBLIC ${NL_INCLUDE_DIR})
-       install(TARGETS dpauxmon RUNTIME DESTINATION ${EXTCAP_DIR})
+       install(TARGETS dpauxmon RUNTIME DESTINATION ${EXTCAP_INSTALL_LIBDIR})
        add_dependencies(extcaps dpauxmon)
 elseif (BUILD_dpauxmon)
        #message( WARNING "Cannot find libnl3, cannot build dpauxmon" )
@@ -188,7 +188,7 @@ if(BUILD_udpdump)
        add_executable(udpdump WIN32 ${udpdump_FILES})
        set_extcap_executable_properties(udpdump)
        target_link_libraries(udpdump ${udpdump_LIBS})
-       install(TARGETS udpdump RUNTIME DESTINATION ${EXTCAP_DIR})
+       install(TARGETS udpdump RUNTIME DESTINATION ${EXTCAP_INSTALL_LIBDIR})
        add_dependencies(extcaps udpdump)
 endif()
 
@@ -210,7 +210,7 @@ if(BUILD_randpktdump)
        # XXX Shouldn't we add wsutil to randpktdump_LIBS instead?
        set_extcap_executable_properties(randpktdump)
        target_link_libraries(randpktdump ${randpktdump_LIBS})
-       install(TARGETS randpktdump RUNTIME DESTINATION ${EXTCAP_DIR})
+       install(TARGETS randpktdump RUNTIME DESTINATION ${EXTCAP_INSTALL_LIBDIR})
        add_dependencies(extcaps randpktdump)
 endif()
 
@@ -219,4 +219,4 @@ set(CLEAN_C_FILES
        ${androiddump_FILES}
        ${sshdump_FILES}
        ${ciscodump_FILES}
-)
\ No newline at end of file
+)