Remove Makefile.common files
[metze/wireshark/wip.git] / epan / nghttp2 / Makefile.am
index ebb0891a45eee12a9cd0cd2e75ecc4466f1d8d0b..d5b8323b0d0385ee22bbb5abda9e5f0df9187c37 100644 (file)
 # along with this program; if not, write to the Free Software
 # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
 
-if HAVE_WARNINGS_AS_ERRORS
-AM_CFLAGS = -Werror
-endif
+include $(top_srcdir)/Makefile.am.inc
 
-include Makefile.common
-
-AM_CPPFLAGS = \
-       -I$(top_srcdir) \
-       $(LIBNGHTTP2_CFLAGS)
+AM_CPPFLAGS = $(INCLUDEDIRS) $(WS_CPPFLAGS) $(LIBNGHTTP2_CFLAGS) \
+       $(GLIB_CFLAGS)
 
 noinst_LTLIBRARIES = libnghttp2.la
 
+libnghttp2_la_SOURCES =        \
+       nghttp2_buf.c                   \
+       nghttp2_hd.c                    \
+       nghttp2_hd_huffman.c            \
+       nghttp2_hd_huffman_data.c       \
+       nghttp2_helper.c                \
+       nghttp2_mem.c                   \
+       nghttp2_rcbuf.c                 \
+       nghttp2_buf.h                   \
+       nghttp2_hd.h                    \
+       nghttp2_hd_huffman.h            \
+       nghttp2_helper.h                \
+       nghttp2_int.h                   \
+       nghttp2_mem.h                   \
+       nghttp2_rcbuf.h                 \
+       nghttp2.h                       \
+       nghttp2ver.h
+
+EXTRA_DIST = \
+       .editorconfig   \
+       README.nghttp2  \
+       CMakeLists.txt
+
 CLEANFILES = \
        libnghttp2.a    \
        libnghttp2.la   \
@@ -41,16 +59,8 @@ DISTCLEANFILES =
 MAINTAINERCLEANFILES = \
        Makefile.in
 
-libnghttp2_la_SOURCES =        \
-       $(LIBNGHTTP2_SRC)       \
-       $(LIBNGHTTP2_INCLUDES)
-
-EXTRA_DIST = \
-       Makefile.common \
-       Makefile.nmake
-
 #
-# Editor modelines  -  http://www.wireshark.org/tools/modelines.html
+# Editor modelines  -  https://www.wireshark.org/tools/modelines.html
 #
 # Local variables:
 # c-basic-offset: 8