CMake: API reference fixes.
[metze/wireshark/wip.git] / epan / dissectors / asn1 / h282 / Makefile.am
index 72d28e600b71f203086de73b93b255356a2a2b87..ef94435260ff1effa141eb8d890f4ec20955e7b0 100644 (file)
@@ -2,22 +2,27 @@
 # By Gerald Combs <gerald@wireshark.org>
 # Copyright 1998 Gerald Combs
 #
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License
-# as published by the Free Software Foundation; either version 2
-# of the License, or (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-
+# SPDX-License-Identifier: GPL-2.0-or-later
 
-include ../Makefile.preinc
-include Makefile.common
 include ../Makefile.inc
 
+PROTOCOL_NAME = h282
+
+EXT_ASN_FILE_LIST =
+
+ASN_FILE_LIST = \
+       RDC-PROTOCOL.asn
+
+EXTRA_DIST = \
+       $(EXTRA_DIST_COMMON) \
+       $(ASN_FILE_LIST) \
+       packet-$(PROTOCOL_NAME)-template.c \
+       $(PROTOCOL_NAME).cnf
+
+SRC_FILES = \
+       $(EXTRA_DIST) \
+       $(EXT_ASN_FILE_LIST)
+
+A2W_FLAGS =
+
+EXTRA_CNF =