Rename "ws_version_info.h", also .c
[metze/wireshark/wip.git] / epan / Makefile.am
index 1b9878fd8ba4abfadc71e0402eee335a8d76fe54..ac9630cffc7a003e79746d71f659992499ad0501 100644 (file)
@@ -38,7 +38,7 @@ SUBDIRS = compress crypt ftypes dfilter dissectors wmem $(wslua_dir)
 DIST_SUBDIRS = $(SUBDIRS) $(wslua_dist_dir)
 
 AM_CPPFLAGS = $(INCLUDEDIRS) -I$(builddir)/wslua $(WS_CPPFLAGS) \
-       $(GLIB_CFLAGS) $(LUA_CFLAGS) $(LIBGNUTLS_CFLAGS) \
+       $(GLIB_CFLAGS) $(PCAP_CFLAGS) $(LUA_CFLAGS) $(LIBGNUTLS_CFLAGS) \
        $(LIBGCRYPT_CFLAGS) $(LIBSMI_CFLAGS) $(LIBGEOIP_CFLAGS) \
        $(LZ4_CFLAGS) $(KRB5_CFLAGS) $(SNAPPY_CFLAGS) $(LIBXML2_CFLAGS)
 
@@ -95,7 +95,6 @@ LIBWIRESHARK_SRC = \
        oids.c                  \
        osi-utils.c             \
        oui.c                   \
-       packet_range.c          \
        packet.c                \
        prefs.c                 \
        print.c                 \
@@ -107,8 +106,8 @@ LIBWIRESHARK_SRC = \
        reedsolomon.c           \
        req_resp_hdrs.c         \
        rtd_table.c             \
+       sequence_analysis.c     \
        show_exception.c        \
-       sminmpec.c              \
        srt_table.c             \
        stat_tap_ui.c           \
        stats_tree.c            \
@@ -172,7 +171,7 @@ LIBWIRESHARK_ALL_SRC = \
        $(LIBWIRESHARK_SRC)     \
        $(LIBWIRESHARK_GENERATED_SRC)
 
-LIBWIRESHARK_INCLUDES = \
+LIBWIRESHARK_INCLUDES_PUBLIC = \
        addr_and_mask.h         \
        addr_resolv.h           \
        address.h               \
@@ -212,7 +211,6 @@ LIBWIRESHARK_INCLUDES = \
        dwarf.h                 \
        eap.h                   \
        eapol_keydes_types.h    \
-       epan-int.h              \
        epan.h                  \
        epan_dissect.h          \
        etypes.h                \
@@ -247,7 +245,6 @@ LIBWIRESHARK_INCLUDES = \
        oids.h                  \
        osi-utils.h             \
        oui.h                   \
-       packet_range.h          \
        packet.h                \
        packet_info.h           \
        params.h                \
@@ -267,6 +264,7 @@ LIBWIRESHARK_INCLUDES = \
        rtd_table.h             \
        rtp_pt.h                \
        sctpppids.h             \
+       sequence_analysis.h     \
        show_exception.h        \
        slow_protocol_subtypes.h \
        sminmpec.h              \
@@ -285,7 +283,6 @@ LIBWIRESHARK_INCLUDES = \
        tfs.h                   \
        time_fmt.h              \
        to_str.h                \
-       to_str-int.h            \
        tvbparse.h              \
        tvbuff.h                \
        tvbuff-int.h            \
@@ -296,14 +293,22 @@ LIBWIRESHARK_INCLUDES = \
        x264_prt_id.h           \
        xdlc.h
 
+LIBWIRESHARK_INCLUDES_PRIVATE = \
+       epan-int.h              \
+       to_str-int.h
+
+subpkgincludedir = $(pkgincludedir)/epan
+
+subpkginclude_HEADERS = $(LIBWIRESHARK_INCLUDES_PUBLIC)
+
 #Since code generated by lex may trigger gcc warnings, we are now generating two
 #libraries. A single library is generated with the lex code without the barrier
 #"stop on warning". An other library is generated from the remaining source
 #files with the "stop on warning" barrier.
 libwireshark_la_SOURCES = \
        $(LIBWIRESHARK_SRC)             \
-       $(LIBWIRESHARK_INCLUDES)        \
-       ws_version_info.c
+       $(LIBWIRESHARK_INCLUDES_PRIVATE)        \
+       version_info.c
 
 libwireshark_la_CPPFLAGS = $(AM_CPPFLAGS) -DWS_BUILD_DLL
 
@@ -377,7 +382,6 @@ EXTRA_DIST = \
        dtd_parse.l             \
        dtd_parse.h             \
        dtd_preparse.l          \
-       enterprise-numbers      \
        radius_dict.l           \
        uat_load.l              \
        doxygen.cfg.in          \
@@ -398,7 +402,7 @@ DISTCLEANFILES = \
        $(NODIST_LIBWIRESHARK_GENERATED_C_FILES) \
        $(NODIST_LIBWIRESHARK_GENERATED_HEADER_FILES) \
        dtd_grammar.out \
-       ws_version_info.c
+       version_info.c
 
 MAINTAINERCLEANFILES = \
        $(LIBWIRESHARK_GENERATED_C_FILES) \
@@ -408,7 +412,7 @@ MAINTAINERCLEANFILES = \
 BUILT_SOURCES = \
        $(LIBWIRESHARK_GENERATED_HEADER_FILES) \
        $(NODIST_LIBWIRESHARK_GENERATED_HEADER_FILES) \
-       ws_version_info.c
+       version_info.c
 
 EXTRA_PROGRAMS = reassemble_test tvbtest oids_test exntest
 
@@ -448,14 +452,11 @@ dtd_grammar.h: dtd_grammar.c
 dtd_grammar.c : $(LEMON) $(lemon_srcdir)/lempar.c $(srcdir)/dtd_grammar.lemon
        $(AM_V_LEMON)$(LEMON) T=$(lemon_srcdir)/lempar.c $(srcdir)/dtd_grammar.lemon
 
-ws_version_info.c: $(top_srcdir)/ws_version_info.c
+version_info.c: $(top_srcdir)/version_info.c
        $(AM_V_LN_S)$(LN_S) $<
 
 tvbtest.o exntest.o oids_test.o: exceptions.h
 
-update-sminmpec:
-       $(PERL) $(srcdir)/../tools/make-sminmpec.pl
-
 ps.c: print.ps $(top_srcdir)/tools/rdps.py
        $(AM_V_python)$(PYTHON) $(top_srcdir)/tools/rdps.py $(srcdir)/print.ps ps.c
 
@@ -464,43 +465,85 @@ if HAVE_PLUGINS
 if ENABLE_STATIC
 -include ../plugins/Custom.make
 plugin_src = \
-       ../plugins/asn1/packet-asn1.c \
-       ../plugins/docsis/packet-bintrngreq.c \
-       ../plugins/docsis/packet-bpkmattr.c \
-       ../plugins/docsis/packet-bpkmreq.c \
-       ../plugins/docsis/packet-bpkmrsp.c \
        ../plugins/docsis/packet-docsis.c \
-       ../plugins/docsis/packet-dsaack.c \
-       ../plugins/docsis/packet-dsareq.c \
-       ../plugins/docsis/packet-dsarsp.c \
-       ../plugins/docsis/packet-dscack.c \
-       ../plugins/docsis/packet-dscreq.c \
-       ../plugins/docsis/packet-dscrsp.c \
-       ../plugins/docsis/packet-dsdreq.c \
-       ../plugins/docsis/packet-dsdrsp.c \
-       ../plugins/docsis/packet-intrngreq.c \
        ../plugins/docsis/packet-macmgmt.c \
-       ../plugins/docsis/packet-map.c \
-       ../plugins/docsis/packet-regack.c \
-       ../plugins/docsis/packet-regreq.c \
-       ../plugins/docsis/packet-regrsp.c \
-       ../plugins/docsis/packet-rngreq.c \
-       ../plugins/docsis/packet-rngrsp.c \
        ../plugins/docsis/packet-tlv.c \
-       ../plugins/docsis/packet-type29ucd.c \
-       ../plugins/docsis/packet-uccreq.c \
-       ../plugins/docsis/packet-uccrsp.c \
-       ../plugins/docsis/packet-ucd.c \
+       ../plugins/docsis/packet-vendor.c \
+       ../plugins/docsis/plugin.c \
+       ../plugins/easy_codec/codec-g722.c \
+       ../plugins/easy_codec/codec-g7231.c \
+       ../plugins/easy_codec/codec-g729a.c \
+       ../plugins/easy_codec/easy_codec_plugin.c \
+       ../plugins/ethercat/packet-ams.c \
+       ../plugins/ethercat/packet-ecatmb.c \
+       ../plugins/ethercat/packet-esl.c \
+       ../plugins/ethercat/packet-ethercat-datagram.c \
+       ../plugins/ethercat/packet-ethercat-frame.c \
+       ../plugins/ethercat/packet-ioraw.c \
+       ../plugins/ethercat/packet-nv.c \
+       ../plugins/ethercat/plugin.c \
        ../plugins/gryphon/packet-gryphon.c \
+       ../plugins/gryphon/plugin.c \
+       ../plugins/irda/packet-ircomm.c \
        ../plugins/irda/packet-irda.c \
+       ../plugins/irda/packet-sir.c \
+       ../plugins/irda/plugin.c \
        ../plugins/m2m/packet-m2m.c \
+       ../plugins/m2m/plugin.c \
        ../plugins/m2m/wimax_tlv.c \
+       ../plugins/Makefile.am.inc \
+       ../plugins/mate/mate_grammar.c \
+       ../plugins/mate/mate_parser.c \
+       ../plugins/mate/mate_runtime.c \
+       ../plugins/mate/mate_setup.c \
+       ../plugins/mate/mate_util.c \
+       ../plugins/mate/packet-mate.c \
+       ../plugins/mate/plugin.c \
+       ../plugins/opcua/opcua_application_layer.c \
+       ../plugins/opcua/opcua.c \
+       ../plugins/opcua/opcua_complextypeparser.c \
+       ../plugins/opcua/opcua_enumparser.c \
+       ../plugins/opcua/opcua_extensionobjecttable.c \
+       ../plugins/opcua/opcua_hfindeces.c \
+       ../plugins/opcua/opcua_security_layer.c \
+       ../plugins/opcua/opcua_serviceparser.c \
+       ../plugins/opcua/opcua_servicetable.c \
+       ../plugins/opcua/opcua_simpletypes.c \
+       ../plugins/opcua/opcua_statuscode.c \
+       ../plugins/opcua/opcua_transport_layer.c \
+       ../plugins/opcua/plugin.c \
+       ../plugins/pluginifdemo/pluginifdemo.c \
+       ../plugins/profinet/packet-dcerpc-pn-io.c \
+       ../plugins/profinet/packet-dcom-cba-acco.c \
+       ../plugins/profinet/packet-dcom-cba.c \
+       ../plugins/profinet/packet-pn.c \
+       ../plugins/profinet/packet-pn-dcp.c \
+       ../plugins/profinet/packet-pn-mrp.c \
+       ../plugins/profinet/packet-pn-mrrt.c \
+       ../plugins/profinet/packet-pn-ptcp.c \
+       ../plugins/profinet/packet-pn-rt.c \
+       ../plugins/profinet/packet-pn-rtc-one.c \
+       ../plugins/profinet/plugin.c \
+       ../plugins/stats_tree/pinfo_stats_tree.c \
+       ../plugins/stats_tree/stats_tree_plugin.c \
+       ../plugins/tpg/packet-http.c \
+       ../plugins/transum/decoders.c \
+       ../plugins/transum/extractors.c \
+       ../plugins/transum/packet-transum.c \
+       ../plugins/transum/plugin.c \
+       ../plugins/unistim/packet-unistim.c \
+       ../plugins/unistim/plugin.c \
+       ../plugins/wimaxasncp/packet-wimaxasncp.c \
+       ../plugins/wimaxasncp/plugin.c \
+       ../plugins/wimaxasncp/wimaxasncp_dict.c \
        ../plugins/wimax/crc.c \
        ../plugins/wimax/crc_data.c \
        ../plugins/wimax/mac_hd_generic_decoder.c \
        ../plugins/wimax/mac_hd_type1_decoder.c \
        ../plugins/wimax/mac_hd_type2_decoder.c \
        ../plugins/wimax/mac_mgmt_msg_decoder.c \
+       ../plugins/wimaxmacphy/packet-wimaxmacphy.c \
+       ../plugins/wimaxmacphy/plugin.c \
        ../plugins/wimax/msg_aas_beam.c \
        ../plugins/wimax/msg_aas_fbck.c \
        ../plugins/wimax/msg_arq.c \
@@ -526,6 +569,7 @@ plugin_src = \
        ../plugins/wimax/msg_ucd.c \
        ../plugins/wimax/msg_ulmap.c \
        ../plugins/wimax/packet-wmx.c \
+       ../plugins/wimax/plugin.c \
        ../plugins/wimax/wimax_cdma_code_decoder.c \
        ../plugins/wimax/wimax_compact_dlmap_ie_decoder.c \
        ../plugins/wimax/wimax_compact_ulmap_ie_decoder.c \
@@ -538,7 +582,6 @@ plugin_src = \
        ../plugins/wimax/wimax_tlv.c \
        ../plugins/wimax/wimax_utils.c
 
-
 else           # ENABLE_STATIC
 
 plugin_src =