steam-ihs: fix memleak on exception
[metze/wireshark/wip.git] / debian / control
index 5a384fd9eb314c0e9797ab89d0197de1faab66ed..e952eaba20c6354e724ebc6b392861ed817452c5 100644 (file)
@@ -2,26 +2,23 @@ Source: wireshark
 Section: net
 Priority: optional
 Maintainer: Balint Reczey <balint@balintreczey.hu>
-Standards-Version: 3.9.5
-Build-Depends: libgtk-3-dev, hardening-includes, lsb-release,
-# enable Qt 5 related dependencies for Qt 5-enabled build
+Standards-Version: 3.9.7
+Build-Depends: lsb-release,
  qtbase5-dev, qtbase5-dev-tools, qttools5-dev, qttools5-dev-tools,
  qtmultimedia5-dev, libqt5svg5-dev,
-# enable Qt 4 related dependencies for Qt 4-enabled build
-# qt4-qmake, libqt4-dev,
  libpcap0.8-dev, flex, libz-dev, debhelper (>= 9), po-debconf, libtool,
  python (>= 2.6.6-3~), python-ply, libc-ares-dev, xsltproc,
  docbook-xsl (>= 1.64.1.0-0), docbook-xml, libxml2-utils, libpcre3-dev,
  libcap2-dev [linux-any] | libcap-dev (>= 2.17) [linux-any],
  bison, quilt, libparse-yapp-perl,
-# enable versioned libgnutls28-dev below to have GPLv2+ compatible GMP
-# libgnutls28-dev (>= 3.2.14-1~),
-# enable backports-compatible libgnutls-dev
- libgnutls-dev,
- libgcrypt-dev, portaudio19-dev, libkrb5-dev, liblua5.2-dev, libsmi2-dev,
- libgeoip-dev, dpkg-dev (>= 1.16.1~), imagemagick, xdg-utils,
libnl-genl-3-dev [linux-any], libnl-route-3-dev [linux-any], asciidoc, cmake, w3m,
- libsbc-dev, libnghttp2-dev
+# libgnutls28-dev >= 3.2.14-1 is GPLv2+ compatible. libgnutls-dev is
+# backports-compatible.
+ libgnutls28-dev (>= 3.2.14-1~) | libgnutls-dev,
+ libgcrypt-dev, libkrb5-dev, liblua5.2-dev, libsmi2-dev,
+ libmaxminddb-dev, dpkg-dev (>= 1.16.1~), libsystemd-dev | libsystemd-journal-dev,
+ libnl-genl-3-dev [linux-any], libnl-route-3-dev [linux-any], asciidoctor,
cmake (>= 3.5) | cmake3, libsbc-dev, libnghttp2-dev, libssh-gcrypt-dev,
+ liblz4-dev, libsnappy-dev, libspandsp-dev, libxml2-dev
 Build-Conflicts: libsnmp4.2-dev, libsnmp-dev
 Vcs-Svn: svn://svn.debian.org/svn/collab-maint/ext-maint/wireshark/trunk
 Vcs-Browser: http://svn.debian.org/wsvn/collab-maint/ext-maint/wireshark/trunk/
@@ -43,12 +40,11 @@ Description: network traffic analyzer - common files
  packets off the wire. Wireshark can decode too many protocols to list
  here.
  .
- This package provides files common to both wireshark (the GTK+ version)
- and tshark (the console version).
+ This package provides files common to both wireshark and tshark (the console version).
 
 Package: wireshark
 Architecture: any
-Depends: wireshark-qt | wireshark-gtk, ${misc:Depends}
+Depends: wireshark-qt, ${misc:Depends}
 Replaces: ethereal (<< 1.0.0-3)
 Conflicts: ethereal (<< 1.0.0-3)
 Description: network traffic analyzer - meta-package
@@ -60,7 +56,7 @@ Description: network traffic analyzer - meta-package
 
 Package: wireshark-qt
 Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}, wireshark-common (= ${binary:Version}), xdg-utils
+Depends: ${shlibs:Depends}, ${misc:Depends}, wireshark-common (= ${binary:Version})
 Recommends: libqt5multimedia5-plugins
 Replaces: ethereal (<< 1.0.0-3), wireshark (<< 2.0.0~)
 Breaks: ethereal (<< 1.0.0-3), wireshark (<< 2.0.0~)
@@ -71,18 +67,6 @@ Description: network traffic analyzer - Qt version
  .
  This package provides the Qt version of Wireshark.
 
-Package: wireshark-gtk
-Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}, wireshark-common (= ${binary:Version}), xdg-utils
-Replaces: ethereal (<< 1.0.0-3), wireshark (<< 2.0.0~)
-Breaks: ethereal (<< 1.0.0-3), wireshark (<< 2.0.0~)
-Description: network traffic analyzer - GTK+ version
- Wireshark is a network "sniffer" - a tool that captures and analyzes
- packets off the wire. Wireshark can decode too many protocols to list
- here.
- .
- This package provides the GTK+ version of Wireshark.
-
 Package: tshark
 Architecture: any
 Depends: ${shlibs:Depends}, ${misc:Depends}, wireshark-common (= ${binary:Version})
@@ -100,8 +84,8 @@ Package: wireshark-dev
 Architecture: any
 Section: devel
 Depends: ${misc:Depends}, omniidl (>= 4.0.1-2), libpcap0.8-dev, libtool,
- libglib2.0-dev, ${python:Depends}, python-ply, snacc, autotools-dev, debhelper,
- cdbs, automake, autoconf, libwireshark-dev, libwiretap-dev
+ libglib2.0-dev, ${python:Depends}, python-ply, snacc, debhelper,
+ cdbs, libwireshark-dev, libwiretap-dev
 Replaces: ethereal-dev (<< 1.0.0-3)
 Conflicts: ethereal-dev (<< 1.0.0-3)
 Description: network traffic analyzer - development tools
@@ -162,7 +146,7 @@ Depends: ${shlibs:Depends}, ${misc:Depends}
 Conflicts: wireshark-common (<< 1.4.0~rc2-1), libwireshark1 (<< 1.4.2-2)
 Replaces: wireshark-common (<< 1.4.0~rc2-1), libwireshark1 (<< 1.4.2-2)
 Description: network packet dissection utilities library -- shared library
- The libwsutil library provides utility functions for libwireshark05.
+ The libwsutil library provides utility functions for libwireshark0.
 
 Package: libwsutil-dev
 Section: libdevel
@@ -193,10 +177,10 @@ Package: libwireshark-data
 Section: libs
 Architecture: all
 Multi-Arch: foreign
-Depends: ${misc:Depends}, libjs-openlayers
+Depends: ${misc:Depends}
 Conflicts: wireshark-common (<< 1.4.0~rc2-1)
 Replaces: wireshark-common (<< 1.4.0~rc2-1)
-Recommends: geoip-database, geoip-database-extra
+#Recommends: geoip-database-contrib # Only includes legacy?
 Suggests: snmp-mibs-downloader
 Description: network packet dissection library -- data files
  The libwireshark library provides the network packet dissection services