From e.yimjia via https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=9289 :
[metze/wireshark/wip.git] / asn1 / Makefile.am
index ae83033bf8840fb78528568336ac0b6c405cc086..238c84514420e7600dcd7822772a9094fbd8c408 100644 (file)
 #
 # You should have received a copy of the GNU General Public License
 # along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA  02111-1307, USA.
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
 
+include Custom.make
 
-SUBDIRS = \
+SUBDIRS =              \
+       $(CUSTOM_SUBDIRS)       \
        acp133          \
        acse            \
        ansi_map        \
-       ansi-tcap       \
+       ansi_tcap       \
+       atn-cm          \
+       atn-cpdlc       \
+       atn-ulcs        \
+       c1222           \
        camel           \
        cdt             \
+       charging_ase    \
        cmip            \
+       cmp             \
+       credssp         \
+       crmf            \
        cms             \
        dap             \
-       disp            \
        dop             \
+       disp            \
        dsp             \
        ess             \
        ftam            \
        gnm             \
-       gsmmap          \
+       goose           \
+       gsm_map         \
+       gprscdr         \
        h225            \
        h235            \
        h245            \
@@ -50,22 +62,37 @@ SUBDIRS = \
        h450-ros        \
        h460            \
        h501            \
+       HI2Operations   \
+       hnbap           \
+       idmp            \
+       ilp             \
        inap            \
+       isdn-sup        \
+       lcsap           \
        ldap            \
-       logotype-cert-extn      \
+       logotypecertextn \
+       lpp             \
+       lppa            \
+       lppe            \
+       lte-rrc         \
+       m3ap            \
        mms             \
        mpeg-audio      \
        mpeg-pes        \
        nbap            \
-       ns-cert-exts    \
+       ns_cert_exts    \
        ocsp            \
+       p1              \
+       p22             \
+       p7              \
+       p772            \
+       pcap            \
        pkcs1           \
        pkcs12          \
        pkinit          \
+       pkixac          \
        pkix1explicit   \
        pkix1implicit   \
-       pkixcmp         \
-       pkixcrmf        \
        pkixproxy       \
        pkixqualified   \
        pkixtsp         \
@@ -79,26 +106,40 @@ SUBDIRS = \
        rrc             \
        rrlp            \
        rtse            \
-       s4406           \
+       rua             \
+       s1ap            \
        sabp            \
+       sbc-ap          \
        smrse           \
        snmp            \
        spnego          \
+       sv              \
+       t124            \
        t125            \
        t38             \
        tcap            \
+       tetra           \
        ulp             \
        wlancertextn    \
-       x411            \
-       x420            \
+       x2ap            \
        x509af          \
        x509ce          \
        x509if          \
-       x509sat         \
+       x509sat
+
+# kerberos is a handwritten dissector, don't replace
+# x721 doesn't build
+DONT_BUILD_SUBDIRS = \
+       kerberos \
        x721
 
+DIST_SUBDIRS = $(SUBDIRS) $(DONT_BUILD_SUBDIRS)
+
 EXTRA_DIST = \
-       Makefile.nmake
+       Makefile.nmake  \
+       Makefile.inc.nmake      \
+       Makefile.preinc.nmake \
+       Custom.make
 
 MAINTAINERCLEANFILES = \
        Makefile.in