From e.yimjia via https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=9289 :
[metze/wireshark/wip.git] / asn1 / Makefile.am
index 89f5ef5031274da02ad2768ae5e147e40eb3980d..238c84514420e7600dcd7822772a9094fbd8c408 100644 (file)
 #
 # You should have received a copy of the GNU General Public License
 # along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA  02111-1307, USA.
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
 
 include Custom.make
 
-SUBDIRS =              \
+SUBDIRS =              \
        $(CUSTOM_SUBDIRS)       \
        acp133          \
        acse            \
        ansi_map        \
        ansi_tcap       \
+       atn-cm          \
+       atn-cpdlc       \
+       atn-ulcs        \
+       c1222           \
        camel           \
        cdt             \
        charging_ase    \
@@ -61,12 +65,17 @@ SUBDIRS =           \
        HI2Operations   \
        hnbap           \
        idmp            \
+       ilp             \
        inap            \
-       kerberos        \
+       isdn-sup        \
        lcsap           \
        ldap            \
        logotypecertextn \
+       lpp             \
+       lppa            \
+       lppe            \
        lte-rrc         \
+       m3ap            \
        mms             \
        mpeg-audio      \
        mpeg-pes        \
@@ -100,6 +109,7 @@ SUBDIRS =           \
        rua             \
        s1ap            \
        sabp            \
+       sbc-ap          \
        smrse           \
        snmp            \
        spnego          \
@@ -115,9 +125,16 @@ SUBDIRS =          \
        x509af          \
        x509ce          \
        x509if          \
-       x509sat         \
+       x509sat
+
+# kerberos is a handwritten dissector, don't replace
+# x721 doesn't build
+DONT_BUILD_SUBDIRS = \
+       kerberos \
        x721
 
+DIST_SUBDIRS = $(SUBDIRS) $(DONT_BUILD_SUBDIRS)
+
 EXTRA_DIST = \
        Makefile.nmake  \
        Makefile.inc.nmake      \