Avoid adding -pie on older cmake versions
[metze/wireshark/wip.git] / Vagrantfile
1 # -*- mode: ruby -*-
2 # vi: set ft=ruby :
3
4 # Vagrantfile API/syntax version. Don't touch unless you know what you're doing!
5 VAGRANTFILE_API_VERSION = "2"
6
7 Vagrant.configure(VAGRANTFILE_API_VERSION) do |config|
8
9   # Base box is Ubuntu 14.04
10   config.vm.box = "ubuntu/trusty64"
11
12   # Bump the default resources as building is expensive
13   config.vm.provider "virtualbox" do |v|
14     v.memory = 1024
15     v.cpus = 2
16   end
17
18   # Permit X11 forwarding so running the graphical Wireshark works
19   config.ssh.forward_x11 = true
20
21   # Install and build the various things (including wireshark!)
22   config.vm.provision :shell, path: 'vagrant_provision.sh'
23   config.vm.provision :shell, path: 'vagrant_build.sh', privileged: false
24 end