a935bd846318beffa954a08270b2bf38235a50dd
[metze/wireshark/wip.git] / INSTALL
1 Installation
2 ============
3
4 These are installation instructions for Unix and Unix-like systems
5 that can run the "configure" script in this same directory. These
6 are not the installation instructions for Windows systems; see
7 README.win32 for those instructions.
8
9 0. This is alpha software.  Beware.
10
11 1. If you wish to build Ethereal, make sure you have GTK+ and GLIB
12     installed. Try running 'gtk-config --version' and
13     'glib-config --version' to see if you have them installed.
14     Ethereal needs versions 1.2.0 or above of both these packages.
15     If you need to install or re-install GTK+ or GLIB, you can find
16     the packages at:
17
18         http://www.gtk.org
19
20     If you installed GTK+ from a binary package, you may have to
21     install a "development" package; there may be separate "user's"
22     and "developer's" packages, with the former not including
23     header files and the like.  For example, Red Hat users will
24     need to install a "gtk-devel" .rpm.
25
26 2. If you wish to build Tethereal, the line-mode version of Ethereal,
27     make sure you have GLIB installed.  See note #1 above for instructions
28     on checking if you have GLIB installed. You can download GLIB from
29     the same site as GTK.
30
31 3. If you want to capture packets, make sure you have libpcap
32     installed.  The latest "official" version can be found at
33
34     http://www.tcpdump.org .
35
36     If you've downloaded the 0.5.2 version, make sure you install
37     the headers ('make install-incl') when you install the library.
38     The CVS snapshots will install the headers if you do 'make
39     install', and have no 'install-incl' target.
40
41     If you installed libpcap from a binary package, you may have to
42     install a "development" package; for example, there's
43     apparently a "libpcap0" Debian package, but it just includes a
44     shared library, a copyright notice, changelog files, and a
45     README file - you also need to install a "libpcap-dev" package
46     to get header files, a non-shared library, and the man page.
47     Similarly, Red Hat 5.x users will need to install a "libpcap-devel"
48     .rpm to go along with the "libpcap" .rpm.
49
50 4. Run './configure' in the Ethereal distribution directory.
51     Running './configure --help' displays a list of options.
52     The file 'INSTALL.configure' contains general instructions for
53     using 'configure' and 'make'. Ethereal has some non-generic configure 
54     options:
55
56     --sysconfdir=DIR
57         Ethereal installs a support file (manuf) in ${PREFIX}/etc by
58         default, where ${PREFIX} comes from --prefix=DIR. If you do not
59         specify any --prefix option, ${PREFIX} is "/usr/local".
60         You can change the location of the manuf file with the --sysconfdir
61         option.
62
63     --disable-usr-local
64         By default 'configure' will look in /usr/local/{include,lib} for
65         additional header files and libraries. Using this switch keeps
66         'configure' from looking there
67
68     --disable-ethereal
69         By default, if 'configure' finds the GTK+ libraries, the Makefile
70         build Ethereal, the GUI packet analyzer. You can disable the
71         build of the GUI version of Ethereal with this switch.
72
73     --enable-gtk2
74         Build Glib2/Gtk2+-based ethereal.
75
76     --disable-tethereal
77         By default the line-mode packet analyzer, Tethereal, is built.
78         Use this switch to avoid building it.
79
80     --disable-editcap
81         By default the capture-file editing program is built.
82         Use this switch to avoid building it.
83
84     --disable-mergecap
85         By default the capture-file merging program is built.
86         Use this switch to avoid building it.
87
88     --disable-text2pcap
89         By default the hex-dump-to-capture file conversion program
90         is built. Use this switch to avoid building it.
91
92     --disable-idl2eth
93         By default the IDL-to-ethereal-dissector-source-code converter
94         is built. Use this switch to avoid building it.
95
96     --enable-dftest
97         By default the display-filter-compiler test program is not built.
98         Use this switch to build it.
99
100     --enable-randpkt
101         By default the program which creates random packet-capture files
102         is not built. Use this switch to build it.
103
104     --without-pcap
105         If you choose to build a packet analyzer that can analyze
106         capture files but cannot capture packets on its own, but you
107         *do* have libpcap installed, or if you are trying to build
108         Ethereal on a system that doesn't have libpcap installed (in
109         which case you have no choice but to build a version that can
110         analyze capture files but cannot capture packets on its own),
111         use --without-pcap to avoid using libpcap.
112
113     --with-pcap=DIR
114         Use this to tell Ethereal where you have libpcap installed, if
115         it is installed in a non-standard location.
116
117     --without-zlib
118         By default, if 'configure' finds zlib (a.k.a, libz), the
119         wiretap library will be built so that it can read compressed
120         capture files. If you have zlib but do not wish to build
121         it into the wiretap library, used by Ethereal, Tethereal, and
122         the capture-file utilities that come in this package, use
123         this switch.
124
125     --with-zlib=DIR
126         Use this to tell Ethereal where you have zlib installed, if it
127         is installed in a non-standard location.
128
129     --disable-ipv6
130         If 'configure' finds support for IPv6 name resolution on
131         your system, the packet analyzers will make use of it.
132         To avoid using IPv6 name resolution if you have the support for it,
133         use this switch.
134
135     --enable-setuid-install
136         Use this switch to install the packet analyzers as setuid.
137         Installating Ethereal and Tethereal as setuid 'root' is
138         dangerous. Repeat: IT'S DANGEROUS. Don't do it.
139
140     --with-ssl=DIR
141         If your SNMP library needs the SSL library, and your
142         SSL library is installed in a non-standard location,
143         you can specify where your SSL library is with this switch.
144
145     --without-net-snmp
146         If 'configure' finds a supported version of the NET SNMP library
147         on your system,  the SNMP dissector will be enhanced to use
148         routines from that SNMP library. Use this switch to avoid
149         using the NET SNMP library even if you have it installed.
150
151     --with-net-snmp=PATH
152         Tell the 'configure' script where your net-snmp-config shell script 
153         that comes with the net-snmp package is located, if not in a standard 
154         location.
155
156     --without-ucdsnmp
157         If 'configure' finds a supported version of the UCD SNMP library
158         on your system,  the SNMP dissector will be enhanced to use
159         routines from that SNMP library. Use this switch to avoid
160         using the UCD SNMP library even if you have it installed.
161
162     --with-ucdsnmp=DIR
163         Tell the 'configure' script where your UCD SNMP library
164         is located, if not in a standard location.
165
166     --without-plugins
167         By default, if your system can support run-time loadable modules,
168         the packet analyzers are build with support for plugins.
169         Use this switcht to build packet analyzers without plugin support.
170
171     --with-plugins=DIR
172         By default, plugins are installed in
173         ${LIBDIR}/ethereal/plugins/${VERSION}
174
175         ${LIBDIR} can be set with --libdir, or defaults to ${EPREFIX/lib}
176         ${EPREFIX} can be set with --exec-prefix, or defaults to ${PREFIX}
177         ${VERSION} is the Etherael version.
178
179         Use this switch to change the location where plugins
180         are installed.
181
182 5. After running './configure', you will see a summary of some
183     of the options you chose. Ensure that the summary reflects
184     what you want. If it doesn't, re-run './configure' with new options.
185
186 6. Run 'make'.  Hopefully, you won't run into any problems.
187
188 7. Run './ethereal' or './tethereal', and make sure things are working.
189     You must have root privileges in order to capture live data.
190
191 8. Run 'make install'.  If you wish to install the man page, run
192     'make install-man'.  If you're running a system that supports
193     the Apt, RPM, or System V Release 4 packaging systems, you can
194     run one of
195
196     make debian-package # Builds a binary package using dpkg
197     make rpm-package    # Builds a binary package using rpm
198     make srpm-package   # Builds a source package using rpm
199     make svr4-package   # Builds a source package using pkgmk
200     make solaris-package        # Same as "make svr4-package"
201
202     to make an installable package for your system.
203
204 If you have trouble with the build or installation process, you can
205 find assistance on the ethereal-users and ethereal-dev mailing lists.
206 See http://www.ethereal.com/lists/ for details.
207