PPP: remove obsolete Van Jacobson decompression preference
[metze/wireshark/wip.git] / .travis.yml
1 language: cpp
2 sudo: required
3 dist: trusty
4 compiler:
5   - clang
6   - gcc
7 env:
8  - BUILD_CMAKE=no
9  - BUILD_CMAKE=yes
10 before_install:
11   - $CC --version
12   - sudo add-apt-repository --yes ppa:ubuntu-toolchain-r/test
13   - sudo apt-get update -qq
14     #libstdc++-4.8 is needed by Clang to build
15   - sudo apt-get -qq install libstdc++-4.8-dev
16   - sudo apt-get -qq build-dep wireshark
17   - sudo apt-get -qq install cmake libgtk-3-0 libglib2.0-0 libgdk-pixbuf2.0-0 libcairo2
18   - sudo apt-get -qq install qt5-default qttools5-dev qttools5-dev-tools
19   - $CC --version
20 before_script:
21   if [ ${BUILD_CMAKE} == "yes" ]; then mkdir build && cd build && cmake ..; else ./autogen.sh && ./configure ; fi
22 script:
23   - make