new version 1.0.51
[sahlberg/ctdb.git] / packaging / RPM / ctdb.spec
1 %define initdir %{_sysconfdir}/init.d
2
3 Summary: Clustered TDB
4 Vendor: Samba Team
5 Packager: Samba Team <samba@samba.org>
6 Name: ctdb
7 Version: 1.0
8 Release: 51
9 Epoch: 0
10 License: GNU GPL version 3
11 Group: System Environment/Daemons
12 URL: http://ctdb.samba.org/
13
14 Source: ctdb-%{version}.tar.gz
15
16 Prereq: /sbin/chkconfig /bin/mktemp /usr/bin/killall
17 Prereq: fileutils sed /etc/init.d
18
19 Provides: ctdb = %{version}
20
21 Prefix: /usr
22 BuildRoot: %{_tmppath}/%{name}-%{version}-root
23
24 %description
25 ctdb is the clustered database used by samba
26
27
28 #######################################################################
29
30 %prep
31 %setup -q
32 # setup the init script and sysconfig file
33 %setup -T -D -n ctdb-%{version} -q
34
35 %build
36
37 CC="gcc"
38
39 ## always run autogen.sh
40 ./autogen.sh
41
42 CFLAGS="$RPM_OPT_FLAGS $EXTRA -O0 -D_GNU_SOURCE -DCTDB_VERS=\"%{version}-%{release}\"" ./configure \
43         --prefix=%{_prefix} \
44         --sysconfdir=%{_sysconfdir} \
45         --mandir=%{_mandir} \
46         --localstatedir="/var"
47
48 make showflags
49 make   
50
51 %install
52 # Clean up in case there is trash left from a previous build
53 rm -rf $RPM_BUILD_ROOT
54
55 # Create the target build directory hierarchy
56 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
57 mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/init.d
58
59 make DESTDIR=$RPM_BUILD_ROOT install
60
61 install -m644 config/ctdb.sysconfig $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/ctdb
62 install -m755 config/ctdb.init $RPM_BUILD_ROOT%{initdir}/ctdb
63
64 # Remove "*.old" files
65 find $RPM_BUILD_ROOT -name "*.old" -exec rm -f {} \;
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %post
71 [ -x /sbin/chkconfig ] && /sbin/chkconfig --add ctdb
72
73 %preun
74 if [ $1 = 0 ] ; then
75     [ -x /sbin/chkconfig ] && /sbin/chkconfig --del ctdb
76 fi
77 exit 0
78
79 %postun
80 if [ "$1" -ge "1" ]; then
81         %{initdir}/ctdb restart >/dev/null 2>&1 || true
82 fi      
83
84
85 #######################################################################
86 ## Files section                                                     ##
87 #######################################################################
88
89 %files
90 %defattr(-,root,root)
91
92 %config(noreplace) %{_sysconfdir}/sysconfig/ctdb
93 %config(noreplace) %{_sysconfdir}/ctdb/functions
94 %attr(755,root,root) %{initdir}/ctdb
95
96 %{_docdir}/ctdb/README.eventscripts
97 %{_sysconfdir}/ctdb/events.d/00.ctdb
98 %{_sysconfdir}/ctdb/events.d/10.interface
99 %{_sysconfdir}/ctdb/events.d/40.vsftpd
100 %{_sysconfdir}/ctdb/events.d/41.httpd
101 %{_sysconfdir}/ctdb/events.d/50.samba
102 %{_sysconfdir}/ctdb/events.d/60.nfs
103 %{_sysconfdir}/ctdb/events.d/61.nfstickle
104 %{_sysconfdir}/ctdb/events.d/70.iscsi
105 %{_sysconfdir}/ctdb/events.d/90.ipmux
106 %{_sysconfdir}/ctdb/events.d/91.lvs
107 %{_sysconfdir}/ctdb/statd-callout
108 %{_sbindir}/ctdbd
109 %{_bindir}/ctdb
110 %{_bindir}/smnotify
111 %{_bindir}/ctdb_ipmux
112 %{_bindir}/ctdb_diagnostics
113 %{_bindir}/onnode
114 %{_mandir}/man1/ctdb.1.gz
115 %{_mandir}/man1/ctdbd.1.gz
116 %{_mandir}/man1/onnode.1.gz
117 %{_includedir}/ctdb.h
118 %{_includedir}/ctdb_private.h
119
120 %changelog
121 * Mon Jul 28 2008 : Version 1.0.51
122  - Strip off the vlan tag from bond devices before we check in /proc
123    if the interface is up or not.
124  - Use testparm in the background in the scripts to allow probing
125    that the shares do exist.
126  - Fix a bug in the logging code to handle multiline entries better
127  - Rename private elements from private to private_data
128 * Fri Jul 18 2008 : Version 1.0.50
129  - Dont assume that just because we can establish a TCP connection
130    that we are actually talking to a functioning ctdb daemon.
131    So dont mark the node as CONNECTED just because the tcp handshake
132    was successful.
133  - Dont try to set the recmaster to ourself during elections for those
134    cases we know this will fail. To remove some annoying benign but scary
135    looking entries from the log.
136  - Bugfix for eventsystem for signal handling that could cause a node to
137    hang.
138 * Thu Jul 17 2008 : Version 1.0.49
139  - Update the safe persistent update fix to work with unpatched samba
140    servers.
141 * Thu Jul 17 2008 : Version 1.0.48
142  - Update the spec file.
143  - Do not start new user-triggered eventscripts if we are already
144    inside recovery mode.
145  - Add two new controls to start/cancel a persistent update.
146    A client such as samba can use these to tell ctdbd that it will soon
147    be writing directly to the persistent database tdb file. So if
148    samba is -9ed before it has eitehr done the persistent_store or
149    canceled the operation, ctdb knows that the persistent databases
150    'may' be out of sync and therefore a full blown recovery is called for.
151  - Add two new options :
152    CTDB_SAMBA_SKIP_CONF_CHECK and CTDB_SAMBA_CHECK_PORTS that can be used
153    to override what checks to do when monitoring samba health.
154    We can no longer use the smbstatus, net or testparm commands to check
155    if samba or its config is healthy since these commands may block
156    indefinitely and thus can not be used in scripts.
157 * Fri Jul 11 2008 : Version 1.0.47
158  - Fix a double free bug where if a user striggered (ctdb eventscript)
159    hung and while the timeout handler was being processed a new user
160    triggered eventscript was started we would free state twice.
161  - Rewrite of onnode and associated documentation.
162 * Thu Jul 10 2008 : Version 1.0.46
163  - Document both the LVS:cingle-ip-address and the REMOTE-NODE:wan-accelerator
164    capabilities.
165  - Add commands "ctdb pnn", "ctdb lvs", "ctdb lvsmaster".
166  - LVS improvements. LVS is the single-ip-address mode for a ctdb cluster.
167  - Fixes to supress rpmlint warnings
168  - AXI compile fixes.
169  - Change \s to [[:space:]] in some scripts. Not all RHEL5 packages come
170    with a egrep that handles \s   even same version but different arch.
171  - Revert the change to NFS restart. CTDB should NOT attempt to restart
172    failed services.
173  - Rewrite of the waitpid() patch to use the eventsystem for handling
174    signals.
175 * Tue Jul 8 2008 : Version 1.0.45
176  - Try to restart the nfs service if it has failed to respond 3 times in a row.
177  - waitpid() can block if the child does not respond promptly to SIGTERM.
178    ignore all SIGCHILD signals by setting SIGCHLD to SIG_DEF.
179    get rid of all calls to waitpid().
180  - make handling of eventscripts hanging more liberal.
181    only consider the script to have failed and making the node unhealthy
182    IF the eventscript terminated wiht an error
183    OR the eventscript hung 5 or more times in a row
184 * Mon Jul 7 2008 : Version 1.0.44
185  - Add a CTDB_VALGRIND option to /etc/sysconfig/ctdb to make it start
186    ctdb under valgrind. Logs go to /var/log/ctdb_valgrind.PID
187  - Add a hack to show the control opcode that caused uninitialized data
188    in the valgrind output by encoding the opcode as the line number.
189  - Initialize structures and allocated memory in various places in
190    ctdb to make it valgrind-clean and remove all valgrind errors/warnings.
191  - If/when we destroy a lockwait child, also make sure we cancel any pending transactions
192  - If a transaction_commit fails, delete/cancel any pending transactions and
193    return an error instead of calling ctdb_fatal()
194  - When running ctdb under valgrind, make sure we run it with --nosetsched and also
195    ensure that we do not use mem-mapped i/o when accessing the tdb's.
196  - zero out ctdb->freeze_handle when we free/destroy a freeze-child.
197    This prevent a heap corruption/ctdb crash bug that could trigger
198    if the freeze child times out.
199  - we dont need to explicitely thaw the databases from the recovery daemon
200    since this is done implicitely when we restore the recovery mode back to normal.
201  - track when we start and stop a recovery. Add the 'time it took to complete the
202    recovery' to the 'ctdb uptime' output.
203    Ensure by tracking the start/stop recovery timestamps that we do not
204    check that the ip allocation is consistend from inside the recovery daemon
205    while a different node (recovery master) is performing a recovery.
206    This prevent a race that could cause a full recovery to trigger if the
207    'ctdb disable/enable' commands took very long.
208  - The freeze child indicates to the master daemon that all databases are locked
209    by writing data to the pipe shared with the master daemon.
210    This write sometimes fail and thus the master daemon never notices that the databases
211    are locked cvausing long timeouts and extra recoveries.
212    Check that the write is successful and try the write again if it failed.
213  - In each node, verify that the recmaster have the right node flags for us
214    and force a push of our flags to the recmaster if wrong.
215 * Tue Jul 1 2008 : Version 1.0.43
216  - Updates and bugfixes to the specfile to keep rpmlint happy
217  - Force a global flags update after each recovery event.
218  - Verify that the recmaster agrees with our node flags and update the
219    recmaster othervise.
220  - When writing back to the parent from a freeze-child across the pipe,
221    loop over the write in case the write failed with an error  othervise
222    the parent will never be notified tha the child has completed the operation.
223  - Automatically thaw all databases when recmaster marks us as being in normal
224    mode instead of recovery mode.
225 * Fri Jun 13 2008 : Version 1.0.42
226  - When event scripts have hung/timedout more than EventScriptBanCount times
227    in a row the node will ban itself.
228  - Many updates to persistent write tests and the test scripts.
229 * Wed May 28 2008 : Version 1.0.41
230  - Reactivate the safe writes to persistent databases and solve the
231    locking issues. Locking issues are solved the only possible way,
232    by using a child process to do the writes.  Expensive and slow but... . 
233 * Tue May 27 2008 : Version 1.0.40
234  - Read the samba sysconfig file from the 50.samba eventscript
235  - Fix some emmory hierarchical bugs in the persistent write handling
236 * Thu May 22 2008 : Version 1.0.39
237  - Moved a CTDB_MANAGES_NFS, CTDB_MANAGES_ISCSI and CTDB_MANAGES_CSFTPD
238    into /etc/sysconfig/ctdb
239  - Lowered some debug messages to not fill the logfile with entries
240    that normally occur in the default configuration.
241 * Fri May 16 2008 : Version 1.0.38
242  - Add machine readable output support to "ctdb getmonmode"
243  - Lots of tweaks and enhancements if the event scripts are "slow"
244  - Merge from tridge: an attempt to break the chicken-and-egg deadlock that
245    net conf introduces if used from an eventscript.
246  - Enhance tickles so we can tickle an ipv6 connection.
247  - Start adding ipv6 support : create a new container to replace sockaddr_in.
248  - Add a checksum routine for ipv6/tcp
249  - When starting up ctdb, let the init script do a tdbdump on all
250    persistent databases and verify that they are good (i.e. not corrupted).
251  - Try to use "safe transactions" when writing to a persistent database
252    that was opened with the TDB_NOSYNC flag. If we can get the transaction
253    thats great, if we cant  we have to write anyway since we cant block here.
254 * Mon May 12 2008 : Version 1.0.37
255  - When we shutdown ctdb we close the transport down before we run the 
256    "shutdown" eventscripts. If ctdb decides to send a packet to a remote node
257    after we have shutdown the transport but before we have shutdown ctdbd
258    itself this could lead to a SEGV instead of a clean shutdown. Fix.
259  - When using the "exportfs" command to extract which NFS export directories
260    to monitor,  exportfs violates the "principle of least surprise" and
261    sometimes report a single export line as two lines of text output
262    causing the monitoring to fail.
263 * Fri May 9 2008 : Version 1.0.36
264  - fix a memory corruption bug that could cause the recovery daemon to crash.
265  - fix a bug with distributing public ip addresses during recovery.
266    If the node that is the recovery master did NOT use public addresses,
267    then it assumed that no other node in the cluster used them either and
268    thus skipped the entire step of reallocating public addresses.
269 * Wed May 7 2008 : Version 1.0.35
270  - During recovery, when we define the new set of lmasters (vnnmap)
271    only consider those nodes that have the can-be-lmaster capability
272    when we create the vnnmap. unless there are no nodes available which
273    supports this capability in which case we allow the recmaster to
274    become lmaster capable (temporarily).
275  - Extend the async framework so that we can use paralell async calls
276    to controls that return data.
277  - If we do not have the "can be recmaster" capability, make sure we will
278    lose any recmaster elections, unless there are no nodes available that
279    have the capability, in which case we "take/win" the election anyway.
280  - Close and reopen the reclock pnn file at regular intervals.
281    Make it a non-fatal event if we occasionally fail to open/read/write
282    to this file.
283  - Monitor that the recovery daemon is still running from the main ctdb
284    daemon and shutdown the main daemon when recovery daemon has terminated.
285  - Add a "ctdb getcapabilities" command to read the capabilities off a node.
286  - Define two new capabilities : can be recmaster and can be lmaster
287    and default both capabilities to YES.
288  - Log denied tcp connection attempts with DEBUG_ERR and not DEBUG_WARNING
289 * Thu Apr 24 2008 : Version 1.0.34
290  - When deleting a public ip from a node, try to migrate the ip to a different
291    node first.
292  - Change catdb to produce output similar to tdbdump
293  - When adding a new public ip address, if this ip does not exist yet in
294    the cluster, then grab the ip on the local node and activate it.
295  - When a node disagrees with the recmaster on WHO is the recmaster, then
296    mark that node as a recovery culprit so it will eventually become
297    banned.
298  - Make ctdb eventscript support the -n all argument.
299 * Thu Apr 10 2008 : Version 1.0.33
300  - Add facilities to include site local adaptations to the eventscript
301    by /etc/ctdb/rc.local which will be read by all eventscripts.
302  - Add a "ctdb version" command.
303  - Secure the domain socket with proper permissions from Chris Cowan
304  - Bugfixes for AIX from Chris Cowan
305 * Wed Apr 02 2008 : Version 1.0.32
306  - Add a control to have a node execute the eventscripts with arbitrary
307    command line arguments.
308  - Add a control "rddumpmemory" that will dump the talloc memory allocations
309    for the recovery daemon.
310  - Decorate the talloc memdump to produce better and easier memory leak
311    tracking. 
312  - Update the RHEL5 iscsi tgtd scripts to allow one iscsi target for each
313    public address.
314  - Add two new controls "addip/delip" that can be used to add/remove public
315    addresses to a node at runtime. After using these controls a "ctdb recover"
316    ir required to make the changes take.
317  - Fix a couple of slow memory leaks.
318 * Tue Mar 25 2008 : Version 1.0.31
319  - Add back controls to disable/enable monitoring on a node.
320  - Fix a memory leak where we used to attach CALL data to the ctdb structure
321    when performing a local call. Memory which would be lost if the call was
322    aborted.
323  - Reduce the loglevel for the log output when someone connects to a non
324    public ip address for samba.
325  - Redo and optimize the vacuuming process to send only one control to each
326    other node containing all records to be vacuumed instead of one
327    control per node per record.
328 * Tue Mar 04 2008 : Version 1.0.30
329  - Update documentation cor new commands and tuneables
330  - Add machinereadable output to the ip,uptime and getdebug commands
331  - Add a moveip command to manually failover/failback public ips
332  - Add NoIPFallback tuneable that prevents ip address failback
333  - Use file locking inside the CFS as alternative to verify when other nodes
334    Are connected/disconnected to be able to recover from split network
335  - Add DisableWhenUnhealthy tunable
336  - Add CTDB_START_AS_DISABLED sysconfig param
337  - Add --start-as-disabled flag to ctdb
338  - Add ability to monitor for OOM condition
339 * Thu Feb 21 2008 : Version 1.0.29
340  - Add a new command to make expansion of an existing cluster easier
341  - Fix bug with references to freed objects in the ctdb structure
342  - Propagate debuglevel changes to the recovery daemon
343  - Merge patches to event scripts from Mathieu Parent :
344  - MP: Simulate "service" on systems which do not provide this tool
345  - MP: Set correct permissions for events.d/README
346  - Add nice helper functions to start/stop nfs from the event scripts
347 * Fri Feb 08 2008 : Version 1.0.28
348  - Fix a problem where we tried to use ethtool on non-ethernet interfaces
349  - Warn if the ipvsadm packege is missing when LVS is used
350  - Dont use absolute pathnames in some of the event scripts
351  - Fix for persistent tdbs growing inifinitely.
352 * Wed Feb 06 2008 : Version 1.0.27
353  - Add eventscript for iscsi
354 * Thu Jan 31 2008 : Version 1.0.26
355  - Fix crashbug in tdb transaction code
356 * Tue Jan 29 2008 : Version 1.0.25
357  - added async recovery code
358  - make event scripts more portable
359  - fixed ctdb dumpmemory
360  - more efficient tdb allocation code
361  - improved machine readable ctdb status output
362  - added ctdb uptime
363 * Wed Jan 16 2008 : Version 1.0.24
364  - added syslog support
365  - documentation updates
366 * Wed Jan 16 2008 : Version 1.0.23
367  - fixed a memory leak in the recoveryd
368  - fixed a corruption bug in the new transaction code
369  - fixed a case where an packet for a disconnected client could be processed
370  - added http event script
371  - updated documentation
372 * Thu Jan 10 2008 : Version 1.0.22
373  - auto-run vacuum and repack ops
374 * Wed Jan 09 2008 : Version 1.0.21
375  - added ctdb vacuum and ctdb repack code
376 * Sun Jan 06 2008 : Version 1.0.20
377  - new transaction based recovery code
378 * Sat Jan 05 2008 : Version 1.0.19
379  - fixed non-master bug
380  - big speedup in recovery for large databases
381  - lots of changes to improve tdb and ctdb for high churn databases
382 * Thu Dec 27 2007 : Version 1.0.18
383  - fixed crash bug in monitor_handler
384 * Tue Dec 04 2007 : Version 1.0.17
385  - fixed bugs related to ban/unban of nodes
386  - fixed a race condition that could lead to monitoring being permanently disabled,
387    which would lead to long recovery times
388  - make deterministic IPs the default
389  - fixed a bug related to continuous recovery 
390  - added a debugging option --node-ip